summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-07 17:16:13 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-07 17:16:13 +0000
commitcadd337fc1d3ee1afad4b4f74dbd36bfcb1f7b29 (patch)
tree5c9a2c36a9ba619074fee037613affc01b2d1b14 /net-analyzer/sbd/sbd-1.37-r1.ebuild
parentDrop amd64 check with USE=win64 now that it is in x86 use.mask. (diff)
downloadhistorical-cadd337fc1d3ee1afad4b4f74dbd36bfcb1f7b29.tar.gz
historical-cadd337fc1d3ee1afad4b4f74dbd36bfcb1f7b29.tar.bz2
historical-cadd337fc1d3ee1afad4b4f74dbd36bfcb1f7b29.zip
Respect LDFLAGS (bug #336241). Respect upstream CFLAGS for warnings.
Package-Manager: portage-2.2_rc77/cvs/Linux i686
Diffstat (limited to 'net-analyzer/sbd/sbd-1.37-r1.ebuild')
-rw-r--r--net-analyzer/sbd/sbd-1.37-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/sbd/sbd-1.37-r1.ebuild b/net-analyzer/sbd/sbd-1.37-r1.ebuild
new file mode 100644
index 000000000000..a3104da409c9
--- /dev/null
+++ b/net-analyzer/sbd/sbd-1.37-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sbd/sbd-1.37-r1.ebuild,v 1.1 2010/09/07 17:16:13 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Netcat-clone, designed to be portable and offer strong encryption"
+HOMEPAGE="http://tigerteam.se/dl/sbd/"
+SRC_URI="http://tigerteam.se/dl/sbd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e '/ -o /{
+ s| $(UNIX_LDFLAGS) $(LDFLAGS)||g;s|$(CFLAGS)|& $(LDFLAGS)|g
+ }' \
+ || die "sed Makefile"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ unix || die "emake failed"
+}
+
+src_install() {
+ dobin sbd || die "dobin failed"
+ dodoc CHANGES README || die "dodoc failed"
+}