summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-04-21 01:00:59 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-04-21 01:00:59 +0000
commitbd02629db96a8ee56e37b06e0b9347881ad5f739 (patch)
treee0358f898339875d795227861bca0987c04b9205 /net-analyzer/cnet/files
parentVersion bump #130598 by Conrad Kostecki. (diff)
downloadhistorical-bd02629db96a8ee56e37b06e0b9347881ad5f739.tar.gz
historical-bd02629db96a8ee56e37b06e0b9347881ad5f739.tar.bz2
historical-bd02629db96a8ee56e37b06e0b9347881ad5f739.zip
2.0.10 version bump for bug 130634, thanks to Kesara Rathnayake <kesara at bcs dot org>.
Package-Manager: portage-2.0.54
Diffstat (limited to 'net-analyzer/cnet/files')
-rw-r--r--net-analyzer/cnet/files/cnet-2.0.10-gentoo.patch96
-rw-r--r--net-analyzer/cnet/files/digest-cnet-2.0.101
-rw-r--r--net-analyzer/cnet/files/digest-cnet-2.0.51
3 files changed, 97 insertions, 1 deletions
diff --git a/net-analyzer/cnet/files/cnet-2.0.10-gentoo.patch b/net-analyzer/cnet/files/cnet-2.0.10-gentoo.patch
new file mode 100644
index 000000000000..24c4a51a9731
--- /dev/null
+++ b/net-analyzer/cnet/files/cnet-2.0.10-gentoo.patch
@@ -0,0 +1,96 @@
+diff --exclude='*~' -Naur cnet-2.0.10.orig/Makefile cnet-2.0.10/Makefile
+--- cnet-2.0.10.orig/Makefile 2006-04-20 21:54:40.000000000 -0300
++++ cnet-2.0.10/Makefile 2006-04-20 21:54:54.000000000 -0300
+@@ -7,14 +7,14 @@
+ # It is presumed that BINDIR and MANDIR exist, so you may need
+ # to create them, and set their permissions, if necessary.
+ #
+-PREFIX = /usr/local
++PREFIX = /usr/
+ #
+ BINDIR = $(PREFIX)/bin
+-CNETDIR = $(PREFIX)/cnetlib
+-MANDIR = $(PREFIX)/man/man1
++CNETDIR = $(PREFIX)/lib/cnetlib
++MANDIR = $(PREFIX)/share/man/man1
+ MANEXT = 1
+ MANFILE = $(MANDIR)/$(NAME).$(MANEXT)
+-WEBDIR = /home/httpd/html/cnet
++WEBDIR = $(CNETDIR)/html
+
+ # ---------------------------------------------------------------------
+
+diff --exclude='*~' -Naur cnet-2.0.10.orig/Makefile.orig cnet-2.0.10/Makefile.orig
+--- cnet-2.0.10.orig/Makefile.orig 1969-12-31 21:00:00.000000000 -0300
++++ cnet-2.0.10/Makefile.orig 2006-03-06 16:03:14.000000000 -0300
+@@ -0,0 +1,46 @@
++NAME = cnet
++VERSION = 2.0.10
++SHELL = /bin/sh
++#
++# Change the following 5 constants to suit your local site.
++#
++# It is presumed that BINDIR and MANDIR exist, so you may need
++# to create them, and set their permissions, if necessary.
++#
++PREFIX = /usr/local
++#
++BINDIR = $(PREFIX)/bin
++CNETDIR = $(PREFIX)/cnetlib
++MANDIR = $(PREFIX)/man/man1
++MANEXT = 1
++MANFILE = $(MANDIR)/$(NAME).$(MANEXT)
++WEBDIR = /home/httpd/html/cnet
++
++# ---------------------------------------------------------------------
++
++it:
++ (cd src && make)
++
++install:
++ (cd src && make)
++ cp $(NAME) $(BINDIR)/$(NAME) && chmod 755 $(BINDIR)/$(NAME)
++ mkdir -p $(CNETDIR) && chmod 755 $(CNETDIR)
++ cp cnetlib/* $(CNETDIR) && chmod 644 $(CNETDIR)/*
++ cp DOC/$(NAME).man $(MANFILE) && chmod 644 $(MANFILE)
++
++web:
++ mkdir -p $(WEBDIR) && chmod 755 $(WEBDIR)
++ mkdir -p $(WEBDIR)/images && chmod 755 $(WEBDIR)/images
++ cp DOC/*.* $(WEBDIR)
++ cp DOC/images/* $(WEBDIR)/images
++ chmod 644 $(WEBDIR)/*.* $(WEBDIR)/images/*
++
++# ---------------------------------------------------------------------
++
++clean:
++ (cd src && make clean)
++ (cd DOC && make clean)
++ (cd EXAMPLES && make clean)
++
++uninstall:
++ rm -rf $(BINDIR)/$(NAME) $(MANFILE) $(CNETDIR) $(WEBDIR)
+diff --exclude='*~' -Naur cnet-2.0.10.orig/src/config.h cnet-2.0.10/src/config.h
+--- cnet-2.0.10.orig/src/config.h 2006-04-20 21:54:40.000000000 -0300
++++ cnet-2.0.10/src/config.h 2006-04-20 21:54:55.000000000 -0300
+@@ -169,7 +169,7 @@
+ #if defined(USE_FREEBSD)
+ #define CNETPATH "/usr/local/share/cnet:/usr/local/include:/usr/local/cnetlib"
+ #else
+-#define CNETPATH "/usr/local/cnetlib:/usr/lib/cnet:/cslinux/cnetlib"
++#define CNETPATH "/usr/lib/cnetlib:/usr/lib/cnet:"
+ #endif
+
+
+diff --exclude='*~' -Naur cnet-2.0.10.orig/src/Makefile.linux cnet-2.0.10/src/Makefile.linux
+--- cnet-2.0.10.orig/src/Makefile.linux 2006-04-20 21:54:40.000000000 -0300
++++ cnet-2.0.10/src/Makefile.linux 2006-04-20 21:54:55.000000000 -0300
+@@ -29,7 +29,7 @@
+ ANSICC = gcc -ansi
+ INCLUDES = $(LIBELFINC)
+
+-CFLAGS = -O -Wall -fPIC $(INCLUDES) $(XINCLUDES)
++CFLAGS = -march=pentium3 -O3 -pipe -fPIC $(INCLUDES) $(XINCLUDES)
+
+ LD = gcc -rdynamic
+ LIBDIRS = -L/usr/X11R6/lib $(XLIBDIRS) $(LIBELFDIR)
diff --git a/net-analyzer/cnet/files/digest-cnet-2.0.10 b/net-analyzer/cnet/files/digest-cnet-2.0.10
new file mode 100644
index 000000000000..345e0228cb04
--- /dev/null
+++ b/net-analyzer/cnet/files/digest-cnet-2.0.10
@@ -0,0 +1 @@
+MD5 c1db7aad3b0379599b3ab0e9b61625d9 cnet-2.0.10.tgz 1158887
diff --git a/net-analyzer/cnet/files/digest-cnet-2.0.5 b/net-analyzer/cnet/files/digest-cnet-2.0.5
deleted file mode 100644
index 0315d4d804c3..000000000000
--- a/net-analyzer/cnet/files/digest-cnet-2.0.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 851b6935691fe08e58de40434f782b51 cnet-2.0.5.tgz 1150005