summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-04-29 04:30:54 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-04-29 04:30:54 +0000
commit30c0b3fc940a8ab3086c8e02f1dd812aba474edd (patch)
tree3737b5400f046b28d37d58e15b763649f25d1937 /media-video
parentSmall fix to the description text. (diff)
downloadhistorical-30c0b3fc940a8ab3086c8e02f1dd812aba474edd.tar.gz
historical-30c0b3fc940a8ab3086c8e02f1dd812aba474edd.tar.bz2
historical-30c0b3fc940a8ab3086c8e02f1dd812aba474edd.zip
The -r1 version of the ebuild with updates by lostlogic@lostlogicx.com
(Brandon Low) (closes bug #2161).
Diffstat (limited to 'media-video')
-rw-r--r--media-video/em8300-libraries/ChangeLog9
-rw-r--r--media-video/em8300-libraries/em8300-libraries-0.12.0-r1.ebuild71
-rw-r--r--media-video/em8300-libraries/files/digest-em8300-libraries-0.12.0-r11
3 files changed, 80 insertions, 1 deletions
diff --git a/media-video/em8300-libraries/ChangeLog b/media-video/em8300-libraries/ChangeLog
index 7529d8b514be..c8ceb5757aad 100644
--- a/media-video/em8300-libraries/ChangeLog
+++ b/media-video/em8300-libraries/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/em8300-libraries
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/ChangeLog,v 1.1 2002/04/23 02:54:25 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/ChangeLog,v 1.2 2002/04/29 04:30:54 agenkin Exp $
+
+*em8300-libraries-0.12.0-r1 (April 29, 2002)
+
+ 29 April 2002; Arcady Genkin <agenkin@thpoon.com> em8300-libraries-0.12.0-r1 :
+
+ Further updates by Brandon Low. Fixed some issues in microcode upload
+ script.
*em8300-libraries-0.12.0 (April 22, 2002)
diff --git a/media-video/em8300-libraries/em8300-libraries-0.12.0-r1.ebuild b/media-video/em8300-libraries/em8300-libraries-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..c30b77059d7e
--- /dev/null
+++ b/media-video/em8300-libraries/em8300-libraries-0.12.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Brandon Low <lostlogic@lostlogicx.com>
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/em8300-libraries-0.12.0-r1.ebuild,v 1.1 2002/04/29 04:30:54 agenkin Exp $
+
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card libraries"
+HOMEPAGE="http://dxr3.sourceforge.net"
+
+SRC_URI="http://prdownloads.sourceforge.net/dxr3/${P/-libraries/}.tar.gz"
+
+DEPEND="media-video/em8300-modules
+ x11-libs/gtk+"
+
+S="${WORKDIR}/${P}"
+
+src_unpack () {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ mv ${A/.tar.gz/} ${P}
+
+}
+
+src_compile () {
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --datadir=/usr/share || die
+ make all || die
+
+}
+
+src_install () {
+
+ cd ${S}/scripts
+ mv microcode_upload.pl microcode_upload.pl.old
+ sed -e "s:/usr/share/misc/em8300.uc:/usr/share/em8300/em8300.uc:g" \
+ < microcode_upload.pl.old > microcode_upload.pl
+ rm microcode_upload.pl.old
+ cd ${S}
+
+ make em8300incdir=${D}/usr/include/linux/ \
+ prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ sysconfdir=/etc \
+ oldincludedir=${D}/usr/include \
+ install || die
+
+ insinto /usr/share/em8300
+ doins modules/em8300.uc
+
+ #this isn't how the installer does this, but it makes more
+ #sense than copying it like they do.
+ dosym /usr/share/em8300/microcode_upload.pl /usr/bin/em8300init
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "The em8300 libraries and modules have now beein installed,"
+ einfo "you will probably want to add /usr/bin/em8300init to your"
+ einfo "/etc/conf.d/local.start so that your em8300 card is "
+ einfo "properly initialized on boot."
+ einfo
+ einfo "If you still need a microcode other than the one included"
+ einfo "with the package, you can simply use em8300init <microcode.ux>"
+ einfo
+
+}
diff --git a/media-video/em8300-libraries/files/digest-em8300-libraries-0.12.0-r1 b/media-video/em8300-libraries/files/digest-em8300-libraries-0.12.0-r1
new file mode 100644
index 000000000000..9230beec12f8
--- /dev/null
+++ b/media-video/em8300-libraries/files/digest-em8300-libraries-0.12.0-r1
@@ -0,0 +1 @@
+MD5 720a5dfba76789321ba6d7e0f8e1ecbe em8300-0.12.0.tar.gz 374843