summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2005-11-21 19:04:09 +0000
committerHanno Boeck <hanno@gentoo.org>2005-11-21 19:04:09 +0000
commit4e783e6d69176dd442fb2edbce81f9103b91989d (patch)
tree9bd2b91ffddf8121246869265bb39c3b20b64e7c /media-video/thoggen/thoggen-0.4.1.ebuild
parentSmall cleanup. This version require >=wxGTK-2.6.2 (diff)
downloadhistorical-4e783e6d69176dd442fb2edbce81f9103b91989d.tar.gz
historical-4e783e6d69176dd442fb2edbce81f9103b91989d.tar.bz2
historical-4e783e6d69176dd442fb2edbce81f9103b91989d.zip
thoggen version bump
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'media-video/thoggen/thoggen-0.4.1.ebuild')
-rw-r--r--media-video/thoggen/thoggen-0.4.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-video/thoggen/thoggen-0.4.1.ebuild b/media-video/thoggen/thoggen-0.4.1.ebuild
new file mode 100644
index 000000000000..9c9337f28e28
--- /dev/null
+++ b/media-video/thoggen/thoggen-0.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/thoggen/thoggen-0.4.1.ebuild,v 1.1 2005/11/21 19:04:09 hanno Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="DVD ripper, based on GStreamer and Gtk+"
+HOMEPAGE="http://thoggen.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dts"
+
+DEPEND=">=dev-libs/glib-2.6.0
+ >=x11-libs/gtk+-2.6.0
+ >=gnome-base/libglade-2.4.0
+ >=media-libs/gstreamer-0.8.9
+ >=media-libs/gst-plugins-0.8.8
+ >=media-plugins/gst-plugins-mpeg2dec-0.8.8
+ >=media-plugins/gst-plugins-a52dec-0.8.8
+ >=media-plugins/gst-plugins-dvdread-0.8.8
+ >=media-plugins/gst-plugins-theora-0.8.8
+ >=media-plugins/gst-plugins-vorbis-0.8.8
+ >=media-plugins/gst-plugins-ogg-0.8.8
+ dts? ( >=media-plugins/gst-plugins-dts-0.8.8 )
+ >=sys-apps/dbus-0.23
+ >=sys-apps/hal-0.4
+ >=media-libs/libdvdread-0.9.4"
+
+pkg_setup() {
+ if ! built_with_use sys-apps/dbus gtk; then
+ eerror "Please merge sys-apps/dbus with 'gtk' in USE flags."
+ die "Need glib support in dbus!"
+ fi
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+# needed to get around some sandboxing checks
+export GST_INSPECT=/bin/true