summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-10-06 15:04:04 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-10-06 15:04:04 +0000
commitdabb235156642693e8dc45d5b449608a83e50436 (patch)
treef72c49b9fde7f1fae0bd748a07db10dc034abd13 /media-video/super_demux/super_demux-0.3.ebuild
parentRemoved obsolete versions. (diff)
downloadhistorical-dabb235156642693e8dc45d5b449608a83e50436.tar.gz
historical-dabb235156642693e8dc45d5b449608a83e50436.tar.bz2
historical-dabb235156642693e8dc45d5b449608a83e50436.zip
initial commit.
Package-Manager: portage-2.1.3.11
Diffstat (limited to 'media-video/super_demux/super_demux-0.3.ebuild')
-rw-r--r--media-video/super_demux/super_demux-0.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-video/super_demux/super_demux-0.3.ebuild b/media-video/super_demux/super_demux-0.3.ebuild
new file mode 100644
index 000000000000..738485b1463c
--- /dev/null
+++ b/media-video/super_demux/super_demux-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/super_demux/super_demux-0.3.ebuild,v 1.1 2007/10/06 15:04:03 sbriesen Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+IUSE=""
+
+DESCRIPTION="DVB transport stream TS to ES demultiplexer"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}.diff"
+}
+
+src_compile() {
+ append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin super_demux
+ dodoc CHANGES README
+}