summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-25 15:15:00 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-25 15:15:00 +0000
commit11947bd2c846b5ab9d9eb47b58afa978b9e72485 (patch)
tree94b13cd2d134c7115000e5511b09a049c8218b12 /media-video/mpeg-tools
parentMarked stable on hppa. (diff)
downloadhistorical-11947bd2c846b5ab9d9eb47b58afa978b9e72485.tar.gz
historical-11947bd2c846b5ab9d9eb47b58afa978b9e72485.tar.bz2
historical-11947bd2c846b5ab9d9eb47b58afa978b9e72485.zip
Closing #38951.
Diffstat (limited to 'media-video/mpeg-tools')
-rw-r--r--media-video/mpeg-tools/ChangeLog8
-rw-r--r--media-video/mpeg-tools/Manifest9
-rw-r--r--media-video/mpeg-tools/files/mpeg-tools-1.5b-64bit_fixes.patch201
-rw-r--r--media-video/mpeg-tools/mpeg-tools-1.5b-r1.ebuild14
4 files changed, 221 insertions, 11 deletions
diff --git a/media-video/mpeg-tools/ChangeLog b/media-video/mpeg-tools/ChangeLog
index f983c6d14e01..42e716f7aafa 100644
--- a/media-video/mpeg-tools/ChangeLog
+++ b/media-video/mpeg-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/mpeg-tools
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg-tools/ChangeLog,v 1.6 2003/11/07 18:54:45 azarah Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg-tools/ChangeLog,v 1.7 2004/02/25 15:14:59 aliz Exp $
+
+ 25 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> mpeg-tools-1.5b-r1.ebuild:
+ Add patch with 64bit fixes and other cleanups by Mikael Rosbacke
+ <rosbacke@nada.kth.se> in #38951.
*mpeg-tools-1.5b-r1 (07 Nov 2003)
diff --git a/media-video/mpeg-tools/Manifest b/media-video/mpeg-tools/Manifest
index 45cf93e3d2d6..47aeb854c274 100644
--- a/media-video/mpeg-tools/Manifest
+++ b/media-video/mpeg-tools/Manifest
@@ -1,9 +1,10 @@
-MD5 da62d77b7a45aa8a1c5da459947e44f6 ChangeLog 1022
MD5 6d1443c5797003ac437cab0ed90af9b0 mpeg-tools-1.5b.ebuild 1112
-MD5 087c0930f8d77aa3ef3709f5dbea695b mpeg-tools-1.5b-r1.ebuild 1228
+MD5 74a79aee2801cdc3518887e8985cbf9a mpeg-tools-1.5b-r1.ebuild 1335
+MD5 531830462f8cd68debebb342086163ed ChangeLog 1199
MD5 bf748902484902bcc7eb4e616a8d04dd files/digest-mpeg-tools-1.5b-r1 73
MD5 bf748902484902bcc7eb4e616a8d04dd files/digest-mpeg-tools-1.5b 73
-MD5 1f0b9c5d21516dc0b597bdd8563a7e39 files/1.5b/libpnmrw.h 6791
-MD5 ee6ac6a97ef340aecff643f24bc2f02c files/1.5b/mpeg-tools-1.5b-gentoo.patch 560
+MD5 c2a255a517528ad380ddb47264c34c58 files/mpeg-tools-1.5b-64bit_fixes.patch 5849
MD5 b45f0ebe9bad10888b67ac1d1475c0d4 files/1.5b/mpeg-tools-1.5b-fix-exit-call.patch 464
MD5 1c465916c02ad5e984eefda8b236fbc9 files/1.5b/libpnmrw.c 37348
+MD5 1f0b9c5d21516dc0b597bdd8563a7e39 files/1.5b/libpnmrw.h 6791
+MD5 ee6ac6a97ef340aecff643f24bc2f02c files/1.5b/mpeg-tools-1.5b-gentoo.patch 560
diff --git a/media-video/mpeg-tools/files/mpeg-tools-1.5b-64bit_fixes.patch b/media-video/mpeg-tools/files/mpeg-tools-1.5b-64bit_fixes.patch
new file mode 100644
index 000000000000..1f693e311a90
--- /dev/null
+++ b/media-video/mpeg-tools/files/mpeg-tools-1.5b-64bit_fixes.patch
@@ -0,0 +1,201 @@
+diff -urN work.orig/convert/eyuvtojpeg.c work/convert/eyuvtojpeg.c
+--- work.orig/convert/eyuvtojpeg.c 1995-04-14 23:16:52.000000000 +0200
++++ work/convert/eyuvtojpeg.c 2004-01-21 21:19:20.463187922 +0100
+@@ -22,6 +22,7 @@
+ /*==============*
+ * HEADER FILES *
+ *==============*/
++#include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <malloc.h>
+@@ -43,7 +44,7 @@
+ void AllocYCC(void);
+
+
+-void main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ FILE *fpointer;
+ char command[256];
+@@ -105,6 +106,7 @@
+ fprintf(stdout, "Converting to JPEG %s\n", dest);
+ sprintf(command, "cjpeg /tmp/foobar > %s", dest);
+ system(command);
++ return 0;
+ }
+
+
+diff -urN work.orig/convert/eyuvtoppm.c work/convert/eyuvtoppm.c
+--- work.orig/convert/eyuvtoppm.c 1995-04-14 23:16:52.000000000 +0200
++++ work/convert/eyuvtoppm.c 2004-01-21 21:19:20.463187922 +0100
+@@ -22,6 +22,7 @@
+ /*==============*
+ * HEADER FILES *
+ *==============*/
++#include <string.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <malloc.h>
+@@ -43,7 +44,7 @@
+ void AllocYCC(void);
+
+
+-void main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ FILE *fpointer;
+ char src[256], dest[256];
+@@ -109,7 +110,7 @@
+
+ WritePPM(fpointer);
+ fclose(fpointer);
+-
++ return 0;
+ }
+
+ void Usage(void)
+diff -urN work.orig/convert/mtv/archdep.h work/convert/mtv/archdep.h
+--- work.orig/convert/mtv/archdep.h 1995-01-24 23:42:33.000000000 +0100
++++ work/convert/mtv/archdep.h 2004-01-21 21:19:20.464187759 +0100
+@@ -45,16 +45,46 @@
+ ((char *)(to))[5] = ((char *)(from))[2]; \
+ ((char *)(to))[6] = ((char *)(from))[1]; \
+ ((char *)(to))[7] = ((char *)(from))[0];
+-#endif /*little-endian*/
++#endif /*little-endian 32bit*/
++
++#if defined (__x86_64)
++#define DECODE_SHORT(from, to) \
++ ((char *)(to))[0] = ((char *)(from))[1]; \
++ ((char *)(to))[1] = ((char *)(from))[0];
++#define DECODE_INT(from, to) \
++ ((char *)(to))[0] = ((char *)(from))[3]; \
++ ((char *)(to))[1] = ((char *)(from))[2]; \
++ ((char *)(to))[2] = ((char *)(from))[1]; \
++ ((char *)(to))[3] = ((char *)(from))[0];
++
++#define DECODE_LONG(from, to) \
++ ((char *)(to))[0] = ((char *)(from))[7]; \
++ ((char *)(to))[1] = ((char *)(from))[6]; \
++ ((char *)(to))[2] = ((char *)(from))[5]; \
++ ((char *)(to))[3] = ((char *)(from))[4]; \
++ ((char *)(to))[4] = ((char *)(from))[3]; \
++ ((char *)(to))[5] = ((char *)(from))[2]; \
++ ((char *)(to))[6] = ((char *)(from))[1]; \
++ ((char *)(to))[7] = ((char *)(from))[0];
++
++#define DECODE_FLOAT(from, to) DECODE_INT((to), (from))
++
++#define DECODE_DOUBLE(from, to) DECODE_LONG((to), (from))
++
++#endif /*little-endian, 64bit*/
+
+
+ /* Most architectures are symmetrical with respect to conversions. */
+-#if defined (mc68000) || defined (sparc) || defined (i386)
++#if defined (mc68000) || defined (sparc) || defined (i386) || defined(__x86_64)
+ #define ENCODE_SHORT(from, to) DECODE_SHORT((from), (to))
+ #define ENCODE_LONG(from, to) DECODE_LONG((from), (to))
+ #define ENCODE_FLOAT(from, to) DECODE_FLOAT((from), (to))
+ #define ENCODE_DOUBLE(from, to) DECODE_DOUBLE((from), (to))
+
++#if defined(__x86_64)
++#define ENCODE_INT(from, to) DECODE_INT((from), (to))
++#endif
++
+ /* Define types of specific length */
+ typedef char i_8;
+ typedef short i_16;
+diff -urN work.orig/convert/mtv/movieToVid.c work/convert/mtv/movieToVid.c
+--- work.orig/convert/mtv/movieToVid.c 1995-01-24 23:42:33.000000000 +0100
++++ work/convert/mtv/movieToVid.c 2004-01-21 21:19:20.465187595 +0100
+@@ -295,7 +295,7 @@
+ exit (0);
+ }
+
+-void
++int
+ main (argc, argv)
+ int argc;
+ char **argv;
+@@ -326,4 +326,5 @@
+ WriteScriptFile (argv[1], argv[2], argv[3], argv[4],
+ &header, offsets, numFrames);
+ fprintf (stderr, "done\n");
++ return 0;
+ }
+diff -urN work.orig/convert/ppmtoeyuv.c work/convert/ppmtoeyuv.c
+--- work.orig/convert/ppmtoeyuv.c 1995-01-20 04:25:37.000000000 +0100
++++ work/convert/ppmtoeyuv.c 2004-01-21 21:19:20.462188086 +0100
+@@ -39,6 +39,7 @@
+ * HEADER FILES *
+ *==============*/
+
++#include <malloc.h>
+ #include <stdio.h>
+ #include "ansi.h"
+
+@@ -65,7 +66,7 @@
+ static void PPMtoYUV _ANSI_ARGS_((void));
+
+
+-void main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ if ( ! ReadPPM(stdin) )
+ {
+@@ -76,6 +77,7 @@
+ PPMtoYUV();
+
+ WriteYUV(stdout);
++ return 0;
+ }
+
+
+diff -urN work.orig/mpeg_encode/bitio.c work/mpeg_encode/bitio.c
+--- work.orig/mpeg_encode/bitio.c 1995-06-21 20:36:12.000000000 +0200
++++ work/mpeg_encode/bitio.c 2004-01-21 21:19:20.458188741 +0100
+@@ -79,6 +79,8 @@
+ * HEADER FILES *
+ *==============*/
+
++#include <unistd.h>
++#include <time.h>
+ #include <assert.h>
+ #include "all.h"
+ #include "byteorder.h"
+diff -urN work.orig/mpeg_encode/jpeg.c work/mpeg_encode/jpeg.c
+--- work.orig/mpeg_encode/jpeg.c 1995-08-05 01:35:07.000000000 +0200
++++ work/mpeg_encode/jpeg.c 2004-01-21 21:19:20.461188250 +0100
+@@ -65,6 +65,8 @@
+ *==============*/
+
+ #include <stdio.h>
++#include <sys/types.h>
++#include <unistd.h>
+ #include "all.h"
+ #include "mtypes.h"
+ #include "frames.h"
+diff -urN work.orig/mpeg_encode/libpnmrw.c work/mpeg_encode/libpnmrw.c
+--- work.orig/mpeg_encode/libpnmrw.c 2004-01-21 19:41:38.000000000 +0100
++++ work/mpeg_encode/libpnmrw.c 2004-01-21 21:19:20.460188414 +0100
+@@ -27,6 +27,7 @@
+ /* #define MSDOS */
+ #endif
+
++#include <stdlib.h>
+ #include <stdio.h>
+ #include "libpnmrw.h"
+
+diff -urN work.orig/mpeg_encode/opts.c work/mpeg_encode/opts.c
+--- work.orig/mpeg_encode/opts.c 1995-08-15 20:34:09.000000000 +0200
++++ work/mpeg_encode/opts.c 2004-01-21 21:19:20.459188578 +0100
+@@ -35,6 +35,7 @@
+ * HEADER FILES *
+ *==============*/
+
++#include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include "opts.h"
diff --git a/media-video/mpeg-tools/mpeg-tools-1.5b-r1.ebuild b/media-video/mpeg-tools/mpeg-tools-1.5b-r1.ebuild
index e4eef942a25d..b78ac2ba9681 100644
--- a/media-video/mpeg-tools/mpeg-tools-1.5b-r1.ebuild
+++ b/media-video/mpeg-tools/mpeg-tools-1.5b-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg-tools/mpeg-tools-1.5b-r1.ebuild,v 1.1 2003/11/07 18:54:45 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpeg-tools/mpeg-tools-1.5b-r1.ebuild,v 1.2 2004/02/25 15:14:59 aliz Exp $
MY_PN=mpeg_encode
S=${WORKDIR}/${MY_PN}
@@ -12,17 +12,21 @@ DEPEND="virtual/x11"
SLOT="0"
LICENSE="BSD"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
src_unpack () {
- unpack ${A}
- cd ${S}
+ unpack ${A} ; cd ${S}
+
cp ${FILESDIR}/${PV}/libpnmrw.c .
cp ${FILESDIR}/${PV}/libpnmrw.h headers/
epatch ${FILESDIR}/${PV}/${P}-gentoo.patch
cd ${S}/../convert
# Fix exit() being called without arguments
epatch ${FILESDIR}/${PV}/${P}-fix-exit-call.patch
+
+ if [ "${ARCH}" == "amd64" ]; then
+ cd ${S}/../.. ; epatch ${FILESDIR}/${P}-64bit_fixes.patch
+ fi
}
src_compile() {