summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2007-01-16 14:51:57 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2007-01-16 14:51:57 +0000
commit3ec83d75051cb49018b64ef61d10ada482af694f (patch)
tree9a3921a46521e2746d30ccf55930b5945ea40155 /media-video/m2vrequantizer/m2vrequantizer-0.0.1.ebuild
parentPass parameters on from our script to the language-specific scripts. (diff)
downloadhistorical-3ec83d75051cb49018b64ef61d10ada482af694f.tar.gz
historical-3ec83d75051cb49018b64ef61d10ada482af694f.tar.bz2
historical-3ec83d75051cb49018b64ef61d10ada482af694f.zip
moved requant-0.0.1.ebuild to m2vrequantizer-0.0.1.ebuild; removed uneeded m2vrequantizer-20030925.ebuild
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'media-video/m2vrequantizer/m2vrequantizer-0.0.1.ebuild')
-rw-r--r--media-video/m2vrequantizer/m2vrequantizer-0.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-video/m2vrequantizer/m2vrequantizer-0.0.1.ebuild b/media-video/m2vrequantizer/m2vrequantizer-0.0.1.ebuild
new file mode 100644
index 000000000000..056170450602
--- /dev/null
+++ b/media-video/m2vrequantizer/m2vrequantizer-0.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/m2vrequantizer/m2vrequantizer-0.0.1.ebuild,v 1.1 2007/01/16 14:51:57 hd_brummy Exp $
+
+REQUANT="M2VRequantizer"
+REQUANT_VN="20030925"
+JAU_FILE="repackmpeg2-v0.9"
+
+DESCRIPTION="Tool to requantize/shrink mpeg2 videos"
+HOMEPAGE="http://www.jausoft.com"
+SRC_URI="mirror://vdrfiles/requant/${JAU_FILE}.tar.bz2"
+
+KEYWORDS="x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${JAU_FILE}
+
+src_unpack() {
+ unpack ${A}
+ tar xjf ${S}/${REQUANT}-${REQUANT_VN}.tar.bz2
+}
+
+src_compile() {
+
+ cd ${WORKDIR}/${REQUANT}-${REQUANT_VN}/src
+ gcc -c ${CFLAGS} main.c -o requant.o
+ gcc ${CFLAGS} requant.o -o requant -lm
+}
+
+src_install() {
+
+ dobin ${WORKDIR}/${REQUANT}-${REQUANT_VN}/src/requant
+}
+