summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-04-23 02:54:25 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-04-23 02:54:25 +0000
commitbeffeb0b6b491004894a035c72d36aaf940ca139 (patch)
treecbd8dfc9c3f30fd0894108f3522c75f9525164d4 /media-video/em8300-modules
parentupdate to 0.7.5 (diff)
downloadhistorical-beffeb0b6b491004894a035c72d36aaf940ca139.tar.gz
historical-beffeb0b6b491004894a035c72d36aaf940ca139.tar.bz2
historical-beffeb0b6b491004894a035c72d36aaf940ca139.zip
- Initial version of the em8300 packages, submitted by Brandon Low
<lostlogic@lostlogicx.com>. - I was unable to test these, since the -modules ebuild requires some kernel foo to be present, but the ebuilds look fine, and are long overdue. - Closes bugs #716 and #717.
Diffstat (limited to 'media-video/em8300-modules')
-rw-r--r--media-video/em8300-modules/ChangeLog9
-rw-r--r--media-video/em8300-modules/em8300-modules-0.12.0.ebuild77
-rw-r--r--media-video/em8300-modules/files/digest-em8300-modules-0.12.01
-rw-r--r--media-video/em8300-modules/files/modules.em83001
4 files changed, 88 insertions, 0 deletions
diff --git a/media-video/em8300-modules/ChangeLog b/media-video/em8300-modules/ChangeLog
new file mode 100644
index 000000000000..8f4693f6af87
--- /dev/null
+++ b/media-video/em8300-modules/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-video/em8300-modules
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.1 2002/04/23 02:54:25 agenkin Exp $
+
+*em8300-modules-0.12.0 (April 22, 2002)
+
+ 22 April 2002; Arcady Genkin <agenkin@thpoon.com> em8300-libraries-0.12.0 :
+
+ Initial version, submitted by Brandon Low <lostlogic@lostlogicx.com>. \ No newline at end of file
diff --git a/media-video/em8300-modules/em8300-modules-0.12.0.ebuild b/media-video/em8300-modules/em8300-modules-0.12.0.ebuild
new file mode 100644
index 000000000000..5e4c61a8ebff
--- /dev/null
+++ b/media-video/em8300-modules/em8300-modules-0.12.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Brandon Low <lostlogic@lostlogicx.com>
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.12.0.ebuild,v 1.1 2002/04/23 02:54:25 agenkin Exp $
+
+DESCRIPTION="em8300 video decoder card kernel modules"
+HOMEPAGE="http://dxr3.sourceforge.net"
+
+DEPEND="sys-kernel/linux-sources"
+
+S="${WORKDIR}/${P}"
+SRC_URI="http://prdownloads.sourceforge.net/dxr3/${P/-modules/}.tar.gz"
+
+
+src_unpack () {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ mv ${A/.tar.gz/} ${P}
+
+}
+
+src_compile () {
+
+ cd ${S}/modules
+ sed -e s/PAL/NTSC/g Makefile > makefile
+ mv makefile Makefile
+
+ [ "x${KV}" = x ] && die "You need to upgrade your portage."
+
+ #Make the em8300 makefile cooperate with our kernel version
+ sed -e s/..shell.uname.-r./${KV}/ Makefile > makefile
+ mv makefile Makefile
+ make clean all || die
+
+}
+
+src_install () {
+
+ insinto "/usr/src/linux/include/linux"
+ doins include/linux/em8300.h
+
+ # The driver goes into the standard modules location
+ insinto "/lib/modules/${KV}/kernel/drivers/video"
+ doins modules/em8300.o modules/bt865.o modules/adv717x.o
+
+ # Docs
+ dodoc modules/README-modoptions \
+ modules/README-modules.conf \
+ modules/devfs_symlinks
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/modules.em8300 em8300
+
+}
+
+pkg_postinst() {
+
+ if [ "${ROOT}" = "/" ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ [ -x /sbin/depmod ] && /sbin/depmod -a
+ fi
+
+ einfo
+ einfo "The em8300 kernel modules have been installed into the modules"
+ einfo "directory of your currently running kernel. They haven't been"
+ einfo "loaded. Please read the documentation, and if you would like"
+ einfo "to have the modules load at startup, add em8300, bt865, adv717x"
+ einfo "to your /etc/modules.autoload they may need module options to "
+ einfo "work correctly on your system. You will also need to add"
+ einfo "the contents of /usr/share/doc/em8300-0.12.0/devfs_symlinks"
+ einfo "to your devfsd.conf so that the em8300 devices will be linked"
+ einfo "correctly."
+ einfo
+
+}
diff --git a/media-video/em8300-modules/files/digest-em8300-modules-0.12.0 b/media-video/em8300-modules/files/digest-em8300-modules-0.12.0
new file mode 100644
index 000000000000..9230beec12f8
--- /dev/null
+++ b/media-video/em8300-modules/files/digest-em8300-modules-0.12.0
@@ -0,0 +1 @@
+MD5 720a5dfba76789321ba6d7e0f8e1ecbe em8300-0.12.0.tar.gz 374843
diff --git a/media-video/em8300-modules/files/modules.em8300 b/media-video/em8300-modules/files/modules.em8300
new file mode 100644
index 000000000000..d31c4d074d01
--- /dev/null
+++ b/media-video/em8300-modules/files/modules.em8300
@@ -0,0 +1 @@
+alias char-major-121 em8300