summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-01-01 04:21:00 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-01-01 04:21:00 +0000
commitabd0f6b503c3022389b47929f83e60f62072355d (patch)
tree5a1d86e457e1f6ac1d84976fc11b8a7af31566f9 /media-sound
parentAdded ladspa and soundtouch USE flag for media-sound/audacity. (diff)
downloadhistorical-abd0f6b503c3022389b47929f83e60f62072355d.tar.gz
historical-abd0f6b503c3022389b47929f83e60f62072355d.tar.bz2
historical-abd0f6b503c3022389b47929f83e60f62072355d.zip
Fixed various issues.
Package-Manager: portage-2.0.53
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacity/ChangeLog15
-rw-r--r--media-sound/audacity/Manifest5
-rw-r--r--media-sound/audacity/audacity-1.2.4b.ebuild90
-rw-r--r--media-sound/audacity/files/audacity-1.2.3-gcc41.patch12
-rw-r--r--media-sound/audacity/files/digest-audacity-1.2.4b1
5 files changed, 120 insertions, 3 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index be66fc8c555c..2457ca77e464 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for media-sound/audacity
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.37 2005/12/26 14:38:49 lu_zero Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.38 2006/01/01 04:21:00 matsuu Exp $
+
+*audacity-1.2.4b (01 Jan 2006)
+
+ 01 Jan 2006; MATSUU Takuto <matsuu@gentoo.org>
+ +files/audacity-1.2.3-gcc41.patch, +audacity-1.2.4b.ebuild:
+ Version Bumped, Bug 113948.
+ Restricted to wxGTK-2.4* with wxgtk1, Bug 100741.
+ Fixed gcc-4.1 compile issue, Bug 113754.
+ Fixed docs install issue, Bug 116615.
+ Removed gtk2 USE flag, Bug 106560.
+ Added ladspa, mp3 and soundtouch USE flag.
26 Dec 2005; Luca Barbato <lu_zero@gentoo.org> audacity-1.2.1.ebuild,
audacity-1.2.2.ebuild, audacity-1.2.3.ebuild, audacity-1.2.3-r1.ebuild:
diff --git a/media-sound/audacity/Manifest b/media-sound/audacity/Manifest
index 034c2f9787dd..03a86cc34d57 100644
--- a/media-sound/audacity/Manifest
+++ b/media-sound/audacity/Manifest
@@ -1,12 +1,15 @@
-MD5 5936cc91c3e410182ab1dc97f9716f46 ChangeLog 7232
+MD5 e2a974f1244fdf27b3eb314acba80b53 ChangeLog 7622
MD5 93c9059ec89a928748fbc4c6ff7ce950 audacity-1.2.1.ebuild 2263
MD5 2fa288b95d1713417e3342b869c83967 audacity-1.2.2.ebuild 2172
MD5 2d7b8330e198f9fc6f5727f293b13d49 audacity-1.2.3-r1.ebuild 1926
MD5 466b743fd1ead3cc85a21538f707d2aa audacity-1.2.3.ebuild 2175
+MD5 c7b795988ee39799680c03a81643908d audacity-1.2.4b.ebuild 2301
+MD5 8d8b48aa5931322a0a0a8ad826335c38 files/audacity-1.2.3-gcc41.patch 650
MD5 502eabf8993eb2af91e1265425024091 files/audacity-1.2.3-x86.patch 995
MD5 8332a9c72a43ed19ab1904a935a25e03 files/audacity.desktop 155
MD5 8f1e5073472cee2da1987db62e7db3a9 files/digest-audacity-1.2.1 72
MD5 a150eb16468631b07901c6ca01451679 files/digest-audacity-1.2.2 71
MD5 bf35b35e84d0c0be6fa8e87acf085294 files/digest-audacity-1.2.3 71
MD5 bf35b35e84d0c0be6fa8e87acf085294 files/digest-audacity-1.2.3-r1 71
+MD5 66713de531f00118315348503d7c52c1 files/digest-audacity-1.2.4b 72
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
diff --git a/media-sound/audacity/audacity-1.2.4b.ebuild b/media-sound/audacity/audacity-1.2.4b.ebuild
new file mode 100644
index 000000000000..664ebf0e4c8d
--- /dev/null
+++ b/media-sound/audacity/audacity-1.2.4b.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.2.4b.ebuild,v 1.1 2006/01/01 04:21:00 matsuu Exp $
+
+inherit wxwidgets eutils
+
+IUSE="encode flac ladspa libsamplerate mad mp3 soundtouch vorbis"
+
+MY_P="${PN}-src-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# amd64: causes xfce pannel to crash...
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="=x11-libs/wxGTK-2.4*
+ >=app-arch/zip-2.3
+ >=media-libs/libsndfile-1.0.0
+ media-libs/libid3tag
+ media-libs/portaudio
+ encode? ( >=media-sound/lame-3.92 )
+ flac? ( media-libs/flac )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12 )
+ libsamplerate? ( >=media-libs/libsamplerate-0.0.14 )
+ mad? ( >=media-libs/libmad-0.14.2b )
+ vorbis? ( >=media-libs/libvorbis-1.0 )"
+
+# nyquist? ( media-sound/nyquist )
+# portmixer? ( media-sound/portmixer )
+# resample? ( media-sound/libresample )
+# !resample? ( libsamplerate? ( >=media-libs/libsamplerate-0.0.14 ) )
+# soundtouch? ( media-libs/libsoundtouch )
+
+WX_GTK_VER="2.4"
+
+pkg_setup() {
+ if ! built_with_use '=x11-libs/wxGTK-2.4*' wxgtk1 ; then
+ eerror "${P} requires =x11-libs/wxGTK-2.4* emerged with USE='wxgtk1'"
+ die "${P} requires =x11-libs/wxGTK-2.4* emerged with USE='wxgtk1'"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2.3-x86.patch # bug 73248
+ epatch "${FILESDIR}"/${PN}-1.2.3-gcc41.patch # bug 113754
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --with-libsndfile=system"
+
+ need-wxwidgets gtk
+
+ econf \
+ $(use_with mad libmad system) \
+ $(use_with vorbis vorbis system) \
+ $(use_with flac libflac system) \
+ $(use_with libsamplerate samplerate system) \
+ $(use_with mp3 id3tag system) \
+ $(use_with soundtouch) \
+ ${myconf} || die
+
+ # parallel borks
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ # Remove bad doc install
+ rm -rf ${D}/usr/share/doc
+
+ # Install our docs
+ dodoc README.txt audacity-1.2-help.htb
+
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins images/AudacityLogo48x48.xpm audacity.xpm
+
+ make_desktop_entry audacity Audacity audacity
+}
diff --git a/media-sound/audacity/files/audacity-1.2.3-gcc41.patch b/media-sound/audacity/files/audacity-1.2.3-gcc41.patch
new file mode 100644
index 000000000000..5c703f5dfc7f
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.2.3-gcc41.patch
@@ -0,0 +1,12 @@
+diff -u audacity-src-1.2.3/lib-src/soundtouch/include/SoundTouch.h audacity-src-1.2.3/lib-src/soundtouch/include/SoundTouch.h.new
+--- audacity-src-1.2.3/lib-src/soundtouch/include/SoundTouch.h 2004-11-18 02:17:35.000000000 -0400
++++ audacity-src-1.2.3/lib-src/soundtouch/include/SoundTouch.h.new 2005-11-27 19:27:49.000000000 -0400
+@@ -146,7 +146,7 @@
+ static const char *getVersionString();
+
+ /// Get SoundTouch library version Id
+- static uint SoundTouch::getVersionId();
++ static uint getVersionId();
+
+ /// Sets new rate control value. Normal rate = 1.0, smaller values
+ /// represent slower rate, larger faster rates.
diff --git a/media-sound/audacity/files/digest-audacity-1.2.4b b/media-sound/audacity/files/digest-audacity-1.2.4b
new file mode 100644
index 000000000000..496c8a29c351
--- /dev/null
+++ b/media-sound/audacity/files/digest-audacity-1.2.4b
@@ -0,0 +1 @@
+MD5 37df5b6119302f7ab77ca16d25311756 audacity-src-1.2.4b.tar.gz 4499894