summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-02 02:17:13 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-02 02:17:13 +0000
commit5f7ea960332d2e46a02e0fe3a96780bca24a4f03 (patch)
treea2cb629022cb70ee914079eb6ed8142c5f949688 /media-sound
parentAdded dependencies (diff)
downloadhistorical-5f7ea960332d2e46a02e0fe3a96780bca24a4f03.tar.gz
historical-5f7ea960332d2e46a02e0fe3a96780bca24a4f03.tar.bz2
historical-5f7ea960332d2e46a02e0fe3a96780bca24a4f03.zip
Added dependencies
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.5.9a.ebuild7
-rw-r--r--media-sound/lame/lame-3.86b.ebuild6
-rw-r--r--media-sound/lopster/lopster-0.9.6.ebuild31
-rw-r--r--media-sound/mpg123/mpg123-0.59r.ebuild4
-rw-r--r--media-sound/sox/sox-12.17.ebuild4
5 files changed, 48 insertions, 4 deletions
diff --git a/media-sound/alsa-utils/alsa-utils-0.5.9a.ebuild b/media-sound/alsa-utils/alsa-utils-0.5.9a.ebuild
index 31ce3c52edd3..b2692a03081a 100644
--- a/media-sound/alsa-utils/alsa-utils-0.5.9a.ebuild
+++ b/media-sound/alsa-utils/alsa-utils-0.5.9a.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.5.9a.ebuild,v 1.2 2000/09/15 20:09:04 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.5.9a.ebuild,v 1.3 2000/11/02 02:17:12 achim Exp $
P=alsa-utils-0.5.9a
A=${P}.tar.bz2
@@ -10,6 +10,11 @@ DESCRIPTION="Advanced Linux Sound Architecture / Utils"
SRC_URI="ftp://ftp.alsa-project.org/pub/utils/"${A}
HOMEPAGE="http://www.alsa-project.org/"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1
+ >=media-libs/alsa-lib-0.5.9"
+
src_unpack() {
unpack ${A}
}
diff --git a/media-sound/lame/lame-3.86b.ebuild b/media-sound/lame/lame-3.86b.ebuild
index 28613653b1c4..7567f7eac64e 100644
--- a/media-sound/lame/lame-3.86b.ebuild
+++ b/media-sound/lame/lame-3.86b.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.86b.ebuild,v 1.3 2000/10/05 00:13:01 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.86b.ebuild,v 1.4 2000/11/02 02:17:12 achim Exp $
P=lame-3.86b
A=lame3.86beta.tar.gz
@@ -11,6 +11,10 @@ DESCRIPTION="LAME Ain't an Mp3 Encoder"
SRC_URI="http://lame.sourceforge.net/download/beta/${A}"
HOMEPAGE="http://www.sulaco.org/mp3/"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=dev-libs/glib-1.2.8
+ >=x11-libs/gtk+-1.2.8"
+
src_unpack () {
unpack ${A}
diff --git a/media-sound/lopster/lopster-0.9.6.ebuild b/media-sound/lopster/lopster-0.9.6.ebuild
new file mode 100644
index 000000000000..a2f545365295
--- /dev/null
+++ b/media-sound/lopster/lopster-0.9.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lopster/lopster-0.9.6.ebuild,v 1.1 2000/11/02 02:17:12 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Napster Client using GTK"
+SRC_URI="http://download.sourceforge.net/lopster/${A}"
+HOMEPAGE="http://lopster.sourceforge.net"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=dev-libs/glib-1.2.8
+ >=x11-libs/gtk+-1.2.8
+ >=x11-base/xfree-4.0.1"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING README ChangeLog NEWS
+}
+
diff --git a/media-sound/mpg123/mpg123-0.59r.ebuild b/media-sound/mpg123/mpg123-0.59r.ebuild
index 605c10c47e68..583aaf84b0ba 100644
--- a/media-sound/mpg123/mpg123-0.59r.ebuild
+++ b/media-sound/mpg123/mpg123-0.59r.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.59r.ebuild,v 1.3 2000/09/15 20:09:04 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.59r.ebuild,v 1.4 2000/11/02 02:17:13 achim Exp $
P=mpg123-0.59r
A=${P}.tar.gz
@@ -10,6 +10,8 @@ DESCRIPTION="Real Time mp3 player"
SRC_URI="http://www.mpg123.de/mpg123/${A}"
HOMEPAGE="http://www.mpg123.de/"
+DEPEND=">=sys-libs/glibc-2.1.3"
+
src_unpack () {
unpack ${A}
cd ${S}
diff --git a/media-sound/sox/sox-12.17.ebuild b/media-sound/sox/sox-12.17.ebuild
index 6f7a4acb77bc..ca4d85ee3f5a 100644
--- a/media-sound/sox/sox-12.17.ebuild
+++ b/media-sound/sox/sox-12.17.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-12.17.ebuild,v 1.2 2000/09/15 20:09:05 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-12.17.ebuild,v 1.3 2000/11/02 02:17:13 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,6 +9,8 @@ DESCRIPTION="The swiss army knife of sound processing programs"
SRC_URI="http://download.sourceforge.net/sox/${A}"
HOMEPAGE="http://home.sprynet.com/~cgabwell/sox.html"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=media-sound/alsa-driver-0.5.9"
src_compile() {