summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-03-08 12:23:34 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-03-08 12:23:34 +0000
commit5a27a76535a715bf60f0dc2809889bc6452a5998 (patch)
treecf93b2a4290ceed91a2965b45e1cb1611671f6a3 /media-sound
parentChanged ~sparc keywords to sparc (diff)
downloadhistorical-5a27a76535a715bf60f0dc2809889bc6452a5998.tar.gz
historical-5a27a76535a715bf60f0dc2809889bc6452a5998.tar.bz2
historical-5a27a76535a715bf60f0dc2809889bc6452a5998.zip
Correctly named MuSE ebuild. Really closes #13949.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/muse/ChangeLog11
-rw-r--r--media-sound/muse/files/digest-muse-0.7.21
-rw-r--r--media-sound/muse/muse-0.7.2.ebuild63
3 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/muse/ChangeLog b/media-sound/muse/ChangeLog
new file mode 100644
index 000000000000..82384042d5a7
--- /dev/null
+++ b/media-sound/muse/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-sound/muse
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muse/ChangeLog,v 1.1 2003/03/08 12:23:34 jje Exp $
+
+*muse-0.7.2 (08 Mar 2003)
+
+ 08 Mar 2003; jje <jje@gentoo.org> muse-0.7.2.ebuild:
+ Initial revision.
+
+ Submitted by Jaromil, Maurizio Disimino. Help from j2.
+
diff --git a/media-sound/muse/files/digest-muse-0.7.2 b/media-sound/muse/files/digest-muse-0.7.2
new file mode 100644
index 000000000000..f3b004662f99
--- /dev/null
+++ b/media-sound/muse/files/digest-muse-0.7.2
@@ -0,0 +1 @@
+MD5 dbeaf1f338fa004638ba1d719006a3ed MuSE-0.7.2.tar.gz 557168
diff --git a/media-sound/muse/muse-0.7.2.ebuild b/media-sound/muse/muse-0.7.2.ebuild
new file mode 100644
index 000000000000..68ce0da0a5f5
--- /dev/null
+++ b/media-sound/muse/muse-0.7.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/muse/muse-0.7.2.ebuild,v 1.1 2003/03/08 12:23:34 jje Exp $
+
+IUSE="ncurses oggvorbis X"
+
+S=${WORKDIR}/${P/muse/MuSE}
+
+DESCRIPTION="Multiple Streaming Engine, an icecast source streamer"
+SRC_URI="http://savannah.nongnu.org/download/muse/${P/muse/MuSE}.tar.gz"
+HOMEPAGE="http://muse.dyne.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ >=sys-apps/portage-2.0.45-r3
+ >=media-sound/lame-3.92
+ >=sys-apps/sed-4.0.5
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ oggvorbis? ( >=media-libs/libogg-1.0 >=media-libs/libvorbis-1.0-r1 )
+ X? ( =x11-libs/gtk+-1* )"
+
+RDEPEND="virtual/glibc
+ >=media-sound/lame-3.92
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ oggvorbis? ( >=media-libs/libogg-1.0 >=media-libs/libvorbis-1.0-r1 )
+ X? ( =x11-libs/gtk+-1* )"
+
+src_compile() {
+ local xcmd
+
+ # if media-libs/{libogg,libvorbis} are installed, the configure script
+ # will automatically enable oggvorbis support
+ if ! use oggvorbis; then
+ xcmd="s:\"\$have_\(ogg\|vorbis\)\":\"no\":;"
+ fi
+
+ # if sys-libs/ncurses is installed, the configure script will
+ # automatically build the ncurses GUI
+ if ! use ncurses; then
+ xcmd="$xcmd /^GUI_RUBIK/s:true:false:"
+ fi
+
+ [ "$xcmd" ] && sed -i "$xcmd" configure
+
+ econf `use_with X x` \
+ --disable-debug
+
+ emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die "Make failed"
+}
+
+src_install() {
+ dobin muse
+ dodoc AUTHORS ChangeLog NEWS README TODO USAGE
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You may want to have a look at /usr/share/doc/${PF}/USAGE.gz for more info."
+ einfo
+}