summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-13 08:59:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-13 08:59:41 +0000
commit4a55a39d901c23852701273c583bf41dc063d788 (patch)
tree44524bbe009a660e4820a65e55f7eb5504948830 /media-sound
parentamd64 stable wrt bug #234465 (diff)
downloadhistorical-4a55a39d901c23852701273c583bf41dc063d788.tar.gz
historical-4a55a39d901c23852701273c583bf41dc063d788.tar.bz2
historical-4a55a39d901c23852701273c583bf41dc063d788.zip
version bump
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/asunder/ChangeLog7
-rw-r--r--media-sound/asunder/asunder-1.6.ebuild29
-rw-r--r--media-sound/snd/ChangeLog7
-rw-r--r--media-sound/snd/snd-9.11.ebuild117
4 files changed, 158 insertions, 2 deletions
diff --git a/media-sound/asunder/ChangeLog b/media-sound/asunder/ChangeLog
index 5f2aa4b9585e..1517ac286c2f 100644
--- a/media-sound/asunder/ChangeLog
+++ b/media-sound/asunder/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/asunder
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/asunder/ChangeLog,v 1.15 2008/06/11 22:18:19 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/asunder/ChangeLog,v 1.16 2008/08/13 08:54:54 aballier Exp $
+
+*asunder-1.6 (13 Aug 2008)
+
+ 13 Aug 2008; Alexis Ballier <aballier@gentoo.org> +asunder-1.6.ebuild:
+ version bump
11 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
-files/asunder-1.0-desktop-entry.patch, -asunder-1.0.ebuild:
diff --git a/media-sound/asunder/asunder-1.6.ebuild b/media-sound/asunder/asunder-1.6.ebuild
new file mode 100644
index 000000000000..ab315f822256
--- /dev/null
+++ b/media-sound/asunder/asunder-1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/asunder/asunder-1.6.ebuild,v 1.1 2008/08/13 08:54:54 aballier Exp $
+
+DESCRIPTION="a graphical Audio CD ripper and encoder with support for WAV, MP3, OggVorbis and FLAC."
+HOMEPAGE="http://littlesvr.ca/asunder"
+SRC_URI="http://littlesvr.ca/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="flac mp3 vorbis wavpack"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.4
+ >=media-libs/libcddb-0.9.5
+ media-sound/cdparanoia"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+RDEPEND="${COMMON_DEPEND}
+ mp3? ( media-sound/lame )
+ vorbis? ( media-sound/vorbis-tools )
+ flac? ( media-libs/flac )
+ wavpack? ( media-sound/wavpack )"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/media-sound/snd/ChangeLog b/media-sound/snd/ChangeLog
index 8b8a73762801..450b62f1fdca 100644
--- a/media-sound/snd/ChangeLog
+++ b/media-sound/snd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/snd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.43 2008/07/12 08:41:32 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.44 2008/08/13 08:59:41 aballier Exp $
+
+*snd-9.11 (13 Aug 2008)
+
+ 13 Aug 2008; Alexis Ballier <aballier@gentoo.org> +snd-9.11.ebuild:
+ version bump
*snd-9.10 (12 Jul 2008)
diff --git a/media-sound/snd/snd-9.11.ebuild b/media-sound/snd/snd-9.11.ebuild
new file mode 100644
index 000000000000..349080e33eb3
--- /dev/null
+++ b/media-sound/snd/snd-9.11.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-9.11.ebuild,v 1.1 2008/08/13 08:59:41 aballier Exp $
+
+inherit multilib eutils versionator
+
+DESCRIPTION="Snd is a sound editor"
+HOMEPAGE="http://ccrma.stanford.edu/software/snd/"
+SRC_URI="ftp://ccrma-ftp.stanford.edu/pub/Lisp/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa cairo esd fam fftw gsl gtk guile jack ladspa motif nls opengl oss ruby xpm"
+
+RDEPEND="media-libs/audiofile
+ motif? ( x11-libs/openmotif )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ fam? ( virtual/fam )
+ fftw? ( sci-libs/fftw )
+ gsl? ( >=sci-libs/gsl-0.8 )
+ gtk? ( >=x11-libs/gtk+-2
+ opengl? ( x11-libs/gtkglext )
+ cairo? ( x11-libs/cairo ) )
+ guile? ( >=dev-scheme/guile-1.3.4 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( media-libs/ladspa-sdk )
+ nls? ( sys-devel/gettext )
+ opengl? ( virtual/opengl )
+ ruby? ( virtual/ruby )
+ xpm? ( x11-libs/libXpm )"
+
+#S=${WORKDIR}/${PN}-$(get_version_component_range 1)
+
+pkg_setup() {
+ if ! use gtk && ! use motif; then
+ ewarn "Warning: no graphic toolkit selected (gtk or motif)."
+ ewarn "Upstream suggests to enable one of the toolkits (or both)"
+ ewarn "or only the command line utilities will be helpful."
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use opengl; then
+ if use guile; then
+ myconf="${myconf} --with-gl"
+ else
+ myconf="${myconf} --with-just-gl"
+ fi
+ else
+ myconf="${myconf} --without-gl"
+ fi
+
+ econf \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with esd) \
+ $(use_with fam) \
+ $(use_with fftw) \
+ $(use_with gsl) \
+ $(use_with gtk) \
+ $(use_with guile) \
+ $(use_with jack) \
+ $(use_with ladspa) \
+ $(use_with motif) \
+ $(use_enable nls) \
+ $(use_with ruby) \
+ $(use_with cairo) \
+ $(use_with xpm) \
+ --with-float-samples \
+ ${myconf} || die
+
+ emake snd || die "emake snd failed"
+
+ # compiling command-line programs. See bug #112695
+ # do not compile ruby extensions for command line programs
+ # those fail to compile
+ if use ruby; then
+ econf \
+ $(use_with alsa) \
+ $(use_with esd) \
+ $(use_with fam) \
+ $(use_with fftw) \
+ $(use_with gsl) \
+ $(use_with gtk) \
+ $(use_with guile) \
+ $(use_with jack) \
+ $(use_with ladspa) \
+ $(use_with motif) \
+ $(use_enable nls) \
+ $(use_with xpm) \
+ --without-ruby \
+ --with-float-samples \
+ ${myconf} || die
+ fi
+
+ for i in sndrecord sndinfo audinfo sndplay; do
+ emake ${i} || die "make ${i} failed"
+ done
+}
+
+src_install () {
+ dobin snd
+ dobin sndplay
+ dobin sndrecord
+ dobin sndinfo
+ dobin audinfo
+
+ insinto /usr/$(get_libdir)/snd/scheme
+ doins *.scm
+
+ dodoc README.Snd HISTORY.Snd TODO.Snd Snd.ad
+ dohtml -r *.html *.png tutorial
+}