summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Cort <tcort@gentoo.org>2006-04-02 17:56:54 +0000
committerThomas Cort <tcort@gentoo.org>2006-04-02 17:56:54 +0000
commitfd0f775b29d4c8606c889015fa1ca5c1fbc28740 (patch)
treefa48a2e82a2aed1aeb8f351e0ff9a2988adf595e /media-sound/soundtracker/soundtracker-0.6.7-r1.ebuild
parentAdd ~x86-fbsd keyword. (diff)
downloadhistorical-fd0f775b29d4c8606c889015fa1ca5c1fbc28740.tar.gz
historical-fd0f775b29d4c8606c889015fa1ca5c1fbc28740.tar.bz2
historical-fd0f775b29d4c8606c889015fa1ca5c1fbc28740.zip
Added a patch to fix an invalid free thanks to Mark Aikens <marka@desert.cx>. Fixes Bug #91618.
Package-Manager: portage-2.0.54
Diffstat (limited to 'media-sound/soundtracker/soundtracker-0.6.7-r1.ebuild')
-rw-r--r--media-sound/soundtracker/soundtracker-0.6.7-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-sound/soundtracker/soundtracker-0.6.7-r1.ebuild b/media-sound/soundtracker/soundtracker-0.6.7-r1.ebuild
new file mode 100644
index 000000000000..77008531e63e
--- /dev/null
+++ b/media-sound/soundtracker/soundtracker-0.6.7-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/soundtracker-0.6.7-r1.ebuild,v 1.1 2006/04/02 17:56:54 tcort Exp $
+
+IUSE="nls esd gnome oss alsa jack"
+
+inherit eutils flag-o-matic
+
+S=${WORKDIR}/${P/_/-}
+
+DESCRIPTION="SoundTracker is a music tracking tool for UNIX/X11 (MOD tracker)"
+SRC_URI="http://www.soundtracker.org/dl/v0.6/${P/_/-}.tar.gz"
+HOMEPAGE="http://www.soundtracker.org"
+
+RDEPEND="sys-libs/zlib
+ =x11-libs/gtk+-1.2*
+ >=media-libs/audiofile-0.2.1
+ media-libs/libsndfile
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.7 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig
+ app-arch/bzip2
+ app-arch/gzip
+ app-arch/unzip"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-alsa1.patch
+ epatch ${FILESDIR}/${P}-invalid-free.patch
+}
+
+src_compile() {
+ replace-flags "-O3" "-O2"
+
+ local myconf
+
+ use oss || myconf="--disable-oss"
+ use esd || myconf="${myconf} --disable-esd"
+ use nls || myconf="${myconf} --disable-nls"
+ use alsa || myconf="${myconf} --disable-alsa"
+ use gnome || myconf="${myconf} --disable-gnome"
+ use x86 || myconf="${myconf} --disable-asm"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall || die "make install failed"
+ #borks make DESTDIR=${D} install || die "make install failed"
+
+ # strip suid from binary
+ chmod -s ${D}/usr/bin/soundtracker
+
+ # documentation
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO
+ dodoc doc/*.txt
+ dohtml -r doc
+}