summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-11 22:05:13 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-11 22:05:13 +0000
commit7b257f51ac8139cfad03831ed6e6b9d64a8131ee (patch)
tree3522a303d41141c68c70b18adcfdbede4cb7ce54 /media-sound/opmixer
parentunmasking 2.0.13 (diff)
downloadhistorical-7b257f51ac8139cfad03831ed6e6b9d64a8131ee.tar.gz
historical-7b257f51ac8139cfad03831ed6e6b9d64a8131ee.tar.bz2
historical-7b257f51ac8139cfad03831ed6e6b9d64a8131ee.zip
New package
Diffstat (limited to 'media-sound/opmixer')
-rw-r--r--media-sound/opmixer/ChangeLog10
-rw-r--r--media-sound/opmixer/files/digest-opmixer-0.751
-rw-r--r--media-sound/opmixer/opmixer-0.75.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/opmixer/ChangeLog b/media-sound/opmixer/ChangeLog
new file mode 100644
index 000000000000..d907705863ad
--- /dev/null
+++ b/media-sound/opmixer/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/opmixer
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-sound/opmixer/ChangeLog,v 1.1 2002/07/11 22:05:13 stroke Exp $
+
+*opmixer-0.75 (11 Jul 2002)
+
+ 11 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> opmixer-0.75.ebuild :
+
+ New package
+ Ebuild written by: Mattias Bengtsson <moonlite@linux.nu>
diff --git a/media-sound/opmixer/files/digest-opmixer-0.75 b/media-sound/opmixer/files/digest-opmixer-0.75
new file mode 100644
index 000000000000..33c53fbff654
--- /dev/null
+++ b/media-sound/opmixer/files/digest-opmixer-0.75
@@ -0,0 +1 @@
+MD5 1ae7fd4b7c710e314a3129ba40ce74db opMixer-0.75.tar.bz2 49638
diff --git a/media-sound/opmixer/opmixer-0.75.ebuild b/media-sound/opmixer/opmixer-0.75.ebuild
new file mode 100644
index 000000000000..3f517bfff04a
--- /dev/null
+++ b/media-sound/opmixer/opmixer-0.75.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/opmixer/opmixer-0.75.ebuild,v 1.1 2002/07/11 22:05:13 stroke Exp $
+
+DESCRIPTION="An oss mixer written in c++ using the gtkmm gui-toolkit. Supports saving, loading and muting of volumes for channels and autoloading via a consoleapp"
+HOMEPAGE="http://optronic.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="*"
+
+PKGVER=`echo ${P}|cut -d \- -f2`
+SRC_URI="http://optronic.sourceforge.net/files/opMixer-${PKGVER}.tar.bz2"
+
+S="${WORKDIR}/opMixer-${PKGVER}"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=x11-libs/gtkmm-1.2.2"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}