summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-01 20:08:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-01 20:08:42 +0000
commit0311f42cef41181bc47cd9c6a341a365bac0d530 (patch)
tree41ba494a46e8356436cf63734c280ec6836247c1 /media-sound/brutefir
parentRemoved old. (diff)
downloadhistorical-0311f42cef41181bc47cd9c6a341a365bac0d530.tar.gz
historical-0311f42cef41181bc47cd9c6a341a365bac0d530.tar.bz2
historical-0311f42cef41181bc47cd9c6a341a365bac0d530.zip
Version bump.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'media-sound/brutefir')
-rw-r--r--media-sound/brutefir/ChangeLog9
-rw-r--r--media-sound/brutefir/brutefir-1.0k.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/media-sound/brutefir/ChangeLog b/media-sound/brutefir/ChangeLog
index e2728343bfa6..5e28df632d4a 100644
--- a/media-sound/brutefir/ChangeLog
+++ b/media-sound/brutefir/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/brutefir
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/brutefir/ChangeLog,v 1.14 2007/08/25 18:27:27 beandog Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/brutefir/ChangeLog,v 1.15 2009/06/01 20:06:28 ssuominen Exp $
+
+*brutefir-1.0k (01 Jun 2009)
+
+ 01 Jun 2009; Samuli Suominen <ssuominen@gentoo.org> +brutefir-1.0k.ebuild:
+ Version bump.
25 Aug 2007; Steve Dibb <beandog@gentoo.org> brutefir-1.0i.ebuild:
amd64 stable
diff --git a/media-sound/brutefir/brutefir-1.0k.ebuild b/media-sound/brutefir/brutefir-1.0k.ebuild
new file mode 100644
index 000000000000..953d3b372509
--- /dev/null
+++ b/media-sound/brutefir/brutefir-1.0k.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/brutefir/brutefir-1.0k.ebuild,v 1.1 2009/06/01 20:06:28 ssuominen Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Software convolution engine for applying long FIR filters"
+HOMEPAGE="http://www.ludd.luth.se/~torger/brutefir.html"
+SRC_URI="http://www.ludd.luth.se/~torger/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake LD="$(tc-getLD)" CC="$(tc-getCC)" \
+ AS="$(tc-getAS)" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/lib/brutefir
+
+ einstall DESTDIR="${D}" INSTALL_PREFIX="${D}"/usr \
+ || die "einstall failed"
+
+ if [ "$(get_libdir)" != "lib" ]; then
+ mv "${D}"/usr/lib "${D}"/usr/$(get_libdir)
+ fi
+
+ dodoc CHANGES README
+
+ insinto usr/share/brutefir
+ doins xtc_config directpath.txt crosspath.txt massive_config \
+ bench1_config bench2_config bench3_config bench4_config bench5_config
+}
+
+pkg_postinst() {
+ elog "Brutefir is a complicated piece of software. Please"
+ elog "read the documentation first! You can find"
+ elog "documentation here: http://www.ludd.luth.se/~torger/brutefir.html"
+ elog "Example config files are in /usr/share/brutefir"
+}