summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-20 17:52:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-20 17:52:06 +0000
commit8388b3c6d043294ed7934a09c7f917f07483d387 (patch)
treef0396ebe0adbfcb9f23cafe0f5f1c99feb7da380 /media-sound/amsynth/amsynth-1.2.0.ebuild
parentApplied the MAKEOPTS fix to version 0.35.4 to resolve issues with parallel ma... (diff)
downloadhistorical-8388b3c6d043294ed7934a09c7f917f07483d387.tar.gz
historical-8388b3c6d043294ed7934a09c7f917f07483d387.tar.bz2
historical-8388b3c6d043294ed7934a09c7f917f07483d387.zip
Add a check for midi USE flag on alsa-lib needed to build, thanks to Patrick for reporting in bug #216890. Also add a patch to build with GCC 4.3.
Package-Manager: portage-2.1.5_rc5
Diffstat (limited to 'media-sound/amsynth/amsynth-1.2.0.ebuild')
-rw-r--r--media-sound/amsynth/amsynth-1.2.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/media-sound/amsynth/amsynth-1.2.0.ebuild b/media-sound/amsynth/amsynth-1.2.0.ebuild
index 3f5c9920ae4f..1b157c3c91c5 100644
--- a/media-sound/amsynth/amsynth-1.2.0.ebuild
+++ b/media-sound/amsynth/amsynth-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.2.0.ebuild,v 1.3 2008/01/14 12:50:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.2.0.ebuild,v 1.4 2008/04/20 17:52:06 flameeyes Exp $
IUSE="debug alsa jack sndfile oss"
@@ -26,6 +26,15 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build Fluidsynth with ALSA support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -33,6 +42,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-asneeded.patch"
epatch "${FILESDIR}/${P}-cflags.patch"
epatch "${FILESDIR}/${P}-debug.patch"
+ epatch "${FILESDIR}/${P}+gcc-4.3.patch"
eautoreconf
}