summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-23 14:32:53 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-23 14:32:53 +0000
commitfcf7a93ddd8f1c80a0ec8ed0f868e5d73372a777 (patch)
tree6c146124ba27fabdc423eb412563f63dec98de12 /media-sound/alsa-driver
parentAdding PDE fix. Closes #29965 & dupex. (diff)
downloadhistorical-fcf7a93ddd8f1c80a0ec8ed0f868e5d73372a777.tar.gz
historical-fcf7a93ddd8f1c80a0ec8ed0f868e5d73372a777.tar.bz2
historical-fcf7a93ddd8f1c80a0ec8ed0f868e5d73372a777.zip
Adding PDE fix. Closes #29965 & dupex.
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/Manifest8
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.7-r4.ebuild93
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-0.9.7-pde.patch16
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.7-r41
4 files changed, 114 insertions, 4 deletions
diff --git a/media-sound/alsa-driver/Manifest b/media-sound/alsa-driver/Manifest
index fa49bb9eaeae..091f05a3cdd3 100644
--- a/media-sound/alsa-driver/Manifest
+++ b/media-sound/alsa-driver/Manifest
@@ -1,9 +1,9 @@
-MD5 38ef046e384b73d1fcd53b0edd12b6e2 ChangeLog 9887
+MD5 88cf3104d8060c23d9004a0b6b9d5efb ChangeLog 10083
MD5 a0d2f9e64f89d3fea2a09767bb1eb6a2 alsa-driver-0.5.12a.ebuild 1663
MD5 ca02c9ed0add3aefaa8c0a5368750fc3 alsa-driver-0.9.0_rc2.ebuild 2655
MD5 cc589e7d9e700047214372dbe1eb3917 alsa-driver-0.9.2.ebuild 2686
-MD5 2bd58a41f590d1f7825bff114b49b60a configure.in.org 36836
-MD5 546d0c4ad29ecbbe255df7679ce3f248 alsa-driver-0.9.7-r4.ebuild 2418
+MD5 0e0616bbe59ee249bf652ed244815f52 alsa-driver-0.9.7-r3.ebuild 2336
+MD5 b70c6d0ad531424e224bf45669700a9c alsa-driver-0.9.7-r4.ebuild 2418
MD5 183fef94ef21e2fce7e2ab78e70e9fa1 alsa-driver-0.9.6.ebuild 2226
MD5 e1147a642867b3b3ea43518a1376f6d2 metadata.xml 250
MD5 28ae6bb0823279c56f378d7ac6d6f607 files/alsasound 4608
@@ -16,7 +16,7 @@ MD5 e3912a14a13dae85c5ee17f351733bae files/digest-alsa-driver-0.9.0_rc2 74
MD5 5283280b5f72b9ea25f3e1e1adcde464 files/digest-alsa-driver-0.9.2 71
MD5 cf99f25f7efcafda6d88713ffa6c5eae files/digest-alsa-driver-0.9.7-r3 72
MD5 cf99f25f7efcafda6d88713ffa6c5eae files/digest-alsa-driver-0.9.7-r4 72
-MD5 bcbd1cb289a1317f1776b9a19e6e25cf files/alsa-driver-0.9.7-pde.patch 586
+MD5 3e71a07cb9c11e4fc53d96f92a3b6c9e files/alsa-driver-0.9.7-pde.patch 524
MD5 91bb028293562b98c340b423abbeea15 files/alsa-driver-0.9.5-spinlock_t.patch 1387
MD5 5cd143011580b3dbe23df393b08c5c1e files/digest-alsa-driver-0.9.6 71
MD5 27ccbe36406f145c1d63725a53517233 files/makefile.patch 1122
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.7-r4.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.7-r4.ebuild
new file mode 100644
index 000000000000..30ec9ba4fa4b
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.7-r4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.7-r4.ebuild,v 1.1 2003/10/23 14:32:48 mholzer Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+IUSE="oss"
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ virtual/linux-sources
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="0.9"
+KEYWORDS="~x86 ~ppc"
+
+ALSA_REVISION="c"
+SRC_URI="mirror://alsaproject/driver/${P}${ALSA_REVISION}.tar.bz2"
+S=${WORKDIR}/${P}${ALSA_REVISION}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # The makefile still installs an alsasound initscript,
+ # which we REALLY dont want.
+ # This patch stops that
+ epatch ${FILESDIR}/makefile.patch
+
+ #this is not needed after 0.9.7c (Bug #29965)
+ epatch ${FILESDIR}/${P}-pde.patch
+ # Looks like the below are not needed as of 0.9.7.
+ #epatch ${FILESDIR}/wolk.patch
+ #epatch ${FILESDIR}/alsa-compile-fix
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+
+ myconf=""
+ use oss && myconf="$myconf --with-oss=yes" || \
+ myconf="$myconf --with-oss=no"
+
+ ./configure \
+ $myconf \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use the 'alsamixer' program to unmute them."
+ einfo
+}
+
diff --git a/media-sound/alsa-driver/files/alsa-driver-0.9.7-pde.patch b/media-sound/alsa-driver/files/alsa-driver-0.9.7-pde.patch
new file mode 100644
index 000000000000..8ab6291996e0
--- /dev/null
+++ b/media-sound/alsa-driver/files/alsa-driver-0.9.7-pde.patch
@@ -0,0 +1,16 @@
+--- configure.in.org 2003-10-24 16:26:20.000000000 +0000
++++ configure.in 2003-10-24 16:26:47.000000000 +0000
+@@ -1029,10 +1029,11 @@
+ #include "$CONFIG_SND_KERNELDIR/include/linux/fs.h"
+ #include "$CONFIG_SND_KERNELDIR/include/linux/proc_fs.h"
+ ],[
+- PDE(NULL);
++ struct proc_dir_entry * (*func)();
++ func = PDE;
+ ],
+- AC_MSG_RESULT("no");pde_defined="0",
+ AC_MSG_RESULT("yes");pde_defined="1",
++ AC_MSG_RESULT("no");pde_defined="0",
+ AC_MSG_RESULT("unknown");pde_defined="0"
+ )
+ CFLAGS=$ac_save_CFLAGS
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.7-r4 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.7-r4
new file mode 100644
index 000000000000..c010c86f1b0f
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.7-r4
@@ -0,0 +1 @@
+MD5 6bab6c98de9cbb2431c439c13d495f47 alsa-driver-0.9.7c.tar.bz2 1645407