summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-06-01 17:23:26 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-06-01 17:23:26 +0000
commit09efaa2ce36d264624381dcc49ae57c40bde5796 (patch)
treeea7eebdb27e0774898c229b543770ba13821c588 /media-plugins/mythgallery/mythgallery-0.15.ebuild
parentIntegrated the python module from snns-dev.berlios.de (diff)
downloadhistorical-09efaa2ce36d264624381dcc49ae57c40bde5796.tar.gz
historical-09efaa2ce36d264624381dcc49ae57c40bde5796.tar.bz2
historical-09efaa2ce36d264624381dcc49ae57c40bde5796.zip
Version bump and cleanup.
Diffstat (limited to 'media-plugins/mythgallery/mythgallery-0.15.ebuild')
-rw-r--r--media-plugins/mythgallery/mythgallery-0.15.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-plugins/mythgallery/mythgallery-0.15.ebuild b/media-plugins/mythgallery/mythgallery-0.15.ebuild
new file mode 100644
index 000000000000..474a3beaefb9
--- /dev/null
+++ b/media-plugins/mythgallery/mythgallery-0.15.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/mythgallery-0.15.ebuild,v 1.1 2004/06/01 17:15:29 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Gallery and slideshow module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="opengl"
+
+DEPEND=">=sys-apps/sed-4
+ opengl? ( virtual/opengl )
+ || ( >=media-tv/mythtv-${PV}* >=media-tv/mythfrontend-${PV}* )"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_enable opengl`"
+
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README UPGRADING
+}