summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-12-12 09:22:04 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-12-12 09:22:04 +0000
commit29ee95a54e271ea84bb38bc02aeb5ca03b89e401 (patch)
tree1159d930eba14c14d65e2a5586e5fa5fdb49c3c7 /media-libs
parentversion bump (diff)
downloadhistorical-29ee95a54e271ea84bb38bc02aeb5ca03b89e401.tar.gz
historical-29ee95a54e271ea84bb38bc02aeb5ca03b89e401.tar.bz2
historical-29ee95a54e271ea84bb38bc02aeb5ca03b89e401.zip
Update to 1-beta0.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog10
-rw-r--r--media-libs/xine-lib/files/digest-xine-lib-1_beta01
-rw-r--r--media-libs/xine-lib/xine-lib-1_beta0.ebuild91
3 files changed, 98 insertions, 4 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 12c43035ff73..17bbe995f71a 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.25 2002/12/09 04:26:14 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.26 2002/12/12 09:22:04 agenkin Exp $
-\* Autoupdate keywords (12-6-02)
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
-
+*xine-lib-1_beta0 (28 Nov 2002)
+
+ 28 Nov 2002; Arcady Genkin <agenkin@gentoo.org> xine-lib-1_beta0.ebuild :
+ Version bump.
+
*xine-lib-1_alpha2 (28 Nov 2002)
28 Nov 2002; Arcady Genkin <agenkin@gentoo.org> xine-lib-1_alpha2.ebuild :
diff --git a/media-libs/xine-lib/files/digest-xine-lib-1_beta0 b/media-libs/xine-lib/files/digest-xine-lib-1_beta0
new file mode 100644
index 000000000000..4b2e55bac74d
--- /dev/null
+++ b/media-libs/xine-lib/files/digest-xine-lib-1_beta0
@@ -0,0 +1 @@
+MD5 98bb592315b9a0fdb92bdb77239b0e82 xine-lib-1-beta0.tar.gz 2972961
diff --git a/media-libs/xine-lib/xine-lib-1_beta0.ebuild b/media-libs/xine-lib/xine-lib-1_beta0.ebuild
new file mode 100644
index 000000000000..ec7d17000ac2
--- /dev/null
+++ b/media-libs/xine-lib/xine-lib-1_beta0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_beta0.ebuild,v 1.1 2002/12/12 09:22:04 agenkin Exp $
+
+DESCRIPTION="Core libraries for Xine movie player."
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ X? ( virtual/x11 )
+ avi? ( >=media-libs/win32codecs-0.50
+ media-libs/divx4linux )
+ esd? ( media-sound/esound )
+ dvd? ( >=media-libs/libdvdcss-0.0.3.3
+ >=media-libs/libdvdread-0.9.2 )
+ arts? ( kde-base/kdelibs )
+ alsa? ( media-libs/alsa-lib )
+ aalib? ( media-libs/aalib )
+ directfb? ( >=dev-libs/DirectFB-0.9.9
+ dev-util/pkgconfig )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+IUSE="arts esd avi nls dvd aalib X directfb oggvorbis alsa"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${PN}-${PV/_/-}
+SRC_URI="mirror://sourceforge/xine/${PN}-${PV/_/-}.tar.gz"
+
+# this build doesn't play nice with -maltivec (gcc 3.2 only option) on ppc
+inherit flag-o-matic || die "I lost my inheritance"
+filter-flags "-maltivec -mabi=altivec"
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ # don't use the --disable-XXXtest because that defaults to ON not OFF
+ local myconf
+ use X \
+ || myconf="${myconf} --disable-x11" # --disable-xv"
+ use esd \
+ || myconf="${myconf} --disable-esd" # --disable-esdtest"
+ use nls \
+ || myconf="${myconf} --disable-nls"
+ use alsa \
+ || myconf="${myconf} --disable-alsa" # --disable-alsatest"
+ use arts \
+ || myconf="${myconf} --disable-arts" # --disable-artstest"
+ use aalib \
+ || myconf="${myconf} --disable-aalib" # --disable-aalibtest"
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-vorbis"
+ #--disable-oggtest --disable-vorbistest"
+ use avi \
+ && myconf="${myconf} --with-w32-path=/usr/lib/win32" \
+ || myconf="${myconf} --disable-asf"
+
+ einfo "myconf: ${myconf}"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ einstall || die
+
+ # Xine's makefiles install some file incorrectly. (Gentoo bug #8583).
+ dodir /usr/share/xine/fonts
+ mv ${D}/usr/share/*.xinefont.gz ${D}/usr/share/xine/fonts/
+ dodir /usr/share/xine/skins
+ mv ${D}/usr/share/xine_logo.mpv ${D}/usr/share/xine/skins/
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
+ cd ${S}/doc
+ dodoc dataflow.dia README*
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Please note, a new version of xine-lib has been installed,"
+ einfo "for library consistency you need to unmerge old versions"
+ einfo "of xine-lib before merging xine-ui."
+ einfo
+
+}