summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-20 19:51:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-20 19:51:10 +0000
commitae7f0b28efe72dc856102fe34ffa980806b7c807 (patch)
treeb2db5717f3daff9e0dee8bb2929ca6aaabd75f19 /media-libs/tremor/tremor-0_pre20120120.ebuild
parentuse eapi4. tidy (diff)
downloadhistorical-ae7f0b28efe72dc856102fe34ffa980806b7c807.tar.gz
historical-ae7f0b28efe72dc856102fe34ffa980806b7c807.tar.bz2
historical-ae7f0b28efe72dc856102fe34ffa980806b7c807.zip
Initial commit wrt #264327 by Robert Piasek
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'media-libs/tremor/tremor-0_pre20120120.ebuild')
-rw-r--r--media-libs/tremor/tremor-0_pre20120120.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/tremor/tremor-0_pre20120120.ebuild b/media-libs/tremor/tremor-0_pre20120120.ebuild
new file mode 100644
index 000000000000..0fa82e89730b
--- /dev/null
+++ b/media-libs/tremor/tremor-0_pre20120120.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tremor/tremor-0_pre20120120.ebuild,v 1.1 2012/01/20 19:51:10 ssuominen Exp $
+
+# svn export http://svn.xiph.org/trunk/Tremor tremor-${PV}
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="A fixed-point version of the Ogg Vorbis decoder (also known as libvorbisidec)"
+HOMEPAGE="http://wiki.xiph.org/Tremor"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/libogg"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="CHANGELOG README"
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-O2::' configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dohtml -r doc/*
+ rm -f "${ED}"usr/lib*/lib*.la
+}