summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2009-04-08 20:11:47 +0000
committerHanno Boeck <hanno@gentoo.org>2009-04-08 20:11:47 +0000
commitb46bbdba3a8e16553fa683c090d94d1709aaa09f (patch)
treebdbd1707842df9915df892fa7a9a1ad6b2d9ce1b /media-libs/openal/openal-1.7.411.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-b46bbdba3a8e16553fa683c090d94d1709aaa09f.tar.gz
historical-b46bbdba3a8e16553fa683c090d94d1709aaa09f.tar.bz2
historical-b46bbdba3a8e16553fa683c090d94d1709aaa09f.zip
openal bump and correct multilib installation patch
Package-Manager: portage-2.2_rc28/cvs/Linux x86_64
Diffstat (limited to 'media-libs/openal/openal-1.7.411.ebuild')
-rw-r--r--media-libs/openal/openal-1.7.411.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/openal/openal-1.7.411.ebuild b/media-libs/openal/openal-1.7.411.ebuild
new file mode 100644
index 000000000000..667e8fcd66f1
--- /dev/null
+++ b/media-libs/openal/openal-1.7.411.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-1.7.411.ebuild,v 1.1 2009/04/08 20:11:46 hanno Exp $
+
+inherit eutils cmake-utils
+
+MY_P=${PN}-soft-${PV}
+
+DESCRIPTION="A software implementation of the OpenAL 3D audio API"
+HOMEPAGE="http://kcat.strangesoft.net/openal.html"
+SRC_URI="http://kcat.strangesoft.net/openal-releases/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa oss debug"
+DEPEND="alsa? ( media-libs/alsa-lib )"
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${MY_P}
+
+DOCS="alsoftrc.sample"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/openal-soft-1.7.411-multilib.patch" || die "epatch failed"
+}
+
+src_compile() {
+ local mycmakeargs=""
+
+ use alsa || mycmakeargs="${mycmakeargs} -DALSA=OFF"
+ use oss || mycmakeargs="${mycmakeargs} -DOSS=OFF"
+ use debug && mycmakeargs="${mycmakeargs} -DCMAKE_BUILD_TYPE=Debug"
+
+ cmake-utils_src_compile
+}
+
+pkg_postinst() {
+ einfo "If you have performance problems using this library, then"
+ einfo "try add these lines to your ~/.alsoftrc config file:"
+ einfo "[alsa]"
+ einfo "mmap = off"
+}