summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-22 16:44:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-22 16:44:19 +0000
commit003130a6d0b9fbbac63d64dd604db52d0db19b6e (patch)
tree9bf7fc60f0ce24f3671d1a719ddf626aacdd144b /media-libs/lcms
parent*** empty log message *** (diff)
downloadhistorical-003130a6d0b9fbbac63d64dd604db52d0db19b6e.tar.gz
historical-003130a6d0b9fbbac63d64dd604db52d0db19b6e.tar.bz2
historical-003130a6d0b9fbbac63d64dd604db52d0db19b6e.zip
Added some missing files
Diffstat (limited to 'media-libs/lcms')
-rw-r--r--media-libs/lcms/lcms-1.06.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/lcms/lcms-1.06.ebuild b/media-libs/lcms/lcms-1.06.ebuild
new file mode 100644
index 000000000000..72e96cb71c78
--- /dev/null
+++ b/media-libs/lcms/lcms-1.06.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lcms/lcms-1.06.ebuild,v 1.1 2001/02/22 16:44:19 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="lcms deals with color management stuff"
+SRC_URI="http://www.littlecms.com/${A}"
+HOMEPAGE="http://www.littlecms.com/index.htm"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ cd ${D}/usr/include/lcms
+ cp lcms.h lcms.orig
+ sed -e "s:#define VERSION.*::" \
+ -e "s:#define PACKAGE.*::" \
+ lcms.orig > lcms.h
+ rm lcms.orig
+
+ cd ${S}/profiles
+ dodir /usr/share/lcms/profiles
+ cp *.icm ${D}/usr/share/lcms/profiles
+ cd ${S}
+
+ dodoc AUTHORS COPYING ChangeLog README*
+ docinto txt
+ dodoc doc/*.txt
+
+}
+