summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-28 21:56:11 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-28 21:56:11 +0000
commit07dc6445b92c5369f369c30894b73154d859d1e3 (patch)
tree8da4701661f232986771a34c2657a7228f1d81aa /media-libs/cogl
parentAdd gnome-3.2 versions of libpeas, clutter, and cogl to p.mask. (diff)
downloadhistorical-07dc6445b92c5369f369c30894b73154d859d1e3.tar.gz
historical-07dc6445b92c5369f369c30894b73154d859d1e3.tar.bz2
historical-07dc6445b92c5369f369c30894b73154d859d1e3.zip
New package, moved from the gnome overlay. Formerly part of media-libs/clutter. Required for clutter-1.8.
Package-Manager: portage-2.2.0_alpha71/cvs/Linux x86_64
Diffstat (limited to 'media-libs/cogl')
-rw-r--r--media-libs/cogl/ChangeLog11
-rw-r--r--media-libs/cogl/Manifest14
-rw-r--r--media-libs/cogl/cogl-1.8.2.ebuild67
-rw-r--r--media-libs/cogl/metadata.xml12
4 files changed, 104 insertions, 0 deletions
diff --git a/media-libs/cogl/ChangeLog b/media-libs/cogl/ChangeLog
new file mode 100644
index 000000000000..c3cc83d063e7
--- /dev/null
+++ b/media-libs/cogl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-libs/cogl
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/ChangeLog,v 1.1 2011/10/28 21:56:11 tetromino Exp $
+
+*cogl-1.8.2 (28 Oct 2011)
+
+ 28 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org> +cogl-1.8.2.ebuild,
+ +metadata.xml:
+ New package, moved from the gnome overlay. Formerly part of
+ media-libs/clutter. Required for clutter-1.8.
+
diff --git a/media-libs/cogl/Manifest b/media-libs/cogl/Manifest
new file mode 100644
index 000000000000..53d6e5415631
--- /dev/null
+++ b/media-libs/cogl/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST cogl-1.8.2.tar.xz 1029304 RMD160 9d6bd22536a8be7f2482f7caf6fee16baa67fbee SHA1 ecc72af65608023dc6103357b86029e62993c62a SHA256 ec26fd90c4ba5643875b5f3a04b4ab14b24f0d618ba3d239d61e773c3e3ca8c7
+EBUILD cogl-1.8.2.ebuild 1740 RMD160 4d321adeb179da7948883082c08928ae78c4cd12 SHA1 fa28c703841bdf2ea887a5f4dd92121f8bf8e194 SHA256 891bd2ae84005173c6345868ea46acbf03320409ba0bedb7432cf220d95c0182
+MISC ChangeLog 440 RMD160 eff0007b54c406673fa8a183486d1ad1ad817444 SHA1 91968a75e116fb6f56110d5ff6ec60d641b40837 SHA256 e8919ef27ee8c52fa0034dc4844774dc82ffc580da2d242744695a3f9abe0b38
+MISC metadata.xml 379 RMD160 18d135a3128e1557181e558a140d86d930f8f648 SHA1 7db82ffa59c5252a1d455dba982d45f515a18b7d SHA256 f4784f07c4dc3569f8386538d560660f035bc2b5d5a040613bd81a158a593952
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iF4EAREIAAYFAk6rJQAACgkQdjK8w9WeBnBHzgD+JPcaSoieIzcHbmunObhB00yJ
+n8hS8XxcX+RSG5JQVxUA/R6x834Hy4bqrwpH1e0cdh6yhb/psf1U72nNaHaGsqFJ
+=qK2d
+-----END PGP SIGNATURE-----
diff --git a/media-libs/cogl/cogl-1.8.2.ebuild b/media-libs/cogl/cogl-1.8.2.ebuild
new file mode 100644
index 000000000000..12880b5bd7de
--- /dev/null
+++ b/media-libs/cogl/cogl-1.8.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cogl/cogl-1.8.2.ebuild,v 1.1 2011/10/28 21:56:11 tetromino Exp $
+
+EAPI="4"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+inherit clutter gnome2 virtualx
+
+DESCRIPTION="A library for using 3D graphics hardware to draw pretty pictures"
+HOMEPAGE="http://www.clutter-project.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0"
+IUSE="doc examples +introspection +pango"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# XXX: need uprof for optional profiling support
+COMMON_DEPEND=">=dev-libs/glib-2.26.0:2
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2:2
+ x11-libs/libdrm
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ virtual/opengl
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ pango? ( >=x11-libs/pango-1.20.0[introspection?] )"
+# before clutter-1.7, cogl was part of clutter
+RDEPEND="${COMMON_DEPEND}
+ !<media-libs/clutter-1.7"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.13 )"
+
+# XXX: at least when using nvidia-drivers, tests fail under Xemake/Xvfb, no
+# matter whether "eselect opengl" is set to nvidia or xorg-x11.
+RESTRICT="test"
+
+pkg_setup() {
+ DOCS="NEWS README"
+ EXAMPLES="examples/{*.c,*.jpg}"
+ # XXX: think about gles, quartz, wayland
+ G2CONF="${G2CONF}
+ --disable-profile
+ --disable-maintainer-flags
+ --enable-cairo
+ --enable-gdk-pixbuf
+ --enable-gl
+ --enable-glx
+ $(use_enable introspection)
+ $(use_enable pango cogl-pango)"
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ clutter_src_install
+}
diff --git a/media-libs/cogl/metadata.xml b/media-libs/cogl/metadata.xml
new file mode 100644
index 000000000000..2568db9ec971
--- /dev/null
+++ b/media-libs/cogl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+ <flag name="pango">Build cogl-pango library for <pkg>x11-libs/pango</pkg>
+ integration</flag>
+</use>
+</pkgmetadata>
+