summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-12-04 22:15:51 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-12-04 22:15:51 +0000
commit5bd9d1dae6d7a72dd545235e638fd750cac0f87b (patch)
tree34ca4ee15b4fa7cd1172b9c5775ba9420554d4cb /media-gfx
parentncompress added properly to non-x86 arches (diff)
downloadhistorical-5bd9d1dae6d7a72dd545235e638fd750cac0f87b.tar.gz
historical-5bd9d1dae6d7a72dd545235e638fd750cac0f87b.tar.bz2
historical-5bd9d1dae6d7a72dd545235e638fd750cac0f87b.zip
removed dependency on libpng-1.0 by making the package compile without png support.
This is the last app that depends on libpng-1.0 series nd there were requests to resolve this multiple libpng versions mess by removing libpng-1.0 Masked in a package.mask as well as in KEYWORDS. Will get unmasked if we do perform libpng clean-up.
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphviz/ChangeLog19
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-1.8.10-r11
-rw-r--r--media-gfx/graphviz/files/gdgen.c.patch15
-rw-r--r--media-gfx/graphviz/graphviz-1.8.10-r1.ebuild48
4 files changed, 75 insertions, 8 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index cd49842ef377..8232acec3534 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-gfx/graphviz
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.4 2002/11/11 11:25:21 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.5 2002/12/04 22:15:51 george Exp $
+
+*graphviz-1.8.10-r1 (10 Nov 2002)
+
+ 10 Nov 2002; George Shapovalov <george@gentoo.org> graphviz-1.8.10-r1.ebuild, files/ :
+
+ removed libpng dependency and made package compile without libpng.
+ Reason: at the moment this is the only app left in portage that depends on libpng-1.0
+ series (often won't compile against 1.2) and libpng-1.0 is creating a lot of trouble
+ for example with kdelibs. See #10726 for details.
*graphviz-1.8.10 (10 Nov 2002)
@@ -20,10 +29,4 @@
*graphviz-1.7.15-r1 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+
diff --git a/media-gfx/graphviz/files/digest-graphviz-1.8.10-r1 b/media-gfx/graphviz/files/digest-graphviz-1.8.10-r1
new file mode 100644
index 000000000000..83e5bdee4202
--- /dev/null
+++ b/media-gfx/graphviz/files/digest-graphviz-1.8.10-r1
@@ -0,0 +1 @@
+MD5 7c9663c8e2cde4f7edc2b412cc148330 graphviz-1.8.10.tar.gz 2837389
diff --git a/media-gfx/graphviz/files/gdgen.c.patch b/media-gfx/graphviz/files/gdgen.c.patch
new file mode 100644
index 000000000000..dabb37d50bc4
--- /dev/null
+++ b/media-gfx/graphviz/files/gdgen.c.patch
@@ -0,0 +1,15 @@
+--- gdgen.c-orig 2002-12-04 11:21:19.000000000 -0800
++++ gdgen.c 2002-12-04 11:22:52.000000000 -0800
+@@ -754,8 +754,11 @@
+ else {
+ suffix = strrchr(imagefile,'.');
+ if (!suffix) suffix = imagefile; else suffix++;
++ #ifdef HAVE_LIBPNG
+ if (!strcasecmp(suffix,"png")) rv = gdImageCreateFromPng(in);
+- else if (!strcasecmp(suffix,"gif")) rv = gdImageCreateFromGif(in);
++ else //this split seems to be the easiest way to disable png correctly
++ #endif
++ if (!strcasecmp(suffix,"gif")) rv = gdImageCreateFromGif(in);
+ else if (!strcasecmp(suffix,"jpeg")||!strcasecmp(suffix,"jpg")) rv = gdImageCreateFromJpeg(in);
+ else if (!strcasecmp(suffix,"wbmp")) rv = gdImageCreateFromWBMP(in);
+ else if (!strcasecmp(suffix,"xbm")) rv = gdImageCreateFromXbm(in);
diff --git a/media-gfx/graphviz/graphviz-1.8.10-r1.ebuild b/media-gfx/graphviz/graphviz-1.8.10-r1.ebuild
new file mode 100644
index 000000000000..85c4d6e86524
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-1.8.10-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.8.10-r1.ebuild,v 1.1 2002/12/04 22:15:51 george Exp $
+
+IUSE="tcltk"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="open source graph drawing software"
+SRC_URI="http://www.graphviz.org/pub/graphviz/${P}.tar.gz"
+HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
+
+SLOT="0"
+LICENSE="as-is | ATT"
+KEYWORDS="~x86 ~ppc"
+
+#Can use freetype-1.3 or 2.0, but not both
+DEPEND=">=sys-libs/zlib-1.1.3
+ >=media-libs/jpeg-6b
+ media-libs/freetype
+ tcltk? ( =dev-lang/tk-8.3* )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/dotneato/common
+ patch gdgen.c < ${FILESDIR}/gdgen.c.patch
+}
+
+src_compile() {
+ local myconf
+ #if no tcltk, this will generate configure warnings, but will
+ #compile without tcltk support
+ use tcltk || myconf="${myconf} --without-tcl --without-tk"
+
+ econf ${myconf} || die "./configure failed"
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog FAQ.txt INSTALL MINTERMS.txt \
+ NEWS README
+
+ dohtml -r .
+ dodoc doc/*.pdf
+}