summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-05-27 17:54:40 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-05-27 17:54:40 +0000
commit5255cbbded9ae71af3604503b51cb25038b9c259 (patch)
treee0074e21dd8258f0f1f3b29d2f5fbf3c3af77976 /media-gfx
parentNew beta release (diff)
downloadhistorical-5255cbbded9ae71af3604503b51cb25038b9c259.tar.gz
historical-5255cbbded9ae71af3604503b51cb25038b9c259.tar.bz2
historical-5255cbbded9ae71af3604503b51cb25038b9c259.zip
various cleanups, not perfect yet.
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp/Manifest2
-rw-r--r--media-gfx/gimp/gimp-1.2.4.ebuild70
2 files changed, 8 insertions, 64 deletions
diff --git a/media-gfx/gimp/Manifest b/media-gfx/gimp/Manifest
index ec39cb9ca914..2c511eacaa66 100644
--- a/media-gfx/gimp/Manifest
+++ b/media-gfx/gimp/Manifest
@@ -1,7 +1,7 @@
MD5 855d7d70f5b845d808e46258219e5d9f ChangeLog 5295
MD5 0baa40e08fefbcca963d21359b210477 gimp-1.2.3-r2.ebuild 4202
MD5 3ffcb6910a8be02857177f4179725ca8 gimp-1.2.3-r3.ebuild 4717
-MD5 c5f902b48e3365bcab097f761b827a35 gimp-1.2.4.ebuild 4743
+MD5 9abd23b9bf6152be1f7ce3dc0fe322c5 gimp-1.2.4.ebuild 2983
MD5 f965b674f1ab5e80d1c83313aee3900b gimp-1.3.11.ebuild 2151
MD5 04eb1d0c00755166e94520f1373b452a gimp-1.3.13.ebuild 2355
MD5 33b3899f6b5b6a4a8e7e43be18ffed46 gimp-1.3.12.ebuild 2280
diff --git a/media-gfx/gimp/gimp-1.2.4.ebuild b/media-gfx/gimp/gimp-1.2.4.ebuild
index 7f78327cd461..a3d0bf3fe551 100644
--- a/media-gfx/gimp/gimp-1.2.4.ebuild
+++ b/media-gfx/gimp/gimp-1.2.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.4.ebuild,v 1.1 2003/05/27 14:48:21 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.4.ebuild,v 1.2 2003/05/27 17:54:31 liquidx Exp $
inherit eutils flag-o-matic
-IUSE="python nls gnome aalib perl doc jpeg png tiff"
+IUSE="python nls gnome aalib perl doc jpeg png tiff doc"
S=${WORKDIR}/${P}
DESCRIPTION="The GIMP"
@@ -28,59 +28,12 @@ RDEPEND="=x11-libs/gtk+-1.2*
DEPEND="nls? ( sys-devel/gettext )
doc? ( dev-util/gtk-doc )
- sys-devel/autoconf
- sys-devel/automake
>=media-libs/mpeg-lib-1.3.1
${RDEPEND}"
src_unpack() {
-# if [ "`use threads`" ]; then
-# eerror "I'm sorry I can't build against a threaded perl,"
-# eerror "please remerge perl and libperl without"
-# eerror "'USE=threads' and try again. (Note: this message"
-# eerror "is triggered by having threads in USE so you must"
-# eerror "leave threads out of your USE var when merging"
-# eerror "gimp."
-# die "Not compatible with threaded perl"
-# fi
unpack ${A}
-
-# cd ${S}/plug-ins/common
- # compile with nonstandard psd_save plugin
-# cp ${FILESDIR}/psd_save.c .
-# epatch ${FILESDIR}/${PF}-gentoo.diff
-# cd ${S}
-
-# if [ -f ${ROOT}/usr/share/gettext/config.rpath ] ; then
-# cp -f ${ROOT}/usr/share/gettext/config.rpath ${S}
-# else
-# touch ${S}/config.rpath
-# chmod 0755 ${S}/config.rpath
-# fi
-
-# echo ">>> Reconfiguring package..."
-# export WANT_AUTOMAKE_1_4=1
-# export WANT_AUTOCONF_2_1=1
-# aclocal -I . -I ${S}/plug-ins/perl
-# automake --add-missing --gnu
-# Do not run autoreconf, or even autoconf, as it (autoreconf at least)
-# needs cvs installed, and breaks configure (locales are not installed).
-# Our psd_save patch anyhow only touch .am files, so only automake is
-# needed .... This should fix bug #8490, #6021 and #9621.
-#
-# <azarah@gentoo.org> (2 Nov 2002)
-#
-# autoreconf --install --symlink &> ${T}/autoreconf.log || ( \
-# echo "DEBUG: working directory is: `pwd`" >>${T}/autoreconf.log
-# eerror "Reonfigure failed, please attatch the contents of:"
-# eerror
-# eerror " ${T}/autoreconf.log"
-# eerror
-# eerror "in your bugreport."
-# # we need an error here, else the ebuild do not die
-# exit 1
-# ) || die "running autoreconf failed"
-
+ # here for a mysterious reason
touch ${S}/plug-ins/common/${P}.tar.bz2
}
@@ -124,13 +77,8 @@ src_compile() {
src_install() {
local mymake=""
- if [ -z "`use aalib`" ] ; then
- mymake="LIBAA= AA="
- fi
-
- if [ -z "`use gnome`" ] ; then
- mymake="${mymake} HELPBROWSER="
- fi
+ use aalib || mymake="LIBAA= AA="
+ use gnome || mymake="${mymake} HELPBROWSER="
dodir /usr/lib/gimp/1.2/plug-ins
@@ -154,17 +102,13 @@ src_install() {
#this next line closes bug #810
dosym gimptool-1.2 /usr/bin/gimptool
- if [ "`use gnome`" ] && [ -d ${ROOT}/usr/share/applications ]
- then
+ use gnome && (
insinto /usr/share/applications
doins ${FILESDIR}/gimp.desktop
- fi
+ )
preplib /usr
dodoc AUTHORS COPYING ChangeLog* *MAINTAINERS README* TODO
dodoc docs/*.txt docs/*.ps docs/Wilber* docs/quick_reference.tar.gz
-# dohtml -r devel-docs
-# docinto devel
-# dodoc devel-docs/*.txt
}