summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-12-02 05:07:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-12-02 05:07:54 +0000
commitca0d65df37ac2fc8f3b4a784512351a9c65c6c36 (patch)
tree8f4350be2e16b66ac9eebd5131ff8f4812fd41bd /media-gfx/springgraph
parentinitial commit, ebuild by robbat2@gentoo.org (diff)
downloadhistorical-ca0d65df37ac2fc8f3b4a784512351a9c65c6c36.tar.gz
historical-ca0d65df37ac2fc8f3b4a784512351a9c65c6c36.tar.bz2
historical-ca0d65df37ac2fc8f3b4a784512351a9c65c6c36.zip
initial commit, ebuild by robbat2@gentoo.org
Diffstat (limited to 'media-gfx/springgraph')
-rw-r--r--media-gfx/springgraph/Manifest4
-rw-r--r--media-gfx/springgraph/files/digest-springgraph-791
-rw-r--r--media-gfx/springgraph/metadata.xml15
-rw-r--r--media-gfx/springgraph/springgraph-79.ebuild30
4 files changed, 49 insertions, 1 deletions
diff --git a/media-gfx/springgraph/Manifest b/media-gfx/springgraph/Manifest
index d63aa64e2e75..440e0b3001f7 100644
--- a/media-gfx/springgraph/Manifest
+++ b/media-gfx/springgraph/Manifest
@@ -1,2 +1,4 @@
-MD5 bba002a508514d58bad42cc7781aa56e springgraph-79.ebuild 530
+MD5 b4ad45b995f4e479520c266340032f4d springgraph-79.ebuild 707
+MD5 31eb3b82c0eb850fc46efa2155fcb88f ChangeLog 395
+MD5 33972e24d3f8c3621bd32c36ba6e8b6c metadata.xml 716
MD5 b0879467842149fda0eb7ccea27b6a64 files/digest-springgraph-79 61
diff --git a/media-gfx/springgraph/files/digest-springgraph-79 b/media-gfx/springgraph/files/digest-springgraph-79
new file mode 100644
index 000000000000..086d74298ca5
--- /dev/null
+++ b/media-gfx/springgraph/files/digest-springgraph-79
@@ -0,0 +1 @@
+MD5 701e49bbceb35a9054dfc7e55a8c863a springgraph.pl.79 26057
diff --git a/media-gfx/springgraph/metadata.xml b/media-gfx/springgraph/metadata.xml
new file mode 100644
index 000000000000..20f921e2d228
--- /dev/null
+++ b/media-gfx/springgraph/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+<longdescription> Springgraph will read in a .dot file description of a graph,
+ which, for each node, specifies its name and which other nodes it is
+ connected to, and then renders a graph. Each node is drawn as an ellipse,
+ and each connection is drawn as an arrow. The node placement is a result of
+ all of the nodes moving away from each other, while all nodes which are
+ connected move toward each other. This movement is repeated until it
+ stabilizes.</longdescription>
+</pkgmetadata>
diff --git a/media-gfx/springgraph/springgraph-79.ebuild b/media-gfx/springgraph/springgraph-79.ebuild
new file mode 100644
index 000000000000..b34f3a54f4be
--- /dev/null
+++ b/media-gfx/springgraph/springgraph-79.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/springgraph/springgraph-79.ebuild,v 1.1 2003/12/02 05:07:52 robbat2 Exp $
+
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://www.chaosreigns.com/code/springgraph"
+SRC_FILENAME="${PN}.pl.${PV}"
+SRC_URI="${HOMEPAGE}/dl/${SRC_FILENAME}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~arm ~hppa ~mips ~ppc ~sparc ia64 amd64"
+IUSE=""
+DEPEND=""
+RDEPEND="dev-perl/GD"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ # nothing to do
+ :
+}
+
+src_compile() {
+ # nothing to do
+ :
+}
+
+src_install() {
+ into /usr
+ newbin ${DISTDIR}/${SRC_FILENAME} ${PN}
+}