summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-04-23 18:53:08 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-04-23 18:53:08 +0000
commitaf57e1df3ab8bc5ce34b679f5429b22ff9632de1 (patch)
tree23ac077d35ef2c03c1b890772e96eb6a0730bc61 /media-gfx/pngtools
parentFix typo (diff)
downloadhistorical-af57e1df3ab8bc5ce34b679f5429b22ff9632de1.tar.gz
historical-af57e1df3ab8bc5ce34b679f5429b22ff9632de1.tar.bz2
historical-af57e1df3ab8bc5ce34b679f5429b22ff9632de1.zip
Keyword ~amd64. Fix implicit declarations; math.h, string.h, stdlib.h. Use toolchain-funcs to export CC.
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'media-gfx/pngtools')
-rw-r--r--media-gfx/pngtools/ChangeLog9
-rw-r--r--media-gfx/pngtools/Manifest5
-rw-r--r--media-gfx/pngtools/files/pngtools-0.3-implicit-declarations.patch40
-rw-r--r--media-gfx/pngtools/pngtools-0.3.ebuild33
4 files changed, 75 insertions, 12 deletions
diff --git a/media-gfx/pngtools/ChangeLog b/media-gfx/pngtools/ChangeLog
index 2b94262cbd16..4301e36344c4 100644
--- a/media-gfx/pngtools/ChangeLog
+++ b/media-gfx/pngtools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/pngtools
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/ChangeLog,v 1.2 2006/06/05 22:23:17 robbat2 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/ChangeLog,v 1.3 2008/04/23 18:53:07 drac Exp $
+
+ 23 Apr 2008; Samuli Suominen <drac@gentoo.org>
+ +files/pngtools-0.3-implicit-declarations.patch, pngtools-0.3.ebuild:
+ Keyword ~amd64. Fix implicit declarations; math.h, string.h, stdlib.h. Use
+ toolchain-funcs to export CC.
05 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> metadata.xml,
pngtools-0.3.ebuild:
diff --git a/media-gfx/pngtools/Manifest b/media-gfx/pngtools/Manifest
index 3e8e11ac4e3e..370b3520c632 100644
--- a/media-gfx/pngtools/Manifest
+++ b/media-gfx/pngtools/Manifest
@@ -1,4 +1,5 @@
+AUX pngtools-0.3-implicit-declarations.patch 1428 RMD160 90a59cff9af1251af6ba93be1c9c27aaeb2ba8de SHA1 2ea57d8b3b393942443e64bfed8f86be8dcb329e SHA256 7ef75837f24736cbba7f7130ba1e31178a70088d883d6581f86acf0fed79ee62
DIST pngtools_0_3.tgz 621817 RMD160 ec6c91cb20bc1e4f982cdc0158b98bc850332aae SHA1 20e864e68fd00ccdc2fc317e2f39952c3ad7935f SHA256 99c413d140b8c48aff1fa78ab8b380b375050af43375cfc8308b27bd1b559452
-EBUILD pngtools-0.3.ebuild 688 RMD160 45dc3fd2e65c85337d6f433babce1d526c2197aa SHA1 978f80d4776ef96d07d1ea7bf35b918aaf477bce SHA256 28140c396e42d08d2a025f12c3094098a4fbe4017e48adf578b2c3aa1d26c933
-MISC ChangeLog 571 RMD160 98e760e7df7e0adc177e6bcde90b0492d3c7c8b6 SHA1 654111940430ceff49f84d7689a7c510647a2497 SHA256 6b4ea5f553e546dde27e7f42baccb7fcc8d2c915203fc650630cc997308ee71f
+EBUILD pngtools-0.3.ebuild 932 RMD160 d301cd3297c27a01c7a9e0329dad1bd53313774f SHA1 8222996b3a78371a5901bce58f96116d6837cf71 SHA256 22549029cc78147ebb30b01a5e1b9161ee7b011adfd26cdb9afb02be867ff43c
+MISC ChangeLog 799 RMD160 5b65cd518ab7575ee6a49efd0533ae3a4d6afe04 SHA1 aa2d2576171466384e6d72e9ea36b033659c9625 SHA256 3f9c906f2b96b99bd097d3ac3f599a0e88a4659acde8b5ce6b05603365feb622
MISC metadata.xml 224 RMD160 ccd6090ef80b519508172a0c24ea5ad88454b42b SHA1 1460973a0074ede59c646aed8e68d428f8c32988 SHA256 5fc722539b33aa476eae5643bf61f0b9aa31488da230655896b36fa2288acc55
diff --git a/media-gfx/pngtools/files/pngtools-0.3-implicit-declarations.patch b/media-gfx/pngtools/files/pngtools-0.3-implicit-declarations.patch
new file mode 100644
index 000000000000..682bcc8c29d3
--- /dev/null
+++ b/media-gfx/pngtools/files/pngtools-0.3-implicit-declarations.patch
@@ -0,0 +1,40 @@
+diff -ur pngtools.orig/inflateraster.c pngtools/inflateraster.c
+--- pngtools.orig/inflateraster.c 2005-04-08 04:23:34.000000000 +0300
++++ pngtools/inflateraster.c 2008-04-23 20:38:05.000000000 +0300
+@@ -1,5 +1,6 @@
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <math.h>
+
+ // Inflate a raster to a given pixel sample size
+ char *inflateraster(char *input, unsigned long width, unsigned long height,
+diff -ur pngtools.orig/pngchunkdesc.c pngtools/pngchunkdesc.c
+--- pngtools.orig/pngchunkdesc.c 2005-04-08 04:23:34.000000000 +0300
++++ pngtools/pngchunkdesc.c 2008-04-23 20:44:38.000000000 +0300
+@@ -20,6 +20,7 @@
+ ******************************************************************************/
+
+ #include <stdio.h>
++#include <string.h>
+
+ char *meanings[4][2] = {
+ {"Critical", "Ancillary"},
+diff -ur pngtools.orig/pngchunks.c pngtools/pngchunks.c
+--- pngtools.orig/pngchunks.c 2005-04-08 04:23:35.000000000 +0300
++++ pngtools/pngchunks.c 2008-04-23 20:38:29.000000000 +0300
+@@ -1,6 +1,7 @@
+ // List the chunks which appear in a given PNG image
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <sys/mman.h>
+ #include <sys/types.h>
+diff -ur pngtools.orig/pngcp.c pngtools/pngcp.c
+--- pngtools.orig/pngcp.c 2005-04-08 04:23:35.000000000 +0300
++++ pngtools/pngcp.c 2008-04-23 20:38:13.000000000 +0300
+@@ -1,3 +1,4 @@
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <math.h>
diff --git a/media-gfx/pngtools/pngtools-0.3.ebuild b/media-gfx/pngtools/pngtools-0.3.ebuild
index 284354471aae..b2f6c5dcd7ab 100644
--- a/media-gfx/pngtools/pngtools-0.3.ebuild
+++ b/media-gfx/pngtools/pngtools-0.3.ebuild
@@ -1,23 +1,40 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/pngtools-0.3.ebuild,v 1.3 2007/07/12 04:08:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngtools/pngtools-0.3.ebuild,v 1.4 2008/04/23 18:53:07 drac Exp $
-MY_PV="${PV/./_}"
+inherit eutils toolchain-funcs
+
+MY_PV=${PV/./_}
DESCRIPTION="A series of tools for the PNG image format"
-HOMEPAGE="http://www.stillhq.com/pngtools/"
+HOMEPAGE="http://www.stillhq.com/pngtools"
SRC_URI="http://www.stillhq.com/pngtools/source/pngtools_${MY_PV}.tgz"
-S="${WORKDIR}/${PN}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND=">=media-libs/libpng-1.2.8-r1
virtual/libc"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-implicit-declarations.patch
+}
+
+src_compile() {
+ tc-export CC
+ econf
+ emake || die "emake failed."
+}
+
src_install() {
- emake -j1 install DESTDIR="${D}" || die "emake install failed"
- dodoc ABOUT AUTHORS ChangeLog NEWS README chunks.txt *.png
+ emake -j1 install DESTDIR="${D}" || die "emake install failed."
+ dodoc ABOUT AUTHORS ChangeLog NEWS README chunks.txt
+ insinto /usr/share/doc/${PF}/examples
+ doins *.png
}