summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-05-04 19:55:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-05-04 19:55:13 +0000
commit791895924aef5bde4a60f8c089fb4e794b8ca29e (patch)
tree1a56a1c84ab1e8851e9c70c766885b17be994ac8 /media-gfx/picturewall
parentVersion bump. Now supports OpenMP and R (diff)
downloadhistorical-791895924aef5bde4a60f8c089fb4e794b8ca29e.tar.gz
historical-791895924aef5bde4a60f8c089fb4e794b8ca29e.tar.bz2
historical-791895924aef5bde4a60f8c089fb4e794b8ca29e.zip
Initial commit of picturewall application
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/picturewall')
-rw-r--r--media-gfx/picturewall/ChangeLog10
-rw-r--r--media-gfx/picturewall/Manifest4
-rw-r--r--media-gfx/picturewall/metadata.xml12
-rw-r--r--media-gfx/picturewall/picturewall-1.0.ebuild30
4 files changed, 56 insertions, 0 deletions
diff --git a/media-gfx/picturewall/ChangeLog b/media-gfx/picturewall/ChangeLog
new file mode 100644
index 000000000000..2a129038152d
--- /dev/null
+++ b/media-gfx/picturewall/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/picturewall
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/picturewall/ChangeLog,v 1.1 2010/05/04 19:55:13 hwoarang Exp $
+
+*picturewall-1.0 (04 May 2010)
+
+ 04 May 2010; Markos Chandras <hwoarang@gentoo.org>
+ +picturewall-1.0.ebuild, +metadata.xml:
+ Initial commit of picturewall application
+
diff --git a/media-gfx/picturewall/Manifest b/media-gfx/picturewall/Manifest
new file mode 100644
index 000000000000..59ea04cd1eeb
--- /dev/null
+++ b/media-gfx/picturewall/Manifest
@@ -0,0 +1,4 @@
+DIST PictureWall_1.0.zip 3265185 RMD160 da1ccf548e14e6ec9da6b9c24fa47d4e8cdbeab5 SHA1 ab8570cbdb93b95ef0dff0ed6bcc90118a5ade20 SHA256 e7458a6f71b3354fd88ce0656d236e7aafa9736f1d079f417986cf3bc6a39722
+EBUILD picturewall-1.0.ebuild 813 RMD160 5d751bd8d10b133a0802b9b3206ed1fbc3218aed SHA1 b3af9be3122ebb4ca107366cb50d5be2e3cd7fcf SHA256 107a3196853717736e2bdcffd4c2518e185fcda7e0487592cc85d74a2f359f24
+MISC ChangeLog 389 RMD160 07954099146d8a983a55be40e08fa4cf8fafcfde SHA1 c34dfc68718ba4a8ad4c7fcba46950bd93778158 SHA256 fb896d12f997b3b1953bdfa0443e53db85a082a95e08537bd3386405ee202de8
+MISC metadata.xml 294 RMD160 ac4e1baa0a1839ae0a807a9d4b915134788d6aa1 SHA1 82865de14486cb30dc9ebfe6f1aecc9c86c0075b SHA256 209af586ae032f00659b69da17d4186854660be14b244d31aa0bea2005c2c5ba
diff --git a/media-gfx/picturewall/metadata.xml b/media-gfx/picturewall/metadata.xml
new file mode 100644
index 000000000000..d5f9562e2df2
--- /dev/null
+++ b/media-gfx/picturewall/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qt</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-gfx/picturewall/picturewall-1.0.ebuild b/media-gfx/picturewall/picturewall-1.0.ebuild
new file mode 100644
index 000000000000..f88861e37f77
--- /dev/null
+++ b/media-gfx/picturewall/picturewall-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/picturewall/picturewall-1.0.ebuild,v 1.1 2010/05/04 19:55:13 hwoarang Exp $
+
+EAPI="2"
+
+inherit qt4-r2
+MY_PN="PictureWall"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Qt4 picture viewer and image searching tool using google.com"
+HOMEPAGE="http://www.qt-apps.org/content/show.php?content=106101"
+SRC_URI="http://picturewall.googlecode.com/files/PictureWall_1.0.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/qt-gui-4.5.3"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}/${MY_PN}"
+
+src_install(){
+ dobin bin/${PN} || die "dobin failed"
+ dodoc ReadMe || die "dodoc failed"
+ dohtml -r doc/html/* || die "dohtml failed"
+}