summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-11-19 05:10:01 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-11-19 05:10:01 +0000
commit67f3758c34f69730f5df7b994a0ad7e60b2b5c36 (patch)
tree5f667299992ba14eff6e7258d416cba62e557300 /media-gfx/hugin
parentAdded ~sparc keyword wrt bug #112811. (diff)
downloadhistorical-67f3758c34f69730f5df7b994a0ad7e60b2b5c36.tar.gz
historical-67f3758c34f69730f5df7b994a0ad7e60b2b5c36.tar.bz2
historical-67f3758c34f69730f5df7b994a0ad7e60b2b5c36.zip
Add patch to fix compilation with gcc4.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'media-gfx/hugin')
-rw-r--r--media-gfx/hugin/ChangeLog6
-rw-r--r--media-gfx/hugin/Manifest11
-rw-r--r--media-gfx/hugin/files/hugin-0.5_rc2-gcc4.patch34
-rw-r--r--media-gfx/hugin/hugin-0.5_rc2.ebuild7
4 files changed, 50 insertions, 8 deletions
diff --git a/media-gfx/hugin/ChangeLog b/media-gfx/hugin/ChangeLog
index f5fe30c84208..c503458d73de 100644
--- a/media-gfx/hugin/ChangeLog
+++ b/media-gfx/hugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/hugin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.6 2005/10/16 02:23:49 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.7 2005/11/19 05:10:01 halcy0n Exp $
+
+ 19 Nov 2005; Mark Loeser <halcy0n@gentoo.org>
+ +files/hugin-0.5_rc2-gcc4.patch, hugin-0.5_rc2.ebuild:
+ Add patch to fix compilation with gcc4.
*hugin-0.5_rc1-r2 (16 Oct 2005)
diff --git a/media-gfx/hugin/Manifest b/media-gfx/hugin/Manifest
index 8d71e37ad288..f20dae4e809f 100644
--- a/media-gfx/hugin/Manifest
+++ b/media-gfx/hugin/Manifest
@@ -1,16 +1,17 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 1ed8119f144d77d0ce8ac4d981b4f5d8 ChangeLog 1179
+MD5 e2ea169a87e1e2719c0f669cc66d7e12 ChangeLog 1327
MD5 549db5b9b4146eb8aff8a35d39eabf1e files/digest-hugin-0.5_rc1-r2 67
MD5 fca5e4ab4e2444d69d18b311f6a5591f files/digest-hugin-0.5_rc2 67
+MD5 12a2513bc1428c9adcadbd78ee32ecdd files/hugin-0.5_rc2-gcc4.patch 1701
MD5 497db1fa2082827dd88807dffec1fe22 hugin-0.5_rc1-r2.ebuild 1483
-MD5 a55ec4c60a26b13c55062ed165600b90 hugin-0.5_rc2.ebuild 1485
+MD5 38c122d86a314a131edbdf69926ffbde hugin-0.5_rc2.ebuild 1542
MD5 958a93f482686868d880a8b448d0899d metadata.xml 324
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDUbnHCRZPokWLroQRAqy6AJ9DeMrzVl1qKf4kLCK2CW9v8n1tUwCfe46q
-eWBIgpOu716KfXIUyzqunAc=
-=NC0I
+iD8DBQFDfrO0CRZPokWLroQRAnlBAKDWJcgInQW7kd44tFctkjZpgs5GQwCfdETd
+ffDjbDdTSxAoRv5SJ4MuM2g=
+=D19l
-----END PGP SIGNATURE-----
diff --git a/media-gfx/hugin/files/hugin-0.5_rc2-gcc4.patch b/media-gfx/hugin/files/hugin-0.5_rc2-gcc4.patch
new file mode 100644
index 000000000000..0499699bc172
--- /dev/null
+++ b/media-gfx/hugin/files/hugin-0.5_rc2-gcc4.patch
@@ -0,0 +1,34 @@
+===================================================================
+RCS file: /cvsroot/hugin/hugin/src/include/PT/RemappedPanoImage.h,v
+retrieving revision 1.8
+retrieving revision 1.9
+diff -u -r1.8 -r1.9
+--- hugin/hugin/src/include/PT/RemappedPanoImage.h 2005/05/11 18:13:12 1.8
++++ hugin/hugin/src/include/PT/RemappedPanoImage.h 2005/11/16 18:50:05 1.9
+@@ -6,7 +6,7 @@
+ *
+ * @author Pablo d'Angelo <pablo.dangelo@web.de>
+ *
+- * $Id: hugin-0.5_rc2-gcc4.patch,v 1.1 2005/11/19 05:10:01 halcy0n Exp $
++ * $Id: hugin-0.5_rc2-gcc4.patch,v 1.1 2005/11/19 05:10:01 halcy0n Exp $
+ *
+ * This is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public
+@@ -436,8 +436,7 @@
+
+ if (imgOpts.docrop) {
+ vigra::BImage alpha(srcImgSize,255);
+-
+- if (pano.getLens(pano.getImage(imgNr)).getProjection() == Lens::CIRCULAR_FISHEYE) {
++ if (pano.getLens(img.getLensNr()).getProjection() == Lens::CIRCULAR_FISHEYE) {
+ FDiff2D m( (imgOpts.cropRect.left() + imgOpts.cropRect.width()/2.0) * scale,
+ (imgOpts.cropRect.top() + imgOpts.cropRect.height()/2.0) * scale);
+
+@@ -494,7 +493,6 @@
+ vigra::BImage alpha(srcImgSize);
+ vigra::copyImage(vigra::make_triple(alphaImg.first, alphaImg.first + srcImgSize, alphaImg.second),
+ vigra::destImage(alpha));
+-
+ if (pano.getLens(img.getLensNr()).getProjection() == Lens::CIRCULAR_FISHEYE) {
+ FDiff2D m( (imgOpts.cropRect.left() + imgOpts.cropRect.width()/2.0) * scale,
+ (imgOpts.cropRect.top() + imgOpts.cropRect.height()/2.0) * scale);
diff --git a/media-gfx/hugin/hugin-0.5_rc2.ebuild b/media-gfx/hugin/hugin-0.5_rc2.ebuild
index 77ced715c8dc..31bb30ef7596 100644
--- a/media-gfx/hugin/hugin-0.5_rc2.ebuild
+++ b/media-gfx/hugin/hugin-0.5_rc2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.5_rc2.ebuild,v 1.1 2005/10/01 20:11:13 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-0.5_rc2.ebuild,v 1.2 2005/11/19 05:10:01 halcy0n Exp $
-inherit wxwidgets
+inherit wxwidgets eutils
DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
@@ -26,6 +26,9 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+
sed -i -e 's/autopanog\.exe/autopanog/' "${S}"/src/include/hugin/config_defaults.h
}