summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-01-21 22:32:37 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-01-21 22:32:37 +0000
commit359d5debffc78f02f11cf7adfe8840bc6e092ff4 (patch)
treec92d9d1beef1aa89bd9d62e9cdadeaff868d8e82 /media-gfx/graphviz
parentadded elogind support #13790 (diff)
downloadhistorical-359d5debffc78f02f11cf7adfe8840bc6e092ff4.tar.gz
historical-359d5debffc78f02f11cf7adfe8840bc6e092ff4.tar.bz2
historical-359d5debffc78f02f11cf7adfe8840bc6e092ff4.zip
another libpng-1.0 related fix
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/ChangeLog13
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-1.8.10-r31
-rw-r--r--media-gfx/graphviz/graphviz-1.8.10-r3.ebuild74
3 files changed, 85 insertions, 3 deletions
diff --git a/media-gfx/graphviz/ChangeLog b/media-gfx/graphviz/ChangeLog
index b4e4a69ff029..eb37949c9fad 100644
--- a/media-gfx/graphviz/ChangeLog
+++ b/media-gfx/graphviz/ChangeLog
@@ -1,10 +1,17 @@
# ChangeLog for media-gfx/graphviz
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.6 2003/01/15 00:54:28 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/ChangeLog,v 1.7 2003/01/21 22:32:37 george Exp $
-*graphviz-1.8.10-r1 (14 Jan 2003)
+*graphviz-1.8.10-r3 (21 Jan 2003)
- 14 jan 2003; George Shapovalov <george@gentoo.org> graphviz-1.8.10-r1.ebuild :
+ 21 Jan 2003; George Shapovalov <george@gentoo.org> graphviz-1.8.10-r3.ebuild :
+ Another libpng-1.0 related fix. Now made sure all -lpng are replaced by lpng10, as quite often
+ gcc tries to link against libpng.so.3 instead of libpng.so.2. See #12433.
+ As the fixed problem tends to lead to silent failures, -r bumping the ebuild to force rebuild.
+
+*graphviz-1.8.10-r2 (14 Jan 2003)
+
+ 14 Jan 2003; George Shapovalov <george@gentoo.org> graphviz-1.8.10-r2.ebuild :
Following up on seemant's fix to libpng-1.0 series upated the graphviz ebuild to link against correct
version of libpng. Please see #10726 for more details.
diff --git a/media-gfx/graphviz/files/digest-graphviz-1.8.10-r3 b/media-gfx/graphviz/files/digest-graphviz-1.8.10-r3
new file mode 100644
index 000000000000..83e5bdee4202
--- /dev/null
+++ b/media-gfx/graphviz/files/digest-graphviz-1.8.10-r3
@@ -0,0 +1 @@
+MD5 7c9663c8e2cde4f7edc2b412cc148330 graphviz-1.8.10.tar.gz 2837389
diff --git a/media-gfx/graphviz/graphviz-1.8.10-r3.ebuild b/media-gfx/graphviz/graphviz-1.8.10-r3.ebuild
new file mode 100644
index 000000000000..38c968812e03
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-1.8.10-r3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.8.10-r3.ebuild,v 1.1 2003/01/21 22:32:37 george Exp $
+
+IUSE="tcltk"
+
+DESCRIPTION="open source graph drawing software"
+SRC_URI="http://www.graphviz.org/pub/graphviz/${P}.tar.gz"
+HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
+
+SLOT="0"
+LICENSE="as-is | ATT"
+KEYWORDS="~x86 ~ppc"
+
+#Can use freetype-1.3 or 2.0, but not both
+#!!!requires libpng-1.0.x!!!
+DEPEND=">=sys-libs/zlib-1.1.3
+ =media-libs/libpng-1.0*
+ >=media-libs/jpeg-6b
+ media-libs/freetype
+ tcltk? ( =dev-lang/tk-8.3* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ mv configure configure-orig
+ sed -e "s:lpng:lpng10:" configure-orig > configure
+ chmod a+x configure
+ mv Config.mk Config.mk-orig
+ sed -e "s:lpng:lpng10:" Config.mk-orig > Config.mk
+
+ cd gd
+ mv Makefile.orig Makefile.orig-orig
+ sed -e "s:lpng:lpng10:" Makefile.orig-orig > Makefile.orig
+ mv nmakefile nmakefile-orig
+ sed -e "s:lpng:lpng10:" nmakefile-orig > nmakefile
+
+ cd ../contrib
+ mv Makefile Makefile-orig
+ sed -e "s:lpng:lpng10:" Makefile-orig>Makefile
+ cd prune
+ mv Makefile Makefile-orig
+ sed -e "s:lpng:lpng10:" Makefile-orig>Makefile
+
+ cd ../../dotneato/common
+ mv nmakefile nmakefile-orig
+ sed -e "s:lpng:lpng10:" nmakefile-orig > nmakefile
+}
+
+src_compile() {
+ local myconf
+ #if no tcltk, this will generate configure warnings, but will
+ #compile without tcltk support
+ use tcltk || myconf="${myconf} --without-tcl --without-tk"
+
+ #libpng-1.0 got tweaked to nicely coexist with libpng-1.2
+ #need to set correct path to the .h's and libs
+ econf ${myconf} \
+ --with-pngincludedir=/usr/include/libpng10/ \
+ --with-pnglibdir=/usr/lib/ || die "./configure failed"
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog FAQ.txt INSTALL MINTERMS.txt \
+ NEWS README
+
+ dohtml -r .
+ dodoc doc/*.pdf
+}