summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-05 13:39:18 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-05 13:39:18 +0000
commit31e0969a7d56a936e9be86f9710a1a87253afe20 (patch)
tree6672ffc96591233051774d011f335474dd0c3316 /media-gfx/gimp/gimp-1.2.5.ebuild
parentversion bump and many fixes. but don't have key to fix :/ (diff)
downloadhistorical-31e0969a7d56a936e9be86f9710a1a87253afe20.tar.gz
historical-31e0969a7d56a936e9be86f9710a1a87253afe20.tar.bz2
historical-31e0969a7d56a936e9be86f9710a1a87253afe20.zip
protection against over optimisation
Diffstat (limited to 'media-gfx/gimp/gimp-1.2.5.ebuild')
-rw-r--r--media-gfx/gimp/gimp-1.2.5.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/media-gfx/gimp/gimp-1.2.5.ebuild b/media-gfx/gimp/gimp-1.2.5.ebuild
index c35fc805e30b..ef793346240b 100644
--- a/media-gfx/gimp/gimp-1.2.5.ebuild
+++ b/media-gfx/gimp/gimp-1.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.5.ebuild,v 1.3 2003/06/19 23:45:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.2.5.ebuild,v 1.4 2003/07/05 13:39:10 liquidx Exp $
inherit eutils flag-o-matic
@@ -42,6 +42,8 @@ src_compile() {
replace-flags -march=k6-2 -march=i586
replace-flags -march=k6-3 -march=i586
replace-flags -march=k6 -march=i586
+ # over-optimisations (#21787)
+ replace-flags -Os -O2
# gimp has inline functions (plug-ins/common/grid.c) (#23078)
filter-flags "-fno-inline"