summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-01-22 20:22:39 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-01-22 20:22:39 +0000
commitf134bbde5b48a4b3f8faefcd7db7ba793b23d76e (patch)
tree084a2e159e364cd562e171ee0bfef78955619cf6 /lxde-base/lxde-common/lxde-common-0.5.0.ebuild
parentNew package lxde-icon-theme , which was splitted from lxde-common and contain... (diff)
downloadhistorical-f134bbde5b48a4b3f8faefcd7db7ba793b23d76e.tar.gz
historical-f134bbde5b48a4b3f8faefcd7db7ba793b23d76e.tar.bz2
historical-f134bbde5b48a4b3f8faefcd7db7ba793b23d76e.zip
Version bump to 0.5.0
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'lxde-base/lxde-common/lxde-common-0.5.0.ebuild')
-rw-r--r--lxde-base/lxde-common/lxde-common-0.5.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/lxde-base/lxde-common/lxde-common-0.5.0.ebuild b/lxde-base/lxde-common/lxde-common-0.5.0.ebuild
new file mode 100644
index 000000000000..cca143044b8e
--- /dev/null
+++ b/lxde-base/lxde-common/lxde-common-0.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/lxde-common-0.5.0.ebuild,v 1.1 2010/01/22 20:22:38 vostorga Exp $
+
+EAPI="1"
+
+inherit eutils
+
+DESCRIPTION="LXDE Session default configuration files and nuoveXT2 iconset"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+PDEPEND="lxde-base/lxde-icon-theme"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-session-fix.patch
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "${P} has renamed the configuration file name to"
+ elog "/etc/xdg/lxsession/LXDE/desktop.conf"
+ elog "Keep in mind you have to migrate your custom settings"
+ elog "from /etc/xdg/lxsession/LXDE/config"
+}