summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-10-31 05:28:59 +0000
committerDan Armak <danarmak@gentoo.org>2002-10-31 05:28:59 +0000
commit526d0ca96dfb6d6a2802616e2d291b740ae70b6a (patch)
tree590e9c8fb1d6f5826c1eb159d8d264cd3aa9bc70 /kde-base
parentmask kde 3.1 rc1 (diff)
downloadhistorical-526d0ca96dfb6d6a2802616e2d291b740ae70b6a.tar.gz
historical-526d0ca96dfb6d6a2802616e2d291b740ae70b6a.tar.bz2
historical-526d0ca96dfb6d6a2802616e2d291b740ae70b6a.zip
kde 3.1 rc1
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/arts/arts-1.1.0.1.ebuild45
-rw-r--r--kde-base/arts/files/digest-arts-1.1.0.11
-rw-r--r--kde-base/kde-env/kde-env-3.1_rc1.ebuild0
-rw-r--r--kde-base/kde/kde-3.1_rc1.ebuild13
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.1_rc1.ebuild26
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.1_rc11
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.1_rc1.ebuild17
-rw-r--r--kde-base/kdeartwork/kdeartwork-3.1_rc1.ebuild16
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.1_rc11
-rw-r--r--kde-base/kdebase/files/startkde-3.1_rc1-gentoo.diff61
-rw-r--r--kde-base/kdebase/kdebase-3.1_rc1.ebuild95
-rw-r--r--kde-base/kdebindings/kdebindings-3.1_rc1.ebuild39
-rw-r--r--kde-base/kdeedu/files/kdeedu-3.1_rc1-errno.diff19
-rw-r--r--kde-base/kdeedu/kdeedu-3.1_rc1.ebuild12
-rw-r--r--kde-base/kdegames/files/digest-kdegames-3.1_rc11
-rw-r--r--kde-base/kdegames/kdegames-3.1_rc1.ebuild8
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.1_rc1.ebuild30
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1_rc11
-rw-r--r--kde-base/kdelibs/kdelibs-3.1_rc1.ebuild93
-rw-r--r--kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_rc11
-rw-r--r--kde-base/kdemultimedia/files/kdemultimedia-3.1_rc1-gentoo-timidity.diff21
-rw-r--r--kde-base/kdemultimedia/files/kdemultimedia-3.1_rc1-ln-sf.diff29
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.1_rc1.ebuild70
-rw-r--r--kde-base/kdenetwork/files/digest-kdenetwork-3.1_rc11
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.1_rc1.ebuild30
-rw-r--r--kde-base/kdepim/kdepim-3.1_rc1.ebuild20
-rw-r--r--kde-base/kdesdk/kdesdk-3.1_rc1.ebuild7
-rw-r--r--kde-base/kdetoys/kdetoys-3.1_rc1.ebuild8
-rw-r--r--kde-base/kdeutils/kdeutils-3.1_rc1.ebuild7
29 files changed, 673 insertions, 0 deletions
diff --git a/kde-base/arts/arts-1.1.0.1.ebuild b/kde-base/arts/arts-1.1.0.1.ebuild
new file mode 100644
index 000000000000..e7eb70878e54
--- /dev/null
+++ b/kde-base/arts/arts-1.1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.1.0.1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-base flag-o-matic
+
+# this is the arts 1.1.0 rfom kde 3.1 rc1, as opposed to the arta 1.1.0 rfom kde 3.1 beta2
+
+S=$WORKDIR/$PN-1.1.0
+SRC_URI="mirror://gentoo/arts-1.1.0-kde31rc1.tar.bz2"
+KEYWORDS="x86"
+HOMEPAGE="http://multimedia.kde.org"
+DESCRIPTION="KDE Sound Server"
+set-kdedir 3.1_rc1
+need-qt 3.1.0_pre20021024
+
+if [ "${COMPILER}" == "gcc3" ]; then
+ # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
+ # these.. Even starting a compile shuts down the arts server
+ filter-flags "-fomit-frame-pointer -fstrength-reduce"
+fi
+
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+
+use alsa && myconf="$myconf --enable-alsa" || myconf="$myconf --disable-alsa"
+
+src_unpack() {
+
+ base_src_unpack
+
+ kde_sandbox_patch ${S}/soundserver
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ # fix root exploit
+ # fixed on kde cvs, not needed anymore
+ # chmod ug-s ${D}${KDEDIR}/bin/artswrapper
+
+ dodoc ${S}/doc/{NEWS,README,TODO}
+
+}
diff --git a/kde-base/arts/files/digest-arts-1.1.0.1 b/kde-base/arts/files/digest-arts-1.1.0.1
new file mode 100644
index 000000000000..0b4cbf7d1058
--- /dev/null
+++ b/kde-base/arts/files/digest-arts-1.1.0.1
@@ -0,0 +1 @@
+MD5 5e36524c0654e2ed778733f2de489b5c arts-1.1.0-kde31rc1.tar.bz2 1081375
diff --git a/kde-base/kde-env/kde-env-3.1_rc1.ebuild b/kde-base/kde-env/kde-env-3.1_rc1.ebuild
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/kde-base/kde-env/kde-env-3.1_rc1.ebuild
diff --git a/kde-base/kde/kde-3.1_rc1.ebuild b/kde-base/kde/kde-3.1_rc1.ebuild
new file mode 100644
index 000000000000..c945f8afa0f4
--- /dev/null
+++ b/kde-base/kde/kde-3.1_rc1.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde/kde-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+
+KEYWORDS="x86"
+DESCRIPTION="KDE 3.1 RC 1 - merge this to pull in all non-developer kde-base/* packages"
+HOMEPAGE="http://www.kde.org/"
+# removed: kdebindings, kdesdk, kdoc since these are developer-only packages
+RDEPEND="`echo ~kde-base/kde{libs,base,addons,admin,artwork,edu,games,graphics,multimedia,network,pim,toys,utils}-${PV}`"
+
+LICENSE="GPL-2"
+
+SLOT="3.1"
diff --git a/kde-base/kdeaddons/kdeaddons-3.1_rc1.ebuild b/kde-base/kdeaddons/kdeaddons-3.1_rc1.ebuild
new file mode 100644
index 000000000000..c52738106598
--- /dev/null
+++ b/kde-base/kdeaddons/kdeaddons-3.1_rc1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist flag-o-matic
+
+DESCRIPTION="KDE $PV: addons - applets, plugins..."
+KEYWORDS="x86"
+
+newdepend "~kde-base/kdebase-${PV}
+ ~kde-base/kdenetwork-${PV}
+ ~kde-base/kdemultimedia-${PV}
+ ~kde-base/kdegames-${PV}
+ sdl? ( >=media-libs/libsdl-1.2 )
+ svga? ( media-libs/svgalib )
+ xmms? ( media-sound/xmms )"
+
+use sdl && myconf="$myconf --with-sdl --with-sdl-prefix=/usr" || myconf="$myconf --without-sdl --disable-sdltest"
+
+use xmms || export ac_cv_have_xmms=no
+
+# fix bug #7625
+if [ "$COMPILER" == "gcc3" ]; then
+ if [ -n "`is-flag -march=pentium4`" -o -n "`is-flag -mcpu=pentium4`" ]; then
+ append-flags -mno-sse2
+ fi
+fi
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.1_rc1 b/kde-base/kdeadmin/files/digest-kdeadmin-3.1_rc1
new file mode 100644
index 000000000000..0dbf84163918
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.1_rc1
@@ -0,0 +1 @@
+MD5 a4a95431a6bbf9a53e1e369320801a74 kdeadmin-3.0.9.tar.bz2 1580593
diff --git a/kde-base/kdeadmin/kdeadmin-3.1_rc1.ebuild b/kde-base/kdeadmin/kdeadmin-3.1_rc1.ebuild
new file mode 100644
index 000000000000..9915199c1372
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.1_rc1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - administration tools"
+
+KEYWORDS="x86"
+
+newdepend ">=app-arch/rpm-4.0.4-r1
+ dev-libs/popt
+ pam? ( >=sys-libs/pam-0.72 )"
+
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --without-pam --with-shadow"
+myconf="$myconf --without-rpm"
+
+# TODO: add nis support
diff --git a/kde-base/kdeartwork/kdeartwork-3.1_rc1.ebuild b/kde-base/kdeartwork/kdeartwork-3.1_rc1.ebuild
new file mode 100644
index 000000000000..d29e43a44a0d
--- /dev/null
+++ b/kde-base/kdeartwork/kdeartwork-3.1_rc1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/kdeartwork-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+newdepend "opengl? ( virtual/opengl ) ~kde-base/kdebase-${PV}"
+
+DESCRIPTION="KDE $PV - artwork"
+
+KEYWORDS="x86"
+
+myconf="$myconf --with-dpms"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+
+PATCHES="$FILESDIR/xsaver-conflicting-typedefs.diff"
+
diff --git a/kde-base/kdebase/files/digest-kdebase-3.1_rc1 b/kde-base/kdebase/files/digest-kdebase-3.1_rc1
new file mode 100644
index 000000000000..166dd690aa51
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.1_rc1
@@ -0,0 +1 @@
+MD5 2abdd2fa78fe47f1074bf85308d589a5 kdebase-3.0.9.tar.bz2 14895004
diff --git a/kde-base/kdebase/files/startkde-3.1_rc1-gentoo.diff b/kde-base/kdebase/files/startkde-3.1_rc1-gentoo.diff
new file mode 100644
index 000000000000..796065e74678
--- /dev/null
+++ b/kde-base/kdebase/files/startkde-3.1_rc1-gentoo.diff
@@ -0,0 +1,61 @@
+--- startkde 2002-09-16 00:08:25.000000000 +0300
++++ startkde 2002-10-01 14:02:59.000000000 +0300
+@@ -1,8 +1,28 @@
+-#!/bin/sh
++#!/bin/sh --login
+ #
+-# DEFAULT KDE STARTUP SCRIPT ( KDE-3.1 )
++# GENTOO CUSTOMIZED KDE STARTUP SCRIPT ( KDE-3.1 )
+ #
+
++# Gentoo part:
++export PATH="_KDEDIR_/bin:${PATH}"
++export KDEDIR="_KDEDIR_"
++export KDEDIRS="_KDEDIR_:/usr" # do NOT add env.d's KDEDIRS
++
++cd ~
++[ -d .kde ] && mv .kde .kde.backup
++if [ ! -e .kde3.1 ]; then
++ if [ -e .kde3 ]; then
++ cp -r .kde3 .kde3.1
++ else
++ mkdir .kde3.1
++ fi
++fi
++ln -sf .kde3.1 .kde
++
++#export KDEHOME="${HOME}/.kdecvs"
++
++# Gentoo part ends
++
+ # Boot sequence:
+ #
+ # kdeinit is used to fork off processes which improves memory usage
+@@ -25,12 +45,12 @@
+ # especially necessary on slow machines, where starting KDE takes one or two
+ # minutes until anything appears on the screen.
+ #
+-# Set the background to plain grey.
++# Set the background to cyan (Gentoo version change).
+ # The standard X background is nasty, causing moire effects and exploding
+ # people's heads. We use colours from the standard KDE palette for those with
+ # palettised displays.
+
+-test "$XDM_MANAGED" || bkg="-solid #C0C0C0"
++test "$XDM_MANAGED" || bkg="-solid #5477A0"
+ xsetroot -cursor_name left_ptr $bkg
+
+ # The user's personal KDE directory is usually ~/.kde, but this setting
+@@ -134,7 +154,11 @@
+ fi
+
+ # the splashscreen and progress indicator
+-ksplash
++if [ -n "$KSPLASH" ]; then
++ $KSPLASH
++else
++ ksplash
++fi
+
+ # We set LD_BIND_NOW to increase the efficiency of kdeinit.
+ # kdeinit unsets this variable before loading applications.
diff --git a/kde-base/kdebase/kdebase-3.1_rc1.ebuild b/kde-base/kdebase/kdebase-3.1_rc1.ebuild
new file mode 100644
index 000000000000..a74e7e7499a1
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.1_rc1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - base packages: the desktop, panel, window manager, konqueror..."
+
+KEYWORDS="x86"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ encode? ( >=media-sound/lame-3.89b )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ opengl? ( virtual/opengl )
+ samba? ( net-fs/samba )
+ >=media-libs/freetype-2"
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+myconf="$myconf --with-dpms --with-cdparanoia"
+
+use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+use motif && myconf="$myconf --with-motif" || myconf="$myconf --without-motif"
+use encode && myconf="$myconf --with-lame" || myconf="$myconf --without-lame"
+use cups && myconf="$myconf --with-cups" || myconf="$myconf --disable-cups"
+use oggvorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
+use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+
+src_compile() {
+
+ kde_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde_src_compile make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ # cf bug #5953
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins ${FILESDIR}/kde.pam kde
+
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ patch -p0 < ${FILESDIR}/startkde-${PVR}-gentoo.diff || die
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ rm startkde.orig
+ chmod a+x startkde
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ mv kdmrc kdmrc.orig
+ sed -e "s:SessionTypes=:SessionTypes=kde-${PV},:" \
+ -e "s:Session=${PREFIX}/share/config/kdm/Xsession:Session=/etc/X11/xdm/Xsession:" kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+ #backup splashscreen images, so they can be put back when unmerging
+ #mosfet or so.
+ if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
+ then
+ cd ${D}/${KDEDIR}/share/apps
+ cp -rf ksplash/ ksplash.default
+ fi
+
+ # Show gnome icons when choosing new icon for desktop shortcut
+ mkdir -p ${D}/usr/share/pixmaps
+ mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
+ cd ${D}/${KDEDIR}/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+
+}
+
+pkg_postinst() {
+ mkdir -p ${KDEDIR}/share/templates/.source/emptydir
+}
diff --git a/kde-base/kdebindings/kdebindings-3.1_rc1.ebuild b/kde-base/kdebindings/kdebindings-3.1_rc1.ebuild
new file mode 100644
index 000000000000..3f4690ebb014
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.1_rc1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+# TODO: add gnustep, objc bindings
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - kde library bindings for languages other than c++"
+
+KEYWORDS="x86"
+
+newdepend "~kde-base/kdebase-${PV}
+ =x11-libs/gtk+-1.2*
+ sys-devel/perl
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ ~kde-base/kdenetwork-${PV}
+ mozilla? ( net-www/mozilla )"
+
+use python || myconf="$myconf --without-python"
+use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
+#myconf="$myconf --enable-objc"
+
+export LIBPYTHON="`python-config`"
+
+#src_unpack()
+#{
+# base_src_unpack
+#
+# if [ -z "`use mozilla`" ]; then
+# # disable mozilla bindings/xpart
+# cd ${S}
+# cp configure configure.orig
+# sed -e 's:mozilla_incldirs=:# mozilla_incldirs=:' configure.orig > configure
+# chmod +x configure
+# fi
+#}
+
diff --git a/kde-base/kdeedu/files/kdeedu-3.1_rc1-errno.diff b/kde-base/kdeedu/files/kdeedu-3.1_rc1-errno.diff
new file mode 100644
index 000000000000..a86bb2b42ad9
--- /dev/null
+++ b/kde-base/kdeedu/files/kdeedu-3.1_rc1-errno.diff
@@ -0,0 +1,19 @@
+--- kmplot/kmplot/View.cpp Mon Jul 15 23:34:49 2002
++++ kmplot/kmplot/View.cpp Sun Jul 21 12:33:25 2002
+@@ -1,6 +1,6 @@
+ #include "View.h"
+ #include "View.moc"
+-
++#include <errno.h>
+
+ View::View( QWidget* parent, const char* name ) : QWidget( parent, name )
+ {
+@@ -151,7 +151,7 @@
+ mflg = 2;
+ for ( x = dmin; x < dmax; x += dx )
+ {
+- int errno = 0;
++ errno = 0;
+ switch ( p_mode )
+ {
+ case 0:
diff --git a/kde-base/kdeedu/kdeedu-3.1_rc1.ebuild b/kde-base/kdeedu/kdeedu-3.1_rc1.ebuild
new file mode 100644
index 000000000000..68b78e0a8aa1
--- /dev/null
+++ b/kde-base/kdeedu/kdeedu-3.1_rc1.ebuild
@@ -0,0 +1,12 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeedu/kdeedu-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - educational apps"
+
+KEYWORDS="x86"
+
+PATCHES="$FILESDIR/$P-errno.diff"
+
+newdepend "!>=app-sci/kstars-0.9"
diff --git a/kde-base/kdegames/files/digest-kdegames-3.1_rc1 b/kde-base/kdegames/files/digest-kdegames-3.1_rc1
new file mode 100644
index 000000000000..115ea7cc9d22
--- /dev/null
+++ b/kde-base/kdegames/files/digest-kdegames-3.1_rc1
@@ -0,0 +1 @@
+MD5 39b812def76f5e49769197c0e3992c35 kdegames-3.0.9.tar.bz2 8422836
diff --git a/kde-base/kdegames/kdegames-3.1_rc1.ebuild b/kde-base/kdegames/kdegames-3.1_rc1.ebuild
new file mode 100644
index 000000000000..67204661f349
--- /dev/null
+++ b/kde-base/kdegames/kdegames-3.1_rc1.ebuild
@@ -0,0 +1,8 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegames/kdegames-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - games"
+
+KEYWORDS="x86"
diff --git a/kde-base/kdegraphics/kdegraphics-3.1_rc1.ebuild b/kde-base/kdegraphics/kdegraphics-3.1_rc1.ebuild
new file mode 100644
index 000000000000..d08fae0f2632
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.1_rc1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - graphics-related apps"
+
+KEYWORDS="x86"
+
+newdepend "gphoto2? ( >=media-gfx/gphoto2-2.0_beta1 >=media-libs/libgpio-20010607 )
+ sys-devel/perl
+ scanner? ( media-gfx/sane-backends )
+ tetex? ( >=app-text/tetex-1.0.7 )
+ media-libs/imlib
+ app-text/ghostscript
+ virtual/glut virtual/opengl
+ !media-gfx/kpovmodeler" # kpovmodeler's old separate ebuild
+# x86? ( scanner? sys-libs/libieee1284 )
+
+use gphoto2 && myconf="$myconf --with-kamera --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2 \
+ --with-gpio --with-gpio-includes=/usr/include \
+ --with-gpio-libraries=/usr/lib" || myconf="$myconf --without-kamera"
+
+use tetex && myconf="$myconf --with-system-kpathsea --with-tex-datadir=/usr/share"
+
+use scanner || KDE_REMOVE_DIR="kooka libkscan"
+
+myconf="$myconf --with-imlib --with-imlib-config=/usr/bin"
+
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1_rc1 b/kde-base/kdelibs/files/digest-kdelibs-3.1_rc1
new file mode 100644
index 000000000000..6ad484e4a177
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1_rc1
@@ -0,0 +1 @@
+MD5 132810c1665ac5baed911e6f3475e907 kdelibs-3.0.9.tar.bz2 10549231
diff --git a/kde-base/kdelibs/kdelibs-3.1_rc1.ebuild b/kde-base/kdelibs/kdelibs-3.1_rc1.ebuild
new file mode 100644
index 000000000000..07372b082257
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1_rc1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde kde.org
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+# check need for glib >=1.3.3 (we have 1.2.10 only; configure has no glib flag but searches for it)
+
+DESCRIPTION="KDE $PV - base libraries needed by all kde programs"
+KEYWORDS="x86"
+HOMEPAGE="http//www.kde.org/"
+SLOT="5.0"
+LICENSE="GPL-2 LGPL-2"
+S=$WORKDIR/$PN-3.0.9
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ ~kde-base/arts-1.1.0.1
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python
+ >=sys-apps/portage-2.0.36" # for #7359
+
+myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+#set_enable_final
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+
+ base_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+ use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+ use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+ [ "$ARCH" != "ppc" ] && \
+ [ "$ARCH" != "sparc" ] && [ "$ARCH" != "sparc64" ] && \
+ myconf="$myconf --enable-fast-malloc=full"
+
+ kde_src_compile configure make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+KDEDIRS=${PREFIX}
+CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/49kdelibs-${PV} # number goes down with version upgrade
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/56kdedir-${PV} # number goes up with version upgrade
+
+}
+
+
diff --git a/kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_rc1 b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_rc1
new file mode 100644
index 000000000000..6cddea808c3e
--- /dev/null
+++ b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.1_rc1
@@ -0,0 +1 @@
+MD5 0e97c83d40ff7c8064a90229e11d33fa kdemultimedia-3.0.9.tar.bz2 6113555
diff --git a/kde-base/kdemultimedia/files/kdemultimedia-3.1_rc1-gentoo-timidity.diff b/kde-base/kdemultimedia/files/kdemultimedia-3.1_rc1-gentoo-timidity.diff
new file mode 100644
index 000000000000..f392a244212e
--- /dev/null
+++ b/kde-base/kdemultimedia/files/kdemultimedia-3.1_rc1-gentoo-timidity.diff
@@ -0,0 +1,21 @@
+diff -ru kdemultimedia-2.2.1.orig/kmidi/TIMIDITY/motif_p.c kdemultimedia-2.2.1/kmidi/TIMIDITY/motif_p.c
+--- kmidi/TIMIDITY/motif_p.c Mon Feb 28 19:07:37 2000
++++ kmidi/TIMIDITY/motif_p.c Fri Oct 19 04:00:10 2001
+@@ -22,6 +22,7 @@
+ pipe communication between motif interface and sound generator
+
+ */
++#include <sys/errno.h>
+ #ifdef IA_MOTIF
+
+ #include <stdio.h>
+--- kmidi/TIMIDITY/tk_c.c 2002-04-04 21:15:35.000000000 -0600
++++ kmidi/TIMIDITY/tk_c.c 2002-04-04 21:17:06.000000000 -0600
+@@ -12,6 +12,7 @@
+ *================================================================*/
+ #ifdef TCLTK
+
++#include <sys/errno.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
diff --git a/kde-base/kdemultimedia/files/kdemultimedia-3.1_rc1-ln-sf.diff b/kde-base/kdemultimedia/files/kdemultimedia-3.1_rc1-ln-sf.diff
new file mode 100644
index 000000000000..ee6daa91f3dc
--- /dev/null
+++ b/kde-base/kdemultimedia/files/kdemultimedia-3.1_rc1-ln-sf.diff
@@ -0,0 +1,29 @@
+--- kmidi/TIMIDITY/makelinks Sat Aug 24 11:36:27 2002
++++ kmidi/TIMIDITY/makelinks Sat Aug 24 11:36:15 2002
+@@ -3,7 +3,7 @@ srcdir=$1
+ for header in common config controls ctl effects filter instrum mix \
+ output playmidi readmidi resample sbk sflayer tables \
+ version ; do
+- if [ ! -h ${header}.h ]; then ln -s ${srcdir}/${header}.h . ; fi
++ if [ ! -h ${header}.h ]; then ln -sf ${srcdir}/${header}.h . ; fi
+ done
+
+ for cfile in alsa_a arts_a b_out bag bsd20_a celeste_e chorus_e \
+@@ -13,14 +13,14 @@ for cfile in alsa_a arts_a b_out bag bsd
+ playmidi raw_a readmidi readsbk resample resample_f \
+ resample_l reverb_e sbktext sf2cfg slang_c sndfont \
+ sun_a tables timidity wav2pat wave_a ; do
+- if [ ! -h ${cfile}.c ]; then ln -s ${srcdir}/${cfile}.cpp ${cfile}.c ; fi
++ if [ ! -h ${cfile}.c ]; then ln -sf ${srcdir}/${cfile}.cpp ${cfile}.c ; fi
+ done
+
+ for lfile in cfg ; do
+- if [ ! -h ${lfile}.l ]; then ln -s ${srcdir}/${lfile}.l . ; fi
++ if [ ! -h ${lfile}.l ]; then ln -sf ${srcdir}/${lfile}.l . ; fi
+ done
+
+ # LEAVE THIS ONE AT THE END!!
+ for other in BITMAPS ; do
+- if [ ! -h ${other} ]; then ln -s ${srcdir}/${other} . ; fi
++ if [ ! -h ${other} ]; then ln -sf ${srcdir}/${other} . ; fi
+ done
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.1_rc1.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.1_rc1.ebuild
new file mode 100644
index 000000000000..201e2d66e1c1
--- /dev/null
+++ b/kde-base/kdemultimedia/kdemultimedia-3.1_rc1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist flag-o-matic
+
+DESCRIPTION="KDE $PV - multimedia apps"
+KEYWORDS="x86"
+
+newdepend ">=sys-libs/ncurses-5.2
+ >=media-sound/cdparanoia-3.9.8
+ >=media-libs/libvorbis-1.0_beta4
+ >=media-video/xanim-2.80.1
+ nas? ( >=media-libs/nas-1.4.1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ slang? ( >=sys-libs/slang-1.4.4 )
+ >=media-sound/mpg123-0.59r
+ tcltk? ( >=dev-lang/tk-8.0.5-r2 )
+ >=dev-libs/glib-1.3.3
+ oggvorbis? ( media-libs/libvorbis )"
+ #>=media-libs/xine-lib-0.9.14" # not yet available
+ #gtk? ( =x11-libs/gtk+-1.2* )
+# alsa? ( >=media-libs/alsa-lib-0.5.9 )"
+
+RDEPEND="$RDEPEND
+ cdr? ( app-cdr/cdrtools
+ >=app-cdr/cdrdao-1.1.5 )"
+
+replace-flags "-O3" "-O2"
+
+myaudio="--enable-audio=oss"
+myinterface="--enable-interface=xaw,ncurses"
+myconf="$myconf --enable-xaw --enable-ncurses"
+#myconf="$myconf --with-xine-prefix=/usr"
+
+# make -j2 fails
+#export MAKEOPTS="-j1"
+PATCHES="$FILESDIR/$P-gentoo-timidity.diff
+ $FILESDIR/$P-ln-sf.diff"
+
+# alsa 0.9 not supported
+#use alsa && myconf="$myconf --with-alsa --with-arts-alsa" && myaudio="$myaudio,alsa" || myconf="$myconf --without-alsa --disable-alsa"
+use nas && myaudio="$myaudio,nas --with-nas-library=/usr/X11R6/lib/libaudio.so --with-nas-includes=/usr/X11R6/include" || myconf="$myconf --disable-nas"
+use esd && myaudio="$myaudio,esd" || myconf="$myconf --disable-esd"
+use motif && myinterface="$myinterface,motif" && myconf="$myconf --enable-motif"
+# kmidi/TIMIDITY miscompiles with gtk
+#use gtk && myinterface="$myinterface,gtk" && myconf="$myconf --enable-gtk"
+use slang && myinterface="$myinterface,slang" && myconf="$myconf --enable-slang"
+use tcltk && myinterface="$myinterface,tcltk" && myconf="$myconf --enable-tcltk"
+use oggvorbis && myconf="$myconf --with-vorbis=/usr" || myconf="$myconf --without-vorbis"
+
+use cdr || KDE_REMOVE_DIR="kaudiocreator"
+
+# xine doesn't compile yet
+# also turn off kaudiocreator if cdr isn't in use
+KDE_REMOVE_DIR="xine_artsplugin"
+[ -z "`use cdr`" ] && KDE_REMOVE_DIR="$KDE_REMOVE_DIR kaudiocreator"
+
+myconf="$myconf $myaudio $myinterface"
+
+pkg_postinst() {
+
+ if [ -n "`use alsa`" ]; then
+ einfo "WARNING: alsa support has been removed becuase of a bug in kdemm sources.
+For further information see bug #2324 on bugs.gentoo.org and bug #39574 on bugs.kde.org.
+Meanwhile, you can use the alsa oss emulation."
+ fi
+ return 0
+
+}
diff --git a/kde-base/kdenetwork/files/digest-kdenetwork-3.1_rc1 b/kde-base/kdenetwork/files/digest-kdenetwork-3.1_rc1
new file mode 100644
index 000000000000..4a6fd09a2611
--- /dev/null
+++ b/kde-base/kdenetwork/files/digest-kdenetwork-3.1_rc1
@@ -0,0 +1 @@
+MD5 b2369f4c6c7083dd042f9504beecb03f kdenetwork-3.0.9.tar.bz2 4949959
diff --git a/kde-base/kdenetwork/kdenetwork-3.1_rc1.ebuild b/kde-base/kdenetwork/kdenetwork-3.1_rc1.ebuild
new file mode 100644
index 000000000000..e91146e86139
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-3.1_rc1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - network apps: kmail..."
+KEYWORDS="x86"
+newdepend "~kde-base/kdebase-${PV}"
+
+src_install() {
+
+ kde_src_install
+
+ chmod +s ${D}/${KDEDIR}/bin/reslisa
+
+ # empty config file needed for lisa to work with default settings
+ touch ${D}/etc/lisarc
+
+ # lisa, reslisa initscripts
+ dodir /etc/init.d
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/lisa > ${D}/etc/init.d/lisa
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/reslisa > ${D}/etc/init.d/reslisa
+ chmod +x ${D}/etc/init.d/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lisa.conf lisa
+ newins ${FILESDIR}/reslisa.conf reslisa
+
+}
+
diff --git a/kde-base/kdepim/kdepim-3.1_rc1.ebuild b/kde-base/kdepim/kdepim-3.1_rc1.ebuild
new file mode 100644
index 000000000000..792bbf36b280
--- /dev/null
+++ b/kde-base/kdepim/kdepim-3.1_rc1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim/kdepim-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - PIM (Personal Information Management) apps: korganizer..."
+KEYWORDS="x86"
+DEPEND="$DEPEND sys-devel/perl"
+
+newdepend "pda? ( >=dev-libs/pilot-link-0.11.1-r1 )
+ ~kde-base/kdebase-$PV
+ ~kde-base/kdenetwork-$PV" # mimelib is needed for support of some stuff with exchange servers
+
+use pda && myconf="$myconf --with-extra-includes=/usr/include/libpisock"
+
+src_install() {
+ kde_src_install
+ docinto html
+ dodoc *.html
+}
diff --git a/kde-base/kdesdk/kdesdk-3.1_rc1.ebuild b/kde-base/kdesdk/kdesdk-3.1_rc1.ebuild
new file mode 100644
index 000000000000..b82677b334e0
--- /dev/null
+++ b/kde-base/kdesdk/kdesdk-3.1_rc1.ebuild
@@ -0,0 +1,7 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - SDK: kbabel, ..."
+KEYWORDS="x86"
diff --git a/kde-base/kdetoys/kdetoys-3.1_rc1.ebuild b/kde-base/kdetoys/kdetoys-3.1_rc1.ebuild
new file mode 100644
index 000000000000..0403df2214e1
--- /dev/null
+++ b/kde-base/kdetoys/kdetoys-3.1_rc1.ebuild
@@ -0,0 +1,8 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdetoys/kdetoys-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - toys"
+KEYWORDS="x86"
+
diff --git a/kde-base/kdeutils/kdeutils-3.1_rc1.ebuild b/kde-base/kdeutils/kdeutils-3.1_rc1.ebuild
new file mode 100644
index 000000000000..298f3fc7b5af
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-3.1_rc1.ebuild
@@ -0,0 +1,7 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-3.1_rc1.ebuild,v 1.1 2002/10/31 05:28:59 danarmak Exp $
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - utilities"
+KEYWORDS="x86"