summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-07 11:05:11 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-07 11:05:11 +0000
commit4a4381d8692fbe3a8fc31fa5e386f0914bb304a0 (patch)
treeabf20b1296f6fb4d1cce873f4c7320543eb53ab0 /kde-base/perlqt
parentStable arm, bug #428900 (diff)
downloadhistorical-4a4381d8692fbe3a8fc31fa5e386f0914bb304a0.tar.gz
historical-4a4381d8692fbe3a8fc31fa5e386f0914bb304a0.tar.bz2
historical-4a4381d8692fbe3a8fc31fa5e386f0914bb304a0.zip
Version bump KDE SC 4.8.5
Package-Manager: portage-2.2.0_alpha120/cvs/Linux i686
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.8.5.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index 6e2c6a7bb2c2..56c9c2804c91 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.37 2012/08/01 22:17:30 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.38 2012/08/07 11:04:55 johu Exp $
+
+*perlqt-4.8.5 (07 Aug 2012)
+
+ 07 Aug 2012; Johannes Huber <johu@gentoo.org> +perlqt-4.8.5.ebuild:
+ Version bump KDE SC 4.8.5
*perlqt-4.9.0 (01 Aug 2012)
diff --git a/kde-base/perlqt/perlqt-4.8.5.ebuild b/kde-base/perlqt/perlqt-4.8.5.ebuild
new file mode 100644
index 000000000000..e1528592efbf
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.8.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.8.5.ebuild,v 1.1 2012/08/07 11:04:55 johu Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+KDE_SCM="git"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7.2-vendor.patch"
+ "${FILESDIR}/${PN}-4.8.1-tests.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${CMAKE_BUILD_DIR}/blib/arch:${CMAKE_BUILD_DIR}/blib/lib" kde4-base_src_test
+}