summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-04-12 06:48:25 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-04-12 06:48:25 +0000
commita23836a100f24ca0b06a61c97e212cd1e6153439 (patch)
treebcbc2f814eb11cd7df6aaf4ace6c0abe1da2b29e /kde-base/okular
parentKeep net-www moves in alphabetical order. Fix whitespace. (diff)
downloadhistorical-a23836a100f24ca0b06a61c97e212cd1e6153439.tar.gz
historical-a23836a100f24ca0b06a61c97e212cd1e6153439.tar.bz2
historical-a23836a100f24ca0b06a61c97e212cd1e6153439.zip
Add KDE 4.2.2
Package-Manager: portage-2.2_rc29/cvs/Linux x86_64
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.2.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index 69835b9381ca..4a507892564f 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.29 2009/04/11 17:29:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.30 2009/04/12 06:39:15 alexxy Exp $
+
+*okular-4.2.2 (11 Apr 2009)
+
+ 11 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> +okular-4.2.2.ebuild:
+ Add KDE 4.2.2
11 Apr 2009; Raúl Porcel <armin76@gentoo.org> okular-4.2.1.ebuild:
Add ~alpha/~ia64 wrt #260777
diff --git a/kde-base/okular/okular-4.2.2.ebuild b/kde-base/okular/okular-4.2.2.ebuild
new file mode 100644
index 000000000000..9b3d7b09feb2
--- /dev/null
+++ b/kde-base/okular/okular-4.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.2.2.ebuild,v 1.1 2009/04/12 06:39:15 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdegraphics"
+inherit kde4-meta
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="chm crypt debug djvu doc ebook +jpeg +ps +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( media-libs/jpeg )
+ pdf? ( >=virtual/poppler-qt4-0.8.5 )
+ ps? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with chm CHM)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg JPEG)
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff TIFF)"
+
+ kde4-meta_src_configure
+}