summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-01 20:22:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-01 20:22:21 +0000
commit7a13232fed5821d39c0af7a4a351b0fe5f0a8a84 (patch)
tree1636d3235a911920ce7e9dcf34d08798f846fff5 /kde-base/kdesktop
parentUpdate to new release. (diff)
downloadhistorical-7a13232fed5821d39c0af7a4a351b0fe5f0a8a84.tar.gz
historical-7a13232fed5821d39c0af7a4a351b0fe5f0a8a84.tar.bz2
historical-7a13232fed5821d39c0af7a4a351b0fe5f0a8a84.zip
Update to new release.
Package-Manager: portage-2.1_rc3-r3
Diffstat (limited to 'kde-base/kdesktop')
-rw-r--r--kde-base/kdesktop/ChangeLog7
-rw-r--r--kde-base/kdesktop/files/digest-kdesktop-3.5.33
-rw-r--r--kde-base/kdesktop/kdesktop-3.5.3.ebuild56
3 files changed, 65 insertions, 1 deletions
diff --git a/kde-base/kdesktop/ChangeLog b/kde-base/kdesktop/ChangeLog
index 0e6997d6b70b..d843c1eb54cf 100644
--- a/kde-base/kdesktop/ChangeLog
+++ b/kde-base/kdesktop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdesktop
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.53 2006/06/01 08:01:44 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.54 2006/06/01 18:09:23 flameeyes Exp $
+
+*kdesktop-3.5.3 (01 Jun 2006)
+
+ 01 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> +kdesktop-3.5.3.ebuild:
+ Update to new release.
01 Jun 2006; Thomas Cort <tcort@gentoo.org> kdesktop-3.5.2.ebuild:
Stable on alpha wrt Bug #132213.
diff --git a/kde-base/kdesktop/files/digest-kdesktop-3.5.3 b/kde-base/kdesktop/files/digest-kdesktop-3.5.3
new file mode 100644
index 000000000000..f6eb5d9b686e
--- /dev/null
+++ b/kde-base/kdesktop/files/digest-kdesktop-3.5.3
@@ -0,0 +1,3 @@
+MD5 9cb6b8291c4f3f986e16f72129e8fcd0 kdebase-3.5.3.tar.bz2 23634194
+RMD160 ef55c72b97577dd86e5c64bf589ff9b2d556ec07 kdebase-3.5.3.tar.bz2 23634194
+SHA256 5a2b9bc5e2682684519dbae89b3bd73fbf5de1f1effd3ca072173a9638dc3ff8 kdebase-3.5.3.tar.bz2 23634194
diff --git a/kde-base/kdesktop/kdesktop-3.5.3.ebuild b/kde-base/kdesktop/kdesktop-3.5.3.ebuild
new file mode 100644
index 000000000000..df02a734f363
--- /dev/null
+++ b/kde-base/kdesktop/kdesktop-3.5.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/kdesktop-3.5.3.ebuild,v 1.1 2006/06/01 18:09:23 flameeyes Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE desktop"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="xscreensaver"
+
+DEPEND="$DEPEND
+$(deprange $PV $MAXKDEVER kde-base/libkonq)
+$(deprange $PV $MAXKDEVER kde-base/kdm)
+$(deprange $PV $MAXKDEVER kde-base/kcontrol)
+ xscreensaver? ( || ( (
+ x11-proto/scrnsaverproto
+ ) virtual/x11 )
+ )"
+ # Requires the desktop background settings module,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+RDEPEND="${DEPEND}
+$(deprange 3.5.0 $MAXKDEVER kde-base/kcheckpass)
+$(deprange $PV $MAXKDEVER kde-base/kdialog)
+ xscreensaver? ( || ( (
+ x11-libs/libXScrnSaver
+ ) virtual/x11 )
+ )"
+
+KMCOPYLIB="libkonq libkonq/"
+KMEXTRACTONLY="kcheckpass/kcheckpass.h
+ libkonq/
+ kdm/kfrontend/themer/
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+KMCOMPILEONLY="kcontrol/background
+ kdmlib/"
+KMNODOCS=true
+
+src_compile() {
+ myconf="${myconf} $(use_with xscreensaver)"
+ kde-meta_src_compile
+}
+
+src_install() {
+ # ugly, needs fixing: don't install kcontrol/background
+ kde-meta_src_install
+
+ rmdir ${D}/${PREFIX}/share/templates/.source/emptydir
+}
+
+pkg_postinst() {
+ mkdir -p ${PREFIX}/share/templates/.source/emptydir
+}