summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 19:58:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 19:58:40 +0000
commit63aa807e04419ab863fcb47e6cf5a1fb29492d68 (patch)
tree1422624a657b22f7ed09123a65bfae7d4ef908a6 /kde-base/kdesktop
parentOne-liner compile fix to use CFLAGS instead of ignoring them. (diff)
downloadhistorical-63aa807e04419ab863fcb47e6cf5a1fb29492d68.tar.gz
historical-63aa807e04419ab863fcb47e6cf5a1fb29492d68.tar.bz2
historical-63aa807e04419ab863fcb47e6cf5a1fb29492d68.zip
Add patch to disable libxss support conditional to xscreensaver useflag.
Package-Manager: portage-2529-svn
Diffstat (limited to 'kde-base/kdesktop')
-rw-r--r--kde-base/kdesktop/ChangeLog8
-rw-r--r--kde-base/kdesktop/files/kdesktop-3.5.0-xscreensaver.patch25
-rw-r--r--kde-base/kdesktop/kdesktop-3.5.0.ebuild27
3 files changed, 52 insertions, 8 deletions
diff --git a/kde-base/kdesktop/ChangeLog b/kde-base/kdesktop/ChangeLog
index b5186dbc83b9..1398563e6247 100644
--- a/kde-base/kdesktop/ChangeLog
+++ b/kde-base/kdesktop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdesktop
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.37 2005/12/17 10:19:24 corsair Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/ChangeLog,v 1.38 2006/01/11 19:58:08 flameeyes Exp $
+
+ 11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kdesktop-3.5.0-xscreensaver.patch, kdesktop-3.5.0.ebuild:
+ Add patch to disable libxss support conditional to xscreensaver useflag.
17 Dec 2005; Markus Rothe <corsair@gentoo.org> kdesktop-3.5.0.ebuild:
Added ~ppc64
diff --git a/kde-base/kdesktop/files/kdesktop-3.5.0-xscreensaver.patch b/kde-base/kdesktop/files/kdesktop-3.5.0-xscreensaver.patch
new file mode 100644
index 000000000000..ee427436837b
--- /dev/null
+++ b/kde-base/kdesktop/files/kdesktop-3.5.0-xscreensaver.patch
@@ -0,0 +1,25 @@
+Index: kdebase-3.5.0/kdesktop/configure.in.in
+===================================================================
+--- kdebase-3.5.0/kdesktop/configure.in.in (revision 497039)
++++ kdebase-3.5.0/kdesktop/configure.in.in (working copy)
+@@ -3,7 +3,11 @@
+
+ LIB_XSS=
+
+-KDE_CHECK_HEADER(X11/extensions/scrnsaver.h,
++AC_ARG_WITH([xscreensaver],
++ AS_HELP_STRING([--without-xscreensaver], [Disable XScreenSaver support (default: check)]) )
++
++if test "x$with_xscreensaver" != "xno"; then
++ KDE_CHECK_HEADER(X11/extensions/scrnsaver.h,
+ [
+ AC_CHECK_LIB(Xext,XScreenSaverQueryInfo,
+ [
+@@ -29,6 +33,7 @@
+ [
+ #include <X11/Xlib.h>
+ ] )
++fi
+
+ AC_SUBST(LIB_XSS)
+ LDFLAGS="$xss_save_ldflags"
diff --git a/kde-base/kdesktop/kdesktop-3.5.0.ebuild b/kde-base/kdesktop/kdesktop-3.5.0.ebuild
index e5d67580cef7..659eb39aaf76 100644
--- a/kde-base/kdesktop/kdesktop-3.5.0.ebuild
+++ b/kde-base/kdesktop/kdesktop-3.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/kdesktop-3.5.0.ebuild,v 1.4 2005/12/17 10:19:24 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesktop/kdesktop-3.5.0.ebuild,v 1.5 2006/01/11 19:58:08 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
@@ -9,18 +9,26 @@ inherit kde-meta eutils
DESCRIPTION="The KDE desktop"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="xscreensaver"
DEPEND="$DEPEND
$(deprange $PV $MAXKDEVER kde-base/libkonq)
$(deprange $PV $MAXKDEVER kde-base/kdm)
-$(deprange $PV $MAXKDEVER kde-base/kcontrol)"
- # Requires the desktop background settings module,
+$(deprange $PV $MAXKDEVER kde-base/kcontrol)
+ xscreensaver? ( || ( (
+ x11-proto/scrnsaverproto
+ ) virtual/x11 )
+ )"
+ # Requires the desktop background settings module,
# so until we separate the kcontrol modules into separate ebuilds :-),
# there's a dep here
RDEPEND="${DEPEND}
$(deprange $PV $MAXKDEVER kde-base/kcheckpass)
-$(deprange $PV $MAXKDEVER kde-base/kdialog)"
+$(deprange $PV $MAXKDEVER kde-base/kdialog)
+ xscreensaver? ( || ( (
+ x11-libs/libXScrnSaver
+ ) virtual/x11 )
+ )"
KMCOPYLIB="libkonq libkonq/"
KMEXTRACTONLY="kcheckpass/kcheckpass.h
@@ -31,6 +39,13 @@ KMCOMPILEONLY="kcontrol/background
kdmlib/"
KMNODOCS=true
+PATCHES="${FILESDIR}/${P}-xscreensaver.patch"
+
+src_compile() {
+ myconf="${myconf} $(use_with xscreensaver)"
+ kde-meta_src_compile
+}
+
src_install() {
# ugly, needs fixing: don't install kcontrol/background
kde-meta_src_install