summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-02 20:01:13 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-02 20:01:13 +0000
commit2e9b86b30fad07b524b028800800096f1caa2182 (patch)
tree642b17f604cf8a90b495210b2740c78a7105092e /kde-base/kdeadmin
parentNew bugfix release, update python use deps, only support gstreamer-0.10 as it... (diff)
downloadhistorical-2e9b86b30fad07b524b028800800096f1caa2182.tar.gz
historical-2e9b86b30fad07b524b028800800096f1caa2182.tar.bz2
historical-2e9b86b30fad07b524b028800800096f1caa2182.zip
version bump
Package-Manager: portage-2.1_rc3-r5
Diffstat (limited to 'kde-base/kdeadmin')
-rw-r--r--kde-base/kdeadmin/ChangeLog7
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.5.33
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.5.3.ebuild33
3 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/kdeadmin/ChangeLog b/kde-base/kdeadmin/ChangeLog
index ca5e1cae1922..97ce93b1297b 100644
--- a/kde-base/kdeadmin/ChangeLog
+++ b/kde-base/kdeadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeadmin
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.164 2006/06/01 10:46:13 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.165 2006/06/02 19:49:01 genstef Exp $
+
+*kdeadmin-3.5.3 (02 Jun 2006)
+
+ 02 Jun 2006; Stefan Schweizer <genstef@gentoo.org> +kdeadmin-3.5.3.ebuild:
+ version bump
01 Jun 2006; Thomas Cort <tcort@gentoo.org> kdeadmin-3.5.2.ebuild:
Stable on alpha wrt Bug #132213.
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.5.3 b/kde-base/kdeadmin/files/digest-kdeadmin-3.5.3
new file mode 100644
index 000000000000..22f59c12d5b4
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.5.3
@@ -0,0 +1,3 @@
+MD5 842e74881c89a719423bbd5cc1f4e226 kdeadmin-3.5.3.tar.bz2 2114019
+RMD160 4785dd89e8078da1b3f8b3e8b424dbb1c1eeb257 kdeadmin-3.5.3.tar.bz2 2114019
+SHA256 77ae2a10bbe2669a9125865c4f0edf53c46e8cf8cde53899cfaed895c3401172 kdeadmin-3.5.3.tar.bz2 2114019
diff --git a/kde-base/kdeadmin/kdeadmin-3.5.3.ebuild b/kde-base/kdeadmin/kdeadmin-3.5.3.ebuild
new file mode 100644
index 000000000000..a2ed1c0dbe68
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.5.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.5.3.ebuild,v 1.1 2006/06/02 19:49:01 genstef Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="~kde-base/kdebase-${PV}"
+RDEPEND="${DEPEND}
+ virtual/cron"
+
+src_compile() {
+ # we only want to compile the lilo config module on x86, but there we want to make sure it's
+ # always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+ # because configure when left to its own devices will build lilo-config or not basd on whether
+ # lilo is present in the path.
+ # so, we make configure build it by removing the configure.in.in file that checks for
+ # lilo's presense
+ if use x86; then
+ echo > ${S}/lilo-config/configure.in.in
+ make -f admin/Makefile.common
+ fi
+
+ local myconf="--with-shadow"
+
+ export DO_NOT_COMPILE="${DO_NOT_COMPILE} ksysv"
+
+ kde_src_compile
+}