summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2006-01-28 14:50:22 +0000
committerDan Armak <danarmak@gentoo.org>2006-01-28 14:50:22 +0000
commit03baad8596ecde045bcba23f33d5602daafa9506 (patch)
tree576ba9f7bfac876c1a1d7db82ae63f2d05e6e812 /kde-base/kdeadmin
parentno need to bzip smallish patches (diff)
downloadhistorical-03baad8596ecde045bcba23f33d5602daafa9506.tar.gz
historical-03baad8596ecde045bcba23f33d5602daafa9506.tar.bz2
historical-03baad8596ecde045bcba23f33d5602daafa9506.zip
Version 3.5.1. Not yet released upstream, so package.masked for now.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'kde-base/kdeadmin')
-rw-r--r--kde-base/kdeadmin/ChangeLog5
-rw-r--r--kde-base/kdeadmin/Manifest2
-rw-r--r--kde-base/kdeadmin/files/digest-kdeadmin-3.5.11
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.5.1.ebuild33
4 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/kdeadmin/ChangeLog b/kde-base/kdeadmin/ChangeLog
index 09978441a4ae..ccaea9221ccc 100644
--- a/kde-base/kdeadmin/ChangeLog
+++ b/kde-base/kdeadmin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/kdeadmin
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.152 2006/01/22 22:52:54 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/ChangeLog,v 1.153 2006/01/28 14:30:55 danarmak Exp $
+
+ 28 Jan 2006; Dan Armak <danarmak@gentoo.org> +kdeadmin-3.5.1.ebuild:
+ Version 3.5.1. Not yet released upstream, so package.masked for now.
*kdeadmin-3.5.1 (23 Jan 2006)
diff --git a/kde-base/kdeadmin/Manifest b/kde-base/kdeadmin/Manifest
index 49f5d5884ea4..94090cf6bda0 100644
--- a/kde-base/kdeadmin/Manifest
+++ b/kde-base/kdeadmin/Manifest
@@ -4,9 +4,11 @@ MD5 8f9c012c60be21c26eb7ffdfdb2028db files/digest-kdeadmin-3.4.1 68
MD5 989e7ce04bdedd84132a4de27b408f93 files/digest-kdeadmin-3.4.2 68
MD5 80b3c1753e84c4d6d9caf0502325b7b4 files/digest-kdeadmin-3.4.3 68
MD5 5e640d90c8921056fae9b3ca328a8093 files/digest-kdeadmin-3.5.0 68
+MD5 223a891a18c8ca71d7a7fb46a382f708 files/digest-kdeadmin-3.5.1 68
MD5 8e05194146eee671618623350403842d kdeadmin-3.3.2.ebuild 1049
MD5 48be512760042fae56362300f41edeb4 kdeadmin-3.4.1.ebuild 1034
MD5 ea014a2bc46363915808f003ccd4085d kdeadmin-3.4.2.ebuild 1040
MD5 3364f1e30a8454b345a6cb5faaf90020 kdeadmin-3.4.3.ebuild 1057
MD5 3987d3b45f76da5d1254b8962f0bb6f1 kdeadmin-3.5.0.ebuild 1081
+MD5 3987d3b45f76da5d1254b8962f0bb6f1 kdeadmin-3.5.1.ebuild 1081
MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
diff --git a/kde-base/kdeadmin/files/digest-kdeadmin-3.5.1 b/kde-base/kdeadmin/files/digest-kdeadmin-3.5.1
new file mode 100644
index 000000000000..46d26d668199
--- /dev/null
+++ b/kde-base/kdeadmin/files/digest-kdeadmin-3.5.1
@@ -0,0 +1 @@
+MD5 08e9bddd2b42e0783d7f79d08cdb031b kdeadmin-3.5.1.tar.bz2 2099139
diff --git a/kde-base/kdeadmin/kdeadmin-3.5.1.ebuild b/kde-base/kdeadmin/kdeadmin-3.5.1.ebuild
new file mode 100644
index 000000000000..c8f146d39da1
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.5.1.ebuild,v 1.1 2006/01/28 14:30:55 danarmak Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="~kde-base/kdebase-${PV}"
+RDEPEND="${DEPEND}
+ virtual/cron"
+
+src_compile() {
+ # we only want to compile the lilo config module on x86, but there we want to make sure it's
+ # always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+ # because configure when left to its own devices will build lilo-config or not basd on whether
+ # lilo is present in the path.
+ # so, we make configure build it by removing the configure.in.in file that checks for
+ # lilo's presense
+ if use x86; then
+ echo > ${S}/lilo-config/configure.in.in
+ make -f admin/Makefile.common
+ fi
+
+ local myconf="--with-shadow"
+
+ export DO_NOT_COMPILE="${DO_NOT_COMPILE} ksysv"
+
+ kde_src_compile
+}