summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
commit5f9a89edfc761f6e642eaf86247fccacdd48d248 (patch)
treed6c5667c5d199a8f311d21b4e1273d740f0b4d06 /kde-base/kalzium
parent[profiles] Update kde mask (diff)
downloadhistorical-5f9a89edfc761f6e642eaf86247fccacdd48d248.tar.gz
historical-5f9a89edfc761f6e642eaf86247fccacdd48d248.tar.bz2
historical-5f9a89edfc761f6e642eaf86247fccacdd48d248.zip
[kde-base] Add KDE SC 4.7.1
Package-Manager: portage-2.2.0_alpha54/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.7.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index cf7f5a8a32ee..7a7197de955a 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.199 2011/08/15 22:02:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.200 2011/09/07 20:13:44 alexxy Exp $
+
+*kalzium-4.7.1 (07 Sep 2011)
+
+ 07 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.7.1.ebuild:
+ Version bump KDE SC 4.7.1
15 Aug 2011; Markus Meier <maekke@gentoo.org> kalzium-4.6.5.ebuild:
x86 stable, bug #377465
diff --git a/kde-base/kalzium/kalzium-4.7.1.ebuild b/kde-base/kalzium/kalzium-4.7.1.ebuild
new file mode 100644
index 000000000000..79f057abaa4e
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.7.1.ebuild,v 1.1 2011/09/07 20:13:44 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}
+
+src_test(){ :; } #see bug 376911