summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
commit0941f8f8b9ab158f571c295f3e1a4db8e2117481 (patch)
tree395111f62c037d6bc60c879297b61c7bbb00ccc4 /kde-base/kalgebra
parentstable sparc, bug 282379 (diff)
downloadhistorical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.gz
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.bz2
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.zip
Version bump KDE 4.3.1
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kalgebra')
-rw-r--r--kde-base/kalgebra/ChangeLog8
-rw-r--r--kde-base/kalgebra/kalgebra-4.3.1.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-base/kalgebra/ChangeLog b/kde-base/kalgebra/ChangeLog
index 48f63eb6aaba..ea5e4ef65072 100644
--- a/kde-base/kalgebra/ChangeLog
+++ b/kde-base/kalgebra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalgebra
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.35 2009/08/04 04:28:05 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.36 2009/09/01 14:48:01 tampakrap Exp $
+
+*kalgebra-4.3.1 (01 Sep 2009)
+
+ 01 Sep 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kalgebra-4.3.1.ebuild:
+ Version bump
04 Aug 2009; Alex Alexander <wired@gentoo.org> ChangeLog:
manifest update (upstream tarball changed)
diff --git a/kde-base/kalgebra/kalgebra-4.3.1.ebuild b/kde-base/kalgebra/kalgebra-4.3.1.ebuild
new file mode 100644
index 000000000000..6615782d3f3a
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.3.1.ebuild,v 1.1 2009/09/01 14:48:01 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook +plasma readline"
+
+DEPEND="
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mathmlpresentationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/analitza/tests/CMakeLists.txt || \
+ die "sed to disable mathmlpresentationtest failed."
+
+ kde4-meta_src_test
+}