summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-08-30 22:04:09 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-08-30 22:04:09 +0000
commitc01caed108d73618ec29b31c020fab9e4e6ec307 (patch)
tree58ca3f1148999d84a03b7fa4502b581b8338c1d5 /gnome-extra/gucharmap
parentDrop unused binding from RDEPEND. Sync test/docbook-xml-dtd with previous rev... (diff)
downloadhistorical-c01caed108d73618ec29b31c020fab9e4e6ec307.tar.gz
historical-c01caed108d73618ec29b31c020fab9e4e6ec307.tar.bz2
historical-c01caed108d73618ec29b31c020fab9e4e6ec307.zip
Version bump. Translation updates and one bug fix.
Package-Manager: portage-2.2_rc68/cvs/Linux x86_64
Diffstat (limited to 'gnome-extra/gucharmap')
-rw-r--r--gnome-extra/gucharmap/ChangeLog8
-rw-r--r--gnome-extra/gucharmap/gucharmap-2.30.3.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/gnome-extra/gucharmap/ChangeLog b/gnome-extra/gucharmap/ChangeLog
index c6ea10f46aa3..ab07964d0cfd 100644
--- a/gnome-extra/gucharmap/ChangeLog
+++ b/gnome-extra/gucharmap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gucharmap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/ChangeLog,v 1.143 2010/08/18 22:16:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/ChangeLog,v 1.144 2010/08/30 22:04:09 eva Exp $
+
+*gucharmap-2.30.3 (30 Aug 2010)
+
+ 30 Aug 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +gucharmap-2.30.3.ebuild:
+ Version bump. Translation updates and one bug fix.
18 Aug 2010; Markus Meier <maekke@gentoo.org> gucharmap-2.28.2.ebuild:
arm stable, bug #314899
diff --git a/gnome-extra/gucharmap/gucharmap-2.30.3.ebuild b/gnome-extra/gucharmap/gucharmap-2.30.3.ebuild
new file mode 100644
index 000000000000..7b7be6bb1134
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-2.30.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gucharmap/gucharmap-2.30.3.ebuild,v 1.1 2010/08/30 22:04:09 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="Unicode character map viewer"
+HOMEPAGE="http://gucharmap.sourceforge.net/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cjk doc gnome python test"
+
+# FIXME: add gobject-introspection support once available
+RDEPEND=">=dev-libs/glib-2.16.3
+ >=x11-libs/pango-1.2.1
+ >=x11-libs/gtk+-2.13.6
+ gnome? ( gnome-base/gconf )
+ python? ( >=dev-python/pygtk-2.7.1 )"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.9.0
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ test? ( ~app-text/docbook-xml-dtd-4.1.2 )"
+
+DOCS="ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --disable-maintainer-mode
+ --disable-introspection
+ $(use_enable gnome gconf)
+ $(use_enable cjk unihan)
+ $(use_enable python python-bindings)"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+}