summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 03:33:03 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 03:33:03 +0000
commita83024060f205ff0773ae8d553b350a8e2caff12 (patch)
tree6bd2f0406f3e5284ee58cd8696d5e145e96c0fd5 /gnome-base
parentgrrr, commit I say COMMIT (diff)
downloadhistorical-a83024060f205ff0773ae8d553b350a8e2caff12.tar.gz
historical-a83024060f205ff0773ae8d553b350a8e2caff12.tar.bz2
historical-a83024060f205ff0773ae8d553b350a8e2caff12.zip
*** empty log message ***
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/ORBit/ORBit-0.5.8.ebuild14
-rw-r--r--gnome-base/glibwww/glibwww-0.2-r1.ebuild17
-rw-r--r--gnome-base/gnome-libs/gnome-libs-1.2.13.ebuild13
-rw-r--r--gnome-base/oaf/oaf-0.6.5.ebuild12
4 files changed, 27 insertions, 29 deletions
diff --git a/gnome-base/ORBit/ORBit-0.5.8.ebuild b/gnome-base/ORBit/ORBit-0.5.8.ebuild
index f15f79469c42..4da449ab38f1 100644
--- a/gnome-base/ORBit/ORBit-0.5.8.ebuild
+++ b/gnome-base/ORBit/ORBit-0.5.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.8.ebuild,v 1.1 2001/05/17 00:10:07 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.8.ebuild,v 1.2 2001/06/04 03:33:03 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,25 +11,27 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.labs.redhat.com/orbit/"
-DEPEND="virtual/glibc
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )
>=sys-apps/tcp-wrappers-7.6
>=dev-libs/glib-1.2.8
>=gnome-base/gnome-env-1.0"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/glibc >=gnome-base/gnome-env-1.0
>=dev-libs/glib-1.2.8"
src_compile() {
-
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --sysconfdir=/etc/opt/gnome
+ --sysconfdir=/etc/opt/gnome $myconf
try make
}
src_install() {
try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome \
- install
+ install
dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
dodoc docs/*.txt docs/IDEA1
diff --git a/gnome-base/glibwww/glibwww-0.2-r1.ebuild b/gnome-base/glibwww/glibwww-0.2-r1.ebuild
index d552fca4a540..2039cba57b77 100644
--- a/gnome-base/glibwww/glibwww-0.2-r1.ebuild
+++ b/gnome-base/glibwww/glibwww-0.2-r1.ebuild
@@ -5,30 +5,21 @@
A=${P}.tar.gz
S=${WORKDIR}/${P}
-DESCRIPTION="The Gnome Application Libraries"
+DESCRIPTION="The Gnome WWW Libraries"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}
ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/"
-DEPEND=">=gnome-base/gnome-libs-1.2.12
- >=net-libs/libwww-1.5.3-r1"
+DEPEND=">=gnome-base/gnome-libs-1.2.13 >=net-libs/libwww-1.5.3-r1 gnome-base/gnome-env"
+RDEPEND=">=net-libs/libwww-1.5.3-r1 gnome-base/gnome-env"
-
-
-src_unpack() {
- unpack ${A}
-}
-
-src_compile() {
- cd ${S}
+src_compile() {
try ./configure --host=${CHOST} --prefix=/opt/gnome
try make
}
src_install() {
- cd ${S}
try make prefix=${D}/opt/gnome install
-
dodoc AUTHORS ChangeLog NEWS README
}
diff --git a/gnome-base/gnome-libs/gnome-libs-1.2.13.ebuild b/gnome-base/gnome-libs/gnome-libs-1.2.13.ebuild
index 4d22739ac3e0..639fd0d3da82 100644
--- a/gnome-base/gnome-libs/gnome-libs-1.2.13.ebuild
+++ b/gnome-base/gnome-libs/gnome-libs-1.2.13.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.2.13.ebuild,v 1.2 2001/04/13 16:59:03 pete Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.2.13.ebuild,v 1.3 2001/06/04 03:33:03 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,18 +10,17 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/"
-DEPEND=">=gnome-base/gnome-env-1.0
- >=media-libs/imlib-1.9.10
+DEPEND=">=media-libs/imlib-1.9.10
>=media-sound/esound-0.2.22
>=gnome-base/ORBit-0.5.7
- >=sys-libs/db-1.85-r1"
+ <sys-libs/db-2"
src_compile() {
try ./configure --host=${CHOST} --prefix=/opt/gnome \
--sysconfdir=/etc/opt/gnome \
- --mandir=/opt/gnome/share/man \
- --localstatedir=/var --enable-prefer-db1
+ --mandir=/opt/gnome/man \
+ --localstatedir=/var --enable-prefere-db1
try make
}
@@ -29,7 +28,7 @@ src_compile() {
src_install() {
try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome \
- mandir=${D}/opt/gnome/share/man \
+ mandir=${D}/opt/gnome/man \
localstatedir=${D}/var install
into /opt/gnome
diff --git a/gnome-base/oaf/oaf-0.6.5.ebuild b/gnome-base/oaf/oaf-0.6.5.ebuild
index adcef896cd58..7ce3066e8c17 100644
--- a/gnome-base/oaf/oaf-0.6.5.ebuild
+++ b/gnome-base/oaf/oaf-0.6.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.6.5.ebuild,v 1.2 2001/05/27 02:58:36 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.6.5.ebuild,v 1.3 2001/06/04 03:33:03 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,18 +9,24 @@ DESCRIPTION="Object Activation Framework for GNOME"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}
ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
-DEPEND=">=sys-devel/perl-5
+DEPEND="virtual/glibc >=sys-devel/perl-5
>=app-arch/rpm-3.0.6
>=gnome-base/gnome-env-1.0
>=gnome-base/ORBit-0.5.7
>=gnome-base/libxml-1.8.11
nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc
+ >=app-arch/rpm-3.0.6
+ >=gnome-base/gnome-env-1.0
+ >=gnome-base/ORBit-0.5.7
+ >=gnome-base/libxml-1.8.11"
+
src_unpack() {
unpack ${A}
cd ${S}
cp -a configure configure.orig
- sed -e "s:perl5\.00404:perl5.6.0:" configure.orig > configure
+ sed -e "s:perl5\.00404:perl5.6.1:" configure.orig > configure
}
src_compile() {