summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-03-30 12:19:01 +0000
committerPacho Ramos <pacho@gentoo.org>2010-03-30 12:19:01 +0000
commit1c49e73088b54607187c81ef9c774c915cd9bc45 (patch)
tree0236d8afbcaa7ec7ddbe19e4c117269ad9fa79f9 /gnome-base/libbonoboui/libbonoboui-2.24.3.ebuild
parentVersion bump and fix repoman warnings with 2.24.2 (diff)
downloadhistorical-1c49e73088b54607187c81ef9c774c915cd9bc45.tar.gz
historical-1c49e73088b54607187c81ef9c774c915cd9bc45.tar.bz2
historical-1c49e73088b54607187c81ef9c774c915cd9bc45.zip
Version bump
Package-Manager: portage-2.1.7.17/cvs/Linux x86_64
Diffstat (limited to 'gnome-base/libbonoboui/libbonoboui-2.24.3.ebuild')
-rw-r--r--gnome-base/libbonoboui/libbonoboui-2.24.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnome-base/libbonoboui/libbonoboui-2.24.3.ebuild b/gnome-base/libbonoboui/libbonoboui-2.24.3.ebuild
new file mode 100644
index 000000000000..74ac1ee17b3a
--- /dev/null
+++ b/gnome-base/libbonoboui/libbonoboui-2.24.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonoboui/libbonoboui-2.24.3.ebuild,v 1.1 2010/03/30 12:19:01 pacho Exp $
+
+GCONF_DEBUG="no"
+
+inherit eutils virtualx gnome2
+
+DESCRIPTION="User Interface part of libbonobo"
+HOMEPAGE="http://developer.gnome.org/arch/gnome/componentmodel/bonobo.html"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+# GTK+ dep due to bug #126565
+RDEPEND=">=gnome-base/libgnomecanvas-1.116
+ >=gnome-base/libbonobo-2.22
+ >=gnome-base/libgnome-2.13.7
+ >=dev-libs/libxml2-2.4.20
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2.8.12
+ >=dev-libs/glib-2.6.0
+ >=gnome-base/libglade-1.99.11
+ >=dev-libs/popt-1.5"
+
+DEPEND="${RDEPEND}
+ x11-apps/xrdb
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_compile() {
+ addpredict "/root/.gnome2_private"
+
+ gnome2_src_compile
+}
+
+src_test() {
+ addwrite "/root/.gnome2_private"
+ Xemake check || die "tests failed"
+}