summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-29 01:33:47 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-29 01:33:47 +0000
commit2e9bf111ff3bc309e1d6a3ec509031041a75b403 (patch)
tree50920cb184d3b18de02966c62b408a48bf106a65 /gnome-base/gnome-session/gnome-session-3.2.1.ebuild
parentBump to EAPI=4 (diff)
downloadhistorical-2e9bf111ff3bc309e1d6a3ec509031041a75b403.tar.gz
historical-2e9bf111ff3bc309e1d6a3ec509031041a75b403.tar.bz2
historical-2e9bf111ff3bc309e1d6a3ec509031041a75b403.zip
Bump to 3.2.1 from the gnome overlay.
Package-Manager: portage-2.2.0_alpha71/cvs/Linux x86_64
Diffstat (limited to 'gnome-base/gnome-session/gnome-session-3.2.1.ebuild')
-rw-r--r--gnome-base/gnome-session/gnome-session-3.2.1.ebuild101
1 files changed, 101 insertions, 0 deletions
diff --git a/gnome-base/gnome-session/gnome-session-3.2.1.ebuild b/gnome-base/gnome-session/gnome-session-3.2.1.ebuild
new file mode 100644
index 000000000000..c275f911044c
--- /dev/null
+++ b/gnome-base/gnome-session/gnome-session-3.2.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-session/gnome-session-3.2.1.ebuild,v 1.1 2011/10/29 01:33:47 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="Gnome session manager"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc ipv6 elibc_FreeBSD"
+
+# x11-misc/xdg-user-dirs{,-gtk} are needed to create the various XDG_*_DIRs, and
+# create .config/user-dirs.dirs which is read by glib to get G_USER_DIRECTORY_*
+# xdg-user-dirs-update is run during login (see 10-user-dirs-update-gnome below).
+# gdk-pixbuf used in the inhibit dialog
+COMMON_DEPEND=">=dev-libs/glib-2.28.0:2
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.90.7:3
+ >=dev-libs/json-glib-0.10
+ >=dev-libs/dbus-glib-0.76
+ >=gnome-base/gconf-2:2
+ >=sys-power/upower-0.9.0
+ elibc_FreeBSD? ( dev-libs/libexecinfo )
+
+ virtual/opengl
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-misc/xdg-user-dirs
+ x11-misc/xdg-user-dirs-gtk
+ x11-apps/xdpyinfo"
+# Pure-runtime deps from the session files should *NOT* be added here
+# Otherwise, things like gdm pull in gnome-shell
+# gnome-themes-standard is needed for the failwhale dialog themeing
+# sys-apps/dbus[X] is needed for session management
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gnome-settings-daemon
+ >=gnome-base/gsettings-desktop-schemas-0.1.7
+ >=x11-themes/gnome-themes-standard-2.91.92
+ sys-apps/dbus[X]"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=sys-devel/gettext-0.10.40
+ >=dev-util/pkgconfig-0.17
+ >=dev-util/intltool-0.40.6
+ !<gnome-base/gdm-2.20.4
+ doc? (
+ app-text/xmlto
+ dev-libs/libxslt )"
+# gnome-common needed for eautoreconf
+# gnome-base/gdm does not provide gnome.desktop anymore
+
+pkg_setup() {
+ # TODO: convert libnotify to a configure option
+ G2CONF="${G2CONF}
+ --disable-deprecation-flags
+ --disable-schemas-compile
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable doc docbook-docs)
+ $(use_enable ipv6)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_install() {
+ gnome2_src_install
+
+ dodir /etc/X11/Sessions
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/Gnome"
+
+ dodir /usr/share/gnome/applications/
+ insinto /usr/share/gnome/applications/
+ doins "${FILESDIR}/defaults.list"
+
+ dodir /etc/X11/xinit/xinitrc.d/
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/15-xdg-data-gnome"
+
+ # This should be done here as discussed in bug #270852
+ doexe "${FILESDIR}/10-user-dirs-update-gnome"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version gnome-base/gdm && ! has_version kde-base/kdm; then
+ ewarn "If you use a custom .xinitrc for your X session,"
+ ewarn "make sure that the commands in the xinitrc.d scripts are run."
+ fi
+}