summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-22 01:36:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-22 01:36:44 +0000
commit4960598f605ed3d0831404ca1985c9933d2d29f7 (patch)
tree8db722150f3deb257cf400c66116b71440dfdf62 /games-strategy
parentinitial commit (bug 31054) (diff)
downloadhistorical-4960598f605ed3d0831404ca1985c9933d2d29f7.tar.gz
historical-4960598f605ed3d0831404ca1985c9933d2d29f7.tar.bz2
historical-4960598f605ed3d0831404ca1985c9933d2d29f7.zip
initial commit (bug 31054)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/netpanzer/Manifest3
-rw-r--r--games-strategy/netpanzer/files/digest-netpanzer-0.1.12
-rw-r--r--games-strategy/netpanzer/netpanzer-0.1.1.ebuild44
3 files changed, 48 insertions, 1 deletions
diff --git a/games-strategy/netpanzer/Manifest b/games-strategy/netpanzer/Manifest
index 37350bf175bd..3906a56985b2 100644
--- a/games-strategy/netpanzer/Manifest
+++ b/games-strategy/netpanzer/Manifest
@@ -1,2 +1,3 @@
-MD5 e2662356ea10a9435dcda92b0ad6feb7 netpanzer-0.1.1.ebuild 769
+MD5 4b46f95d12f6061c6110c0ea26bfd7c3 netpanzer-0.1.1.ebuild 1362
+MD5 2e0c547a6196d31c6eac737bf071cb4e ChangeLog 408
MD5 445b8fd897674545f22a41398d72e1aa files/digest-netpanzer-0.1.1 139
diff --git a/games-strategy/netpanzer/files/digest-netpanzer-0.1.1 b/games-strategy/netpanzer/files/digest-netpanzer-0.1.1
new file mode 100644
index 000000000000..1037beae7272
--- /dev/null
+++ b/games-strategy/netpanzer/files/digest-netpanzer-0.1.1
@@ -0,0 +1,2 @@
+MD5 0701c71b705655293c6cda941a3161b2 netpanzer-0.1.1.tar.bz2 345280
+MD5 ab49d2389a69fc13c243569db2363e66 netpanzerdata-0.1.tar.bz2 9775228
diff --git a/games-strategy/netpanzer/netpanzer-0.1.1.ebuild b/games-strategy/netpanzer/netpanzer-0.1.1.ebuild
new file mode 100644
index 000000000000..c89d0283fd6a
--- /dev/null
+++ b/games-strategy/netpanzer/netpanzer-0.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/netpanzer/netpanzer-0.1.1.ebuild,v 1.1 2003/10/22 01:36:22 mr_bones_ Exp $
+
+inherit games eutils
+
+DESCRIPTION="Fast-action multiplayer strategic network game"
+HOMEPAGE="http://www.nongnu.org/netpanzer/"
+SRC_URI="http://savannah.nongnu.org/download/netpanzer/netpanzer.pkg/0.1/netpanzer-${PV}.tar.bz2
+ http://savannah.nongnu.org/download/netpanzer/netpanzer.pkg/0.1/netpanzerdata-0.1.tar.bz2"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-net-1.2.4
+ >=media-libs/sdl-mixer-1.2.4
+ >=media-libs/sdl-image-1.2.3
+ >=dev-games/physfs-0.1.9
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ >=dev-util/jam-2.5"
+
+src_compile() {
+ egamesconf || die
+ jam || die "jam failed"
+
+ cd ${WORKDIR}/${PN}data-0.1/
+ egamesconf || die
+ jam || die "jam failed (2)"
+}
+
+src_install() {
+ # don't put a '/' between ${D} and ${GAMES_PREFIX} because of a jam bug
+ # (more than 3 continuos slashes don't work
+ jam -sprefix=${D}${GAMES_PREFIX} \
+ -sdatadir=${D}${GAMES_DATADIR} install || die "jam install failed"
+
+ cd ${WORKDIR}/${PN}data-0.1/
+ jam -sprefix=${D}${GAMES_PREFIX} \
+ -sdatadir=${D}${GAMES_DATADIR} install || die "jam install failed (2)"
+ prepgamesdirs
+}