summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 05:27:31 +0000
commitab4f2946553cbc625cd82c853072cb36467fe40e (patch)
treece4c3749e9e4fb10f2366b302c0ed63113ba1041 /games-strategy/xarchon
parentminor version update. resolves bug 27641 (diff)
downloadhistorical-ab4f2946553cbc625cd82c853072cb36467fe40e.tar.gz
historical-ab4f2946553cbc625cd82c853072cb36467fe40e.tar.bz2
historical-ab4f2946553cbc625cd82c853072cb36467fe40e.zip
mmm strategy games
Diffstat (limited to 'games-strategy/xarchon')
-rw-r--r--games-strategy/xarchon/ChangeLog13
-rw-r--r--games-strategy/xarchon/Manifest5
-rw-r--r--games-strategy/xarchon/files/digest-xarchon-0.501
-rw-r--r--games-strategy/xarchon/files/digest-xarchon-0.602
-rw-r--r--games-strategy/xarchon/xarchon-0.50.ebuild38
-rw-r--r--games-strategy/xarchon/xarchon-0.60.ebuild48
6 files changed, 107 insertions, 0 deletions
diff --git a/games-strategy/xarchon/ChangeLog b/games-strategy/xarchon/ChangeLog
new file mode 100644
index 000000000000..b75a332c0499
--- /dev/null
+++ b/games-strategy/xarchon/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-games/xarchon
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xarchon/ChangeLog,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+*xarchon-0.60 (31 Jul 2003)
+
+ 31 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Development version ... pretty messed up src but ppl want it ;)
+
+*xarchon-0.50 (29 Jul 2003)
+
+ 29 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me for Guru.
diff --git a/games-strategy/xarchon/Manifest b/games-strategy/xarchon/Manifest
new file mode 100644
index 000000000000..4aa06213887b
--- /dev/null
+++ b/games-strategy/xarchon/Manifest
@@ -0,0 +1,5 @@
+MD5 689a185cbdfa51ad46911e3703f8e7bc xarchon-0.50.ebuild 881
+MD5 8bfbd70aee2831c6c7a4587cad2f6011 files/digest-xarchon-0.50 64
+MD5 50a9df5dead133494d2506a91264661e files/digest-xarchon-0.60 133
+MD5 7b47ee1986da190e2e61cd6c95042ec6 ChangeLog 497
+MD5 e41139467a7a76e6ff4a047cc5d28bea xarchon-0.60.ebuild 1126
diff --git a/games-strategy/xarchon/files/digest-xarchon-0.50 b/games-strategy/xarchon/files/digest-xarchon-0.50
new file mode 100644
index 000000000000..b7add5bf6d29
--- /dev/null
+++ b/games-strategy/xarchon/files/digest-xarchon-0.50
@@ -0,0 +1 @@
+MD5 491dea5b4e61ed13cd988d1c184a8ef0 xarchon-0.50.tar.gz 371299
diff --git a/games-strategy/xarchon/files/digest-xarchon-0.60 b/games-strategy/xarchon/files/digest-xarchon-0.60
new file mode 100644
index 000000000000..404db7d3c26c
--- /dev/null
+++ b/games-strategy/xarchon/files/digest-xarchon-0.60
@@ -0,0 +1,2 @@
+MD5 d7f3fc32b2ddbbfb8578a3366400c5c6 xarchon-0.60.tar.gz 435088
+MD5 299edc5edf0d0ded68801e1beaa3164e xarchon-0.60-gtk.patch.bz2 3541
diff --git a/games-strategy/xarchon/xarchon-0.50.ebuild b/games-strategy/xarchon/xarchon-0.50.ebuild
new file mode 100644
index 000000000000..a1912f34aceb
--- /dev/null
+++ b/games-strategy/xarchon/xarchon-0.50.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xarchon/xarchon-0.50.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+inherit games
+
+DESCRIPTION="modelled after the golden oldie Archon game"
+HOMEPAGE="http://xarchon.seul.org/"
+SRC_URI="ftp://ftp.seul.org/pub/xarchon/${P}.tar.gz
+ http://xarchon.seul.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="esd joystick"
+
+DEPEND="virtual/x11
+ =x11-libs/gtk+-1*
+ esd? ( media-sound/esound )"
+
+src_compile() {
+ local mysndconf
+ [ `use esd` ] \
+ && mysndconf="--with-esd-prefix=/usr" \
+ || mysndconf="--disable-sound"
+ egamesconf \
+ --enable-network \
+ `use_enable joystick` \
+ ${mysndconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ egamesinstall || die
+ dodoc AUTHORS ChangeLog NEWS README
+ prepgamesdirs
+}
diff --git a/games-strategy/xarchon/xarchon-0.60.ebuild b/games-strategy/xarchon/xarchon-0.60.ebuild
new file mode 100644
index 000000000000..f61e5de7e61c
--- /dev/null
+++ b/games-strategy/xarchon/xarchon-0.60.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xarchon/xarchon-0.60.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="modelled after the golden oldie Archon game"
+HOMEPAGE="http://xarchon.seul.org/"
+SRC_URI="ftp://ftp.seul.org/pub/xarchon/${P}.tar.gz
+ http://xarchon.seul.org/${P}.tar.gz
+ mirror://gentoo/${P}-gtk.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="esd joystick" # also has qt support but it fails :/
+
+DEPEND="virtual/x11
+ =x11-libs/gtk+-1*
+ <dev-util/glade-2
+ esd? ( media-sound/esound )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P}-gtk.patch
+ sed -i 's:gtk12-config:gtk-config:' configure
+}
+
+src_compile() {
+ local mysndconf
+ [ `use esd` ] \
+ && mysndconf="--with-esd-prefix=/usr" \
+ || mysndconf="--disable-sound"
+ egamesconf \
+ --enable-network \
+ `use_enable joystick` \
+ --with-default-gtk \
+ ${mysndconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ egamesinstall || die
+ dodoc AUTHORS ChangeLog NEWS README
+ prepgamesdirs
+}