summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-06-22 22:42:26 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-06-22 22:42:26 +0000
commit68a9d6ea8effd751b77de140929da9c95393ab92 (patch)
tree697d73ddbf742cab47539e1cdd40e0c12fffc895 /games-rpg/manaplus/manaplus-1.3.6.23.ebuild
parentAdd init script license, bug 425898 (diff)
downloadhistorical-68a9d6ea8effd751b77de140929da9c95393ab92.tar.gz
historical-68a9d6ea8effd751b77de140929da9c95393ab92.tar.bz2
historical-68a9d6ea8effd751b77de140929da9c95393ab92.zip
version bump, remove old
Package-Manager: portage-2.2.0_alpha184/cvs/Linux x86_64 Manifest-Sign-Key: 0xE73C35B3
Diffstat (limited to 'games-rpg/manaplus/manaplus-1.3.6.23.ebuild')
-rw-r--r--games-rpg/manaplus/manaplus-1.3.6.23.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/games-rpg/manaplus/manaplus-1.3.6.23.ebuild b/games-rpg/manaplus/manaplus-1.3.6.23.ebuild
new file mode 100644
index 000000000000..aec0e0d4cc6c
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.3.6.23.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/manaplus-1.3.6.23.ebuild,v 1.1 2013/06/22 22:42:22 hasufell Exp $
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ dev-libs/libxml2
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ net-misc/curl
+ sys-libs/zlib
+ media-libs/libpng:0
+ media-fonts/dejavu
+ >=dev-games/guichan-0.8.1[sdl]
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ x11-misc/xsel
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/^SUBDIRS/s/fonts//' \
+ data/Makefile.in || die
+
+ rm -r src/guichan || die
+}
+
+src_configure() {
+ egamesconf \
+ --without-internalguichan \
+ --localedir=/usr/share/locale \
+ --disable-manaserv \
+ --disable-eathena \
+ $(use_with opengl) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-mono.ttf
+ insinto "${GAMES_DATADIR}"/${PN}/data
+
+ prepgamesdirs
+}