summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 18:10:15 +0000
commitad69522f5e6b57d5350a46ebda16dbe091d0e4b6 (patch)
tree1580e46b57d69a004ab7bafb3f19590605890684 /games-fps/unreal/unreal-226.ebuild
parentNew version 'n cleanup (diff)
downloadhistorical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.tar.gz
historical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.tar.bz2
historical-ad69522f5e6b57d5350a46ebda16dbe091d0e4b6.zip
games-fps uNF uNF uNF
Diffstat (limited to 'games-fps/unreal/unreal-226.ebuild')
-rw-r--r--games-fps/unreal/unreal-226.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-fps/unreal/unreal-226.ebuild b/games-fps/unreal/unreal-226.ebuild
new file mode 100644
index 000000000000..d5d4d261dee7
--- /dev/null
+++ b/games-fps/unreal/unreal-226.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal/unreal-226.ebuild,v 1.1 2003/09/09 18:10:15 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Futuristic FPS (a hack that runs on top of Unreal Tournament)"
+HOMEPAGE="http://www.unreal.com/"
+SRC_URI="http://www.icculus.org/%7Echunky/ut/unreal/unreali-install.run"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE="X"
+
+DEPEND="|| ( app-games/unreal-tournament app-games/unreal-tournament-goty )
+ sys-libs/lib-compat"
+RDEPEND="X? ( virtual/x11 )
+ opengl? ( virtual/opengl )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ games_get_cd System/
+ games_verify_cd ${PN}
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself ${A}
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/unreal
+ dodir ${dir}
+
+ tar -zxf System.tar.gz -C ${D}/${dir}
+
+ cp -rf ${GAMES_CD}/{Maps,Music,Sounds} ${D}/${dir}/
+
+ insinto ${dir}
+ doins icon.* README*
+
+ dosym ${GAMES_PREFIX_OPT}/unreal-tournament/System/Engine.so ${dir}/System/Engine.so
+ dosym ${GAMES_PREFIX_OPT}/unreal-tournament/System/Core.so ${dir}/System/Core.so
+
+ dogamesbin ${FILESDIR}/unreal
+ dosed "s:GENTOO_DIR:${GAMES_BINDIR}:" ${GAMES_BINDIR}/unreal
+
+ prepgamesdirs
+}