summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-04-09 18:23:25 +0000
committerTristan Heaven <tristan@gentoo.org>2007-04-09 18:23:25 +0000
commit4b7ac8b9b0298f79015e299f0ead8b7eb8e7c28a (patch)
treea7393e247a2db1a4533a64c034ac0d62ad1d86af /games-fps/red-blue-quake2
parentStable on amd64 wrt bug 173880 (diff)
downloadhistorical-4b7ac8b9b0298f79015e299f0ead8b7eb8e7c28a.tar.gz
historical-4b7ac8b9b0298f79015e299f0ead8b7eb8e7c28a.tar.bz2
historical-4b7ac8b9b0298f79015e299f0ead8b7eb8e7c28a.zip
use games_get_libdir
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'games-fps/red-blue-quake2')
-rw-r--r--games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild36
1 files changed, 19 insertions, 17 deletions
diff --git a/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild b/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
index 753d7b441864..acdd8174f80b 100644
--- a/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
+++ b/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild,v 1.10 2006/12/05 17:55:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild,v 1.11 2007/04/09 18:19:41 nyhm Exp $
inherit eutils games
@@ -22,36 +22,38 @@ S=${WORKDIR}/quake2-3.21/linux
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${PV}-gentoo.patch
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
cd quake2-3.21
epatch "${FILESDIR}/${P}"-gcc41.patch
cd linux
- sed -i "s:GENTOO_DIR:${GAMES_LIBDIR}/${PN}:" sys_linux.c
- sed -i "s:/etc/quake2.conf:${GAMES_SYSCONFDIR}/${PN}.conf:" sys_linux.c vid_so.c
+ sed -i "s:GENTOO_DIR:$(games_get_libdir)/${PN}:" sys_linux.c \
+ || die "sed failed"
+ sed -i "s:/etc/quake2.conf:${GAMES_SYSCONFDIR}/${PN}.conf:" \
+ sys_linux.c vid_so.c \
+ || die "sed failed"
}
src_compile() {
mkdir -p releasei386-glibc/ref_soft
- make \
+ emake \
GENTOO_CFLAGS="${CFLAGS}" \
GENTOO_DATADIR="${GAMES_DATADIR}"/quake2/baseq2/ \
- build_release || die
+ build_release \
+ || die "emake failed"
}
src_install() {
cd release*
- exeinto ${GAMES_LIBDIR}/${PN}
- doexe gamei386.so ref_softx.so || die
- exeinto ${GAMES_LIBDIR}/${PN}/ctf
- doexe ctf/gamei386.so || die
- newgamesbin quake2 red-blue-quake2 || die
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe gamei386.so ref_softx.so || die "doexe failed"
+ exeinto "$(games_get_libdir)"/${PN}/ctf
+ doexe ctf/gamei386.so || die "doexe failed"
+ newgamesbin quake2 red-blue-quake2 || die "newgamesbin failed"
- dodir ${GAMES_DATADIR}/quake2
-
- insinto ${GAMES_SYSCONFDIR}
- echo ${GAMES_LIBDIR}/${PN} > ${PN}.conf
- doins ${PN}.conf
+ insinto "${GAMES_SYSCONFDIR}"
+ echo "$(games_get_libdir)"/${PN} > ${PN}.conf
+ doins ${PN}.conf || die "doins failed"
prepgamesdirs
}